R_Estrada
Contributor
Contributor

Vsphere 4.1 reconoce como enclosure el vdisk SAN

Hola chicos

Tenia un vi 3.5 u1  y una san HP MSA2012i con 2 vdisk  y storage valido asignado para el host.


Estoy instalando vsphere 4.1 en un nuevo host y conectando la SAN con iscsi software.

Al hacer el rescan reconoce el storage anterior con vmfs 3 correctamente con todo su contenido.

Sin embargo al añadir otro storage nuevo de 500gb, me lo declara como un iscsi enclosure y no como un iscsi disk.  No puedo añadir por lo tanto el storage.  ver el adjunto

Alguien ha tenido este problema.

Gracias por anticipado.

0 Kudos
15 Replies
FerrerDeCouto
Commander
Commander

Hola R_ Estrada:

Revisaría que la asignación de hosts a esa LUN estuviera correcta. ¿Puedes pasarnos capturas?

Un saludo.

José Luis Gómez Ferrer de Couto Founder of PiPo e2H Blog: http://blog.e2h.net Si encuentras que esta o cualquier otra respuesta fue de utilidad, por favor da el voto. Gracias. If you find this or any other answer useful, please consider awarding points. Thank you.
0 Kudos
MauroBonder
Leadership
Leadership

Hola,

Ya hiciste el Rescan !?

*Please, don't forget the awarding points for "helpful" and/or "correct" answers. *Por favor, não esqueça de atribuir os pontos se a resposta foi útil ou resolveu o problema.* Thank you/Obrigado
0 Kudos
R_Estrada
Contributor
Contributor

Si se ha realizado el rescan varias veces.  Incluso se ha vuelto a desactivar todo y vuelto a realizar target.

Reconoce los 2 targets, uno como iscsi vdisk y el otro como iscsi enclosure.

La asignacion del volumen en la san, ha sido similar a la creacion del iscsi disk.

He creado un segundo host. y pasa lo mismo reconoce el iscsi vdisk, pero el nuevo lo declara como iscsi enclosure.

ambos emplean el mismo controller de la msa.  he asignado por el segundo controller con otros puertos.  Resultado similar.

0 Kudos
R_Estrada
Contributor
Contributor

Hola Ferrer gracias por salir a la ayuda.

En principio en la SAN la asignacion al host del volumen es correcto, de hecho tanto el iscsi vdisk como el iscsi enclosure tienen la misma asignacion.

0 Kudos
FerrerDeCouto
Commander
Commander

Hola R_Estrada:

¿Qué número de LUN le estás dando al nuevo vDisk? Si es el cero cámbialo por otro. Comprueba que la cabina detecta los iniciadores iSCSI de los hosts y que le das por las dos controladoras permisos de escritura.

Un saludo.

José Luis Gómez Ferrer de Couto Founder of PiPo e2H Blog: http://blog.e2h.net Si encuentras que esta o cualquier otra respuesta fue de utilidad, por favor da el voto. Gracias. If you find this or any other answer useful, please consider awarding points. Thank you.
0 Kudos
R_Estrada
Contributor
Contributor

Ferrer

Ya he probado lo que me indicas.

He cambiado el numero de la lun, he probado cambiarlo a la segunda controladora.

Mismo resultado el disco previo lo ve como iscsi disk y el nuevo como iscsi enclosure

He destruido el disco varias veces en la san, mismo resultado.  Con el segundo hosta pasa lo mismo.

Necesitas algun printscreen ....

0 Kudos
MauroBonder
Leadership
Leadership

Creaste un VMkernel Port para el iSCSI ? és un Storage iSCSI corecto ?

Perdon, pero és un storage nuevo o el host ya conocia ? Te lo digo esto, porque si no seria bueno dar un "reboot".

encontré un kb que te ayude http://kb.vmware.com/selfservice/microsites/search.do?language=en_US&cmd=displayKC&externalId=101138...

Por favor, não esqueça de atribuir os pontos para resposta "helpful" e ou "correta".

Mauro Bonder - Moderator

*Please, don't forget the awarding points for "helpful" and/or "correct" answers. *Por favor, não esqueça de atribuir os pontos se a resposta foi útil ou resolveu o problema.* Thank you/Obrigado
0 Kudos
FerrerDeCouto
Commander
Commander

Hola R_Estrada:

Hay algo que no me gusta, es que aparazca los vDisks y aparezcan todos con la LUN en none. Haz una cosa, realiza el rescan de los datastore conectándote directamente a un ESX(i) sin pasar por el vCenter y nos cuentas.

Un saludo.

José Luis Gómez Ferrer de Couto Founder of PiPo e2H Blog: http://blog.e2h.net Si encuentras que esta o cualquier otra respuesta fue de utilidad, por favor da el voto. Gracias. If you find this or any other answer useful, please consider awarding points. Thank you.
0 Kudos
R_Estrada
Contributor
Contributor

Ferrer

Perdon por no aclarar el gráfico de la SAN

La SAN tiene 2 vdisk, con 5 volumenes cada uno.

En cada vdisk, 4 volumenes virtuales 4 son para maquinas físicas, y estan funcionando correctamente.

En el RAID1 el quinto volumen san-iscsi es para el host vsphere 4.1.  Y lo reconoce perfectamente como un HP Iscsi disk.  Este fue creado en su momento con vi 3.5 que no tuvo ningun problema en reconocerlo.

En el RAID2 el quinto volumen vm-iscsi tambien es para el host vsphere 4.1, fue creado posteriormente y con la idea de asignarlo a los host.  Mismo procedimiento en la san, asigno al host con el mismo identificador.  Entiendo que a nivel de storage adapter como ya ve al primer storage solamente hago un rescan.  Reconoce el dispositivo nuevo, pero en su defecto lo ve como HP Iscsi Enclosure Svc Dev.

Es la primera vez que me sucede.  Existe manera de cambiar la naturalea del dispositivo de HP Iscsi Enclosure Svc Dev a HP Iscsi disk.

Saludos

0 Kudos
R_Estrada
Contributor
Contributor

Hola Ferrer

El rescan lo empeze inicialmente desde el host mismo.  Como no tenia tiempo para comprobar mas cosas instale el vcenter con el mismo resultado.

0 Kudos
FerrerDeCouto
Commander
Commander

Hola R_Estrada:

Para el ESXi 4.1 debería ser indiferente que las LUNs se hayan creado posteriormente, ya que está viendo las que se crearon para cuando estaba la 3.5 Además, la versión del datastore también da igual, al menos el 4.1 debería ver el almacenamiento sin formato. Una pregunta, ¿el disco que ve como enclosure qué espacio muestra?

Otra cosa, prueba a poner como LUN un número alto, por ejemplo el 20 en vez del 3

Un saludo.

José Luis Gómez Ferrer de Couto Founder of PiPo e2H Blog: http://blog.e2h.net Si encuentras que esta o cualquier otra respuesta fue de utilidad, por favor da el voto. Gracias. If you find this or any other answer useful, please consider awarding points. Thank you.
0 Kudos
R_Estrada
Contributor
Contributor

Hola Ferrero

En la imagen que adjunte veras que el disco que como enclosure vmhba37:C0:L0:T0 no declara capacidad (560 Gb)

En cambio en otro target si que lo identifica bien (esta en un RAID diferent)  vmhba37:C0:L0:T7 iscsi disk capacidad 189 Gb.

Más dudas ..

Me quedaban 50 Gb en el raid del disco que si reconoce, le he probado a crear un disco de 30 Gb y si lo ha reconocido al instante.

El enclosure con LUN 20 no lo ve ....  que estare pasando por alto.

Saludos y muchas gracis por tu tiempo

0 Kudos
FerrerDeCouto
Commander
Commander

Hola R_Estrada:

Es que en las capturas que pusiste de vCenter no aparece la columna de los tamaños, por eso te preguntaba a ver si al menos aparecía el tamaño de la LUN que creabas. De todos modos, haz las siguientes pruebas:

1. Si eliminas la LUN que no ves, ¿sigue apareciendo el enclosure en el vCenter?

2. Si dispones de logs en la cabina comprueba si aparece algún error de conexión

3. ¿Tiene la cabina limitado el número de LUNs a crear?

Un saludo.

José Luis Gómez Ferrer de Couto Founder of PiPo e2H Blog: http://blog.e2h.net Si encuentras que esta o cualquier otra respuesta fue de utilidad, por favor da el voto. Gracias. If you find this or any other answer useful, please consider awarding points. Thank you.
dquintana
Virtuoso
Virtuoso

Hola R_Estrada, como tenes configurada la interfaz de management y las interfaces de ISCSI de tu storage?

Don't forget award points / no olvides puntar las respuestas.

---
Diego Quintana

LinkedIn Twitter WordPress
Ing. Diego Quintana - VMware Communities Moderator - Co Founder & CEO at Wetcom Group - vEXPERT From 2010 to 2020- VCP, VSP, VTSP, VAC - Twitter: @daquintana - Blog: http://www.wetcom.com-blog & http://www.diegoquintana.net - Enjoy the vmware communities !!!

0 Kudos
R_Estrada
Contributor
Contributor

Hola Chicos perdon por no contestar en tanto tiempo.

Las asignaciones e identificadores eran correctos.

Resolvi el tema.  Actualización de FW y SW.

Actualizacion de Firmware de la Cabina en ambas controladoras.  Reconocio al final los elementos para ambas si ningún problemas.  No eran problemas de restricciones de luns, ni el id de la lun.

Actualizacion de parches para iscsi de vmware para el modelo del Servidor.

Funciona como la seda.  Con  redundancia y multipath.

Gracias especiales a Ferrer, por tu ayuda, es el primer caso que me encuentro y me llevaba por el camino de la amargura.

Gracias a todos por vuestras ayudas y sugerencias.

0 Kudos