rafadcp
Enthusiast
Enthusiast

Problemas con CLI 5.5

Buenos días.

Dispongo de un servidor ESXi 5.5 y quiero realizar un backup a través de vSphere CLI 5.5 pero me aparece el siguiente error:

error1.jpg

error2.jpg

He revisado esta web:

http://pcloadletter.co.uk/2010/07/27/vsphere-cli-libeay32-dll-error/

Pero no puedo instalar Crypt-SSLeay 0.57 al parecer por la versión de ppm.

He probado bajo Windows 7 y 2008.

¿Alguna solución?

Gracias de antemano.

0 Kudos
5 Replies
rafadcp
Enthusiast
Enthusiast

Por supuesto que hice esos pasos... pero da el siguiente error:

error3.jpg

Que por lo visto hace falta Business Edition....ridículo tener que pagar otra vez para solucionar un error de un paquete de VMware....Existe solución?

0 Kudos
Borja_Mari
Virtuoso
Virtuoso

Hola,

parece que efectivamente, las versiones de ActivePerl < 5.16 necesitan de la licencia de pago Business Edition para poder bajar paquetes de Perl ...

Y claro, el vCLI 5.5 usa la versión 5.8.8 de ActivePerl ...

La cosa parece que no tiene (fácil) solución.

Puedes probar a instalar el ActivePerl versión 5.16 después de haber instalado el vCLI, pero no te aseguro que te vaya a funcionar.

Un saludo,

Pablo

------------------------------------------------------------------------------------------------- PLEASE CONSIDER AWARDING any HELPFUL or CORRECT reply. Thanks!! Por favor CONSIDERA PREMIAR cualquier respuesta ÚTIL o CORRECTA . ¡¡Muchas gracias!! VCP3, VCP4, VCP5-DCV (VCP550), vExpert 2010, 2014 BLOG: http://communities.vmware.com/blogs/VirtuallyAnITNoob
0 Kudos
rafadcp
Enthusiast
Enthusiast

Tras instalar la versión 5.16 me da el siguiente error:

error4.jpg

Smiley Sad

0 Kudos
Borja_Mari
Virtuoso
Virtuoso

Hola,

parece que solucionar el problema es más sencillo de lo que parece ... Smiley Wink

Primero, haz una instalación en limpio del vCLI 5.5 (des-instala y vuelve a instalar - esperemos que haga una des-instalación "limpia" ... )

Y reinicias el equipo (por aquí comentan que basta con que cierres la sesión del usuario y vuelas a entrar)

Lo de reiniciar el equipo para que no de el error que te da (fíjate que se queja que no encuentra la librería libxmls2.dll, parece que no tiene que ver nada con el crypt-ssleay) ya lo comentan en las release notes (busca por la cadena libxml2.dll):

vSphere Command-Line Interface Release Notes

Espero que esto te solucione tu problema Smiley Happy

Un saludo,

Pablo

------------------------------------------------------------------------------------------------- PLEASE CONSIDER AWARDING any HELPFUL or CORRECT reply. Thanks!! Por favor CONSIDERA PREMIAR cualquier respuesta ÚTIL o CORRECTA . ¡¡Muchas gracias!! VCP3, VCP4, VCP5-DCV (VCP550), vExpert 2010, 2014 BLOG: http://communities.vmware.com/blogs/VirtuallyAnITNoob
0 Kudos
rafadcp
Enthusiast
Enthusiast

Tampoco...

Na he decidido crear una nueva MV pelada para cuando necesite el CLI 5.5

Gracias de todas formas por la ayuda.

Saludos

0 Kudos