joanmv
Contributor
Contributor

Problema al conectar a internet máquinas virtuales con Windos 7 en host

Buenas,

estoy usando VMware Workstation (6.5.1 build-126130) en tres ordenadores, uno con XP, otro con Vista y otro con Win 7. En ningún caso he configurado nada del programa si no que todo está como quedó tras la instalación. Tanto en XP como en Vista, las máquinas virtuales reciben conexión a internet, mientras que las mismas máquina en Win 7 no. He probado desactivando antivirus y Firewall y el problema persiste.

¿Alguna solución?, es un problema grave pues tengo una máquina con el programa de gestión de partes de trabajo de mi empresa y necesita de itnernet para actualizarse.

Muchísimas gracias.

0 Kudos
16 Replies
nsolop
Expert
Expert

hola a las máquinas virtuales les instalaste las VMware tools? la configuración de la red virtual que usan estás máquinas con Windows 7 en que modo están (nat, bridged, etc)?

Saludos/Regards

Nicolas Solop

Buenos Aires, Argentina

-


Mi empresa

Mi perfil en LinkedIn

Grupo de Virtualizacion en español de Linkedin

0 Kudos
joanmv
Contributor
Contributor

Como decía, en todos los SO stán iguales por que yo simplemente me he dedicado a instalar le programa y dejarlo tal como queda y en todos los casos, a excepción de Win 7, funciona.

No he instalado las tools y las máquinas están en NAT, pero lo están sobre Win 7 y sobre los otros dos SO....

Muchas gracias.

0 Kudos
edzava
Enthusiast
Enthusiast

Seguramente es porque tenes dhcp habilitado, bien las vmware tools son los drivers para las máquinas virtuales, seguramente por ahí viene el problema, trata de instalarlos y revisa con el comando ipconfig /all que configuración tiene la placa de red de cada virtual (fijate además que esté conectada en el win7) y cuentenos si estas trabajando en modo bridge o modo nat.

Saludos,

Eduardo

Twitter @eduszavala
0 Kudos
maescutia
Contributor
Contributor

Saludos.

soy nuevo por aqui, a mi me pasaba lo mismo que a ti.

yo lo que hice fue lo siguiente

con el workstation 6.5.1 cerrado

da click en inicio

y escribe en el buscador de inicio "run programs for previous versions"

sigue el wizard y ponle que se ejecute en modo windows xp Sp2

y asunto arreglado

Si hay algo mas en lo que te pueda ayudar.

Miguel

0 Kudos
joanmv
Contributor
Contributor

Gente, sigo igual.He hecho lo de ejcutar el VMware en modo XP SP2 pero sigue sin internet y en cuanto a la rspuesta anterior, me gustaría que me dieses más datos pues soy algo novato en el tema y en muchos casos no sé a que te refieres.

Al otro usuario, decirte que las máquinas están en NAT (pero tb lo están en Vista y XP cuando si conectan), que he ido a instalar las Tools y he visto que la opción era "Reinstall" con lo que deduzco que si estaban instaladas y lo que he hecho ha sido "repararlas" y reiniciar, pero seguimos igual.

0 Kudos
joanmv
Contributor
Contributor

Ayer al hacer ipconfig/all vi que salía DHCP deshabilitado y que en TCP/IP tenía una IP fija. Miré en Win VIsta y ví que allí lo tenía todo en automático, así que lo cambié. Al volver a hacer ipconfig/all veo que ahora DHCP está activado, igual que en Vista, pero sigue sin conectar.

0 Kudos
tomisuka
Contributor
Contributor

hola

si no montas ningun tipo de proxy, u otro servidor dhcp, lo mas facil es poner cada maquina en modo bridget, asi te aseguras que el servidor dchp, en tu caso tu router le asigne direcciones dentro de la red local,

tambien puedes ir hasta el menu edicion, editor de red virtual y checa que el vmnet0 sea tu placa de red fisica,

saludos

0 Kudos
evitish
Contributor
Contributor

Hola, ¿has probado a ejecutar el programa como Administrador? Y no me refiero al acceso directo, sino al vmware.exe que hay en C:\Program Files (x86)\VMware\VMware Workstation.

¡ A mí me funciona!

0 Kudos
Simsim
Contributor
Contributor

Me pasaba lo mismo que al autor del post, tengo windows 7 y en la

maquina virtual que tenia XP no obtenia conexion, y hosteando en

windows Vista si que tenia. La solución que me funcionó fue esta:

puedes ir hasta el menu edit, virtual network editor..., host virtual network mapping, y checa que el vmnet0 sea tu placa de red fisica.

Y ahora hosteo en Windows 7 una maquina XP con conexion a internet sin problemas.

salu2

0 Kudos
Hunted
Contributor
Contributor

Hola a todos! Por más q trato no puedo conectar VMware 7 a Internet... tuve problemas copiando archivos del host a la máquina virtual, pero lo solucioné fraccionando los archivos. Mi host: Wxp SP2; en la máquina virtual tengo W7 Ultimate. He tratado Bridged y los demás. También tengo instaladas las herramientas -aunque muestra error y no instala dos de ellas- Mi conexión a Internet es un modem USB móvil -cada vez q me conecto, me cambia la IPS- Me urge ayuda, mucho lo sabré agradecer. Saludos!!

!

0 Kudos
kailess1
Enthusiast
Enthusiast

Hola a todos

Hablo de memoria y a lo mejor me columpio, pero me parece que la 6.5 no está soportada 'oficialmente' sobre Windows 7 en ninguna de sus versiones.

La 7 creo que ya si. Quizás por ahí vengan parte de tus problemas, yo en tu caso y si me fuese posible me actualizaría, o para descartar probaría la máquina en otro Windows 7 con la versión 7 del Workstation (puedes descargar gratuitamente una versión de evaluación desde esta misma página), en mi caso hize pruebas hace tiempo con la versión 6.5.1 sobre un Windows 7 RC y la verdad es que no funcionaba nada, nada bien, pero bueno como el Windows también era un RC no seguí probando.

Espero que te ayude.

Saludes

0 Kudos
jose_maria_gonz
Virtuoso
Virtuoso

Hola Hunted,

Podrías adjuntar el log: M:\vmw7\vmware.log?

Saludos,

Jose Maria Gonzalez,

Founder and President of JmGVirtualConsulting.com

-


See http://www.JmGVirtualConsulting.com for official Vi3 and vSphere consultancy

See http://www.josemariagonzalez.es for my blog on VMware training and tips

See http://www.twitter.com/jose_m_gonzalez for some twittering

VMware vExpert 2009

Autor del Libro VMware ESX y VMware VCP Hecho Fácil

-


If you find this or any other answer useful please consider awarding points by marking the answer helpful or correct.

<a href="http://feedproxy.google.com/ElBlogDeVirtualizacionEnEspanol">!http://feedproxy.google.com/ElBlogDeVirtualizacionEnEspanol.2.gif!</a>

0 Kudos
Hunted
Contributor
Contributor

José María, muchas gracias por tu interés. No tengo un log como tal, pues no me muestra error, simplemente q no puede conectar a Internet. Trataré de ilustrarlo con imagenes. La primera imagen muestra como inicio la máquina virtual:

La segunda imagen muestra el mensaje que bridged se encuentra temporalmente down:

Y cuando trato de conectarme me aparece esto y no tengo clave ni nombre de usuario para conectarme. Tengo un modem conectado vía USB para Internet móvil tipo: ZTE Mobile Connection Manager. Mucho te agradeceré me guíes en los pasos q debo tomar para hacer posible mi conexión a Internet, pues tener VMware Workstation trabajando me evitaría entre muchos, otra partición a mi disco duro. Debo agregar q uso un Disco duro de 160Gb -60 para "C" y 100 para "D"- y que tengo un disco duro portátil de 1000Gb conectado vía USB, que es donde tengo la máquina virtual q trato de conectar a Internet.

De antemano, muchas gracias y saludos!

0 Kudos
Hunted
Contributor
Contributor

(José María, no me cargó la última imagen, la envio con este segundo mensaje)

Y cuando trato de conectarme me aparece esto y no tengo clave ni nombre de usuario para conectarme.

Tengo un modem conectado vía USB para Internet móvil tipo: ZTE Mobile Connection Manager. Mucho le agradeceré me guíe en los pasos q debo tomar para hacer posible mi conexión a Internet, pues tener VMware Workstation trabajando me evitaría entre muchos, otra partición a mi disco duro. Debo agregar q uso un Disco duro de 160Gb -60 para "C" y 100 para "D"- y que tengo un disco duro portátil de 1000Gb conectado vía USB, que es donde tengo la máquina virtual q trato de conectar a Internet.

De antemano, muchas gracias y saludos!

0 Kudos
ofmoreno
Contributor
Contributor

hola a todos... el problema no es la compatibilidad de VMWare con el Windows 7, la bronca es ke tiene una diferencia contra las otras versiones que consiste en ke como dices, no tienes la tarjeta de red alámbrica o inalámbrica con conexión a una red o la tienes sin una IP, fija o estática, no la detecta... lo ke puedes intentar es en el menú principal del VMWare Workstation en Edit le das Virtual Network Editor, creo ke es... ahi le dirás ke por supuesto con el USB conectado, ke el bridge por defecto no será automático, sino será el USB, espero ke funcione porke no lo he probado, no he conectado un 3G de Telcel en mi PC, desconectando las otras redes y probar... te deseo suerte... sino, pues entonces puedes hacer una conexión de otro tipo... sería nat o host-only, ke consiste en ke si te fijas, el VMWare te instala 2 tarjetas de red con direcciones IP de diferentes subredes... eso si te debe de funcionar porke yo así configuré en una ocasión mi PC host, teniendo virus, no tenía internet a pesar de tener red e IP DHCP... configuré la IP de mi LAN de manera estática pero con IP de mi red y como puerta de enlace puse la IP de la máquina virtual, al mismo tiempo puse el RouterOS de Mikrotik, ke si no lo conoces, pues es un router con su propio sistema operativo ke se llama RouterOS, al router ke si tenía internet directo del infinitum porke si no sabes las virtuales son máquinas independientes del host y pues esa además es linux, le configuré 2 ethernet, 1 con DHCP Server y la otra como DHCP Client, el client como bridge y el server como nat de tal manera ke la virtual recibía el internet y lo pasaba a la red nat haciendo ke el host tuviera conexión desde la virtual... ahora, después de tanto rollo, te digo ke debes hacer lo contrario... debes configurar el host, el usb como el bridge y la virtual le debes de poner ip estática con puerta de enlace de tu máquina... espero funcione... es más o menos lo ke tienes ke hacer, espero haberme dado a entender y no haberte enredado más... mi mail es Maniaco_99@hotmail.com

0 Kudos
tomisuka
Contributor
Contributor

hola saludos,

son dos casos diferentes al inicio unicamente se expuso via cable de red

para el caso del usb

se puede compartir el internet :

1) solo con la maquina virtual,

en nat simplemente funciona, tambien podes puentear la coneccion de la forma compartir la coneccion desde la coneccion del modem (pero vas a tener que eleguir una red) y definir esa red, como la que use el vmware (mucho lio), en nat es el modo mas facil, el vmware lo hace de modo automatico,

2)compartir con otras maquinas fisicas

a) solo internet

te vas a la coneccion del usb en al maquina que tiene conectado el modem y le das conpartir la conneccion y te deja eleguir el adaptador de red que sera el puente, eso en el so que tenga la coneccion a internet, en ese caso la coneccion de cable de red si o si te queda con ip fija en el adaptador de red (lo mas comun es 192.168.0.1 255.255.255.0 porque se necesita un vinculo fisico a donde conectarce), para esa coneccion se puede montar un servidor dhcp en al misma maquina u otra o simplemente completar manualmenten en las otras maquinas (fisicas) en el mismo cable de red, ip mascara gateway, dns, (para el caso de 192.168.0.1 255.255.255.0 en la maquina fisica a la cual le vamos a compartir internet por cable fisico en protocolo tcp/ip o ipver4 quedaria ip 192.168.0.{X=numero de maquina distinto de 1} mascara 255.255.255.0 gateway 192.168.0.1 , dns 192.168.0.1)

en la maquina que tenga internet, (por mas que no lleve conectado aun el cable rj45 deberia aparecer como que esta conectado o un signo de admiracion ) en propiedades aparecera activa y con ip, por lo cual las otras maquinas se podran conectar, via cable de red,

b) compartir internet ademas con la otra maquina fisica en la cual hay instalados maquinas logicas (vmware)

idem a) con la salvedad de poder en el equipo que no tiene el usb, (se conecta por cable) en el vmware eleguir Nat o bridget, es indistinto, porque manualmente ya configuraste su placa de red fisica o lo hizo el dhcp desde la maquina que provee internet

consideraciones a tener en cuenta

  • para la maquina host con internet via modem usb conviene el nat, asi se hace de manera automatica,(para el caso que este sola en la red fisica, sino decidir)

  • para el momento de la coneccion checar los firewalls de los dos puntos siempre y dado el caso reiniciarel equipo que lo requiera

  • los equipos no necesariamente tienen que estar en el mismo grupo de trabajo, solo el mismo rango de ip y mascara

  • para el balance de carga de internet, conviene colocar un proxy-cache como squid en linux o windows (de manera de ahorrar kb transferido y aumentar seguridad)

tambien se puede conectar el usb a una maquina logica vmware y compartir, (en el caso de no tener por ejemplo drivers para el so host y admita el driver usb del vmware) es lo mismo, solo que de dentro hacia afuera lo mas facil, para mi, -&gt; modo bridget en host darle ip fija a la maquina host en la placa de red vmnet0, ip fija a la maquina virtual en el rango que sea necesario (192.168.0.1 ocualquiera) y el procedimiento continua conmo el 2) a) con la salvedad de lo que se llamo host, ahora es virtual y viceversa

saludos

0 Kudos