Warrenjc
Contributor
Contributor

No puedo accesar los los luns desde mis nuevos ESXI

Jump to solution

hola a todos tengo un problema..........

acabo de instalar dos nuevos ESXI en mi granja de servidores ESXI, las zones en los fabric swtches  estan bien configuradas agredagas al zoneset y activas.... agregue mis nuevos dos ESXI al virtual center sin problemas... pero no veo las LUN q tengo configuradas en la SAN.... ya le he dado en el tab de storage Rescan all y tambien en storage adapters pero no veo las luns, no se si me estoy brincando algun paso......

tengo un mensaje en mi ESXI q dice " the VMware ESX server does not have persistent storage" no se si esto tiene algo q ver con mi problema

saludos,

0 Kudos
1 Solution

Accepted Solutions
pcerda
Virtuoso
Virtuoso

Hola que tal,

Primero revisar si la zonificación fue bien realizada o no. 

Luego realizar el LUN Masking, que es basicamente asignar las LUNs a cada host en el Storage.  Si el Storage no puede "ver" a los nuevos hosts entonces debes revisar el Zoning de los fabric. 

Por los pasos que indicas que has realizado, no veo que hayas hecho el LUN Masking, por lo que al hacer el rescan de Datastores en los nuevos hosts, no podrán "ver" las LUNs, por lo que no podrán montarlas.

Saludos,

Regards / Saludos - Patricio Cerda - vExpert 2011 / 2012 / 2013

View solution in original post

0 Kudos
11 Replies
sanmarfe
Expert
Expert

Estimado, deberias incluir algun dato mas del storage ya que cada storage se maneja diferente.

Si entiendo bien necesitas agregar 2 nuevos ESXi al cluster.

Si esto es asi, y el zoning esta bien configurado, debieras ademas, agregar en el storage los nuevos hosts.

Te recomiendo que chequees las zonas ya que deberian ser 1 iniciador - 1 target.

Otra cosa que debes tener en cuenta es el orden de mapeo de las luns existentes, todas las luns deben estar presentadas con el mismo numero de lun para todos los servidores del cluster.

Si nos das mas datos del storage quizas podriamos ayudarte un poco mas.

Con respecto al error es un error normal mientras no tengas ningun datastore asignado a los hosts.

Espero haber sido de ayuda.

Saludos,

S.G.

Sanmarfe. VMware Certified Professional VCP3/VCP4/VCP5 VTSP4 / VTSP5 Si esta u otra respuesta es util, por favor marca su correspondiente notificador. Gracias/Regards
leonhardtla
Expert
Expert

Hola,

La conexión con la cabina es iscsi? Si es así, debes de instalar el controlador por Software desde network adapter desde los Host nuevos, luego configurar la ip y el Puerto de tu cabina.

Tal como comenta el compañero, debes de dar mas datos.

Saludo

----- Leandro Ariel Leonhardt: Virtualized System Architect at GrupoSothis.com. VSAN vExpert 2016, vExpert 2017/16/15/14/13, VMware Certified Instructor, VCAP5-DCA, VCP6/5-DCV, VCA-DCV, Nutanix NPP/NSEN & Nutanix Technology Champions (NTC). | Founder of BlogVMware Blog: https://www.blogvmware.com & Nutanix Course http://vExpert.me/Z0 Si encuentras que esta o cualquier otra respuesta fue de utilidad, por favor da el voto. Gracias. If you find this or any other answer useful, please consider awarding points. Thank you.
0 Kudos
Warrenjc
Contributor
Contributor

bueno la conexion es por fabric channel....

no puedo agregar los storage porque cuando le doy agregar storage y escojo la opcion Disk/lun no me aparece ninguna

0 Kudos
sanmarfe
Expert
Expert

Supuse que las conexiones son de FC ya que hablas de ... " las zones en los fabric swtches"...

Por favor agrega todos los datos que puedas con respecto a los servidores/storage para que tengamos mas herramientas con que ayudarte.

Saludos.

Sanmarfe. VMware Certified Professional VCP3/VCP4/VCP5 VTSP4 / VTSP5 Si esta u otra respuesta es util, por favor marca su correspondiente notificador. Gracias/Regards
0 Kudos
leonhardtla
Expert
Expert

Perdón, se me paso lo del zoning, no me dí cuenta que era de suponer que es FC.

----- Leandro Ariel Leonhardt: Virtualized System Architect at GrupoSothis.com. VSAN vExpert 2016, vExpert 2017/16/15/14/13, VMware Certified Instructor, VCAP5-DCA, VCP6/5-DCV, VCA-DCV, Nutanix NPP/NSEN & Nutanix Technology Champions (NTC). | Founder of BlogVMware Blog: https://www.blogvmware.com & Nutanix Course http://vExpert.me/Z0 Si encuentras que esta o cualquier otra respuesta fue de utilidad, por favor da el voto. Gracias. If you find this or any other answer useful, please consider awarding points. Thank you.
FerrerDeCouto
Commander
Commander

Hola Warrenjc,

Ya te han dado bastantes pistas de por dónde pueden ir los tiros. Intento de nuevo recopilártelas para que compruebes una a una:

  • Comprueba que las HBA están dando link.
  • Revisa de nuevo el zoning y en los alias recuerda no meter el WWN del nodo, sino el de la hba.
  • Si tienes habilitado el control de acceso en tu almacenamiento, tienes que asegurarte que asocias las LUNs a los nuevos hosts.

Según muestras en tu imagen, los hosts no están llegando al almacenamiento.

Un saludo.

José Luis Gómez Ferrer de Couto Founder of PiPo e2H Blog: http://blog.e2h.net Si encuentras que esta o cualquier otra respuesta fue de utilidad, por favor da el voto. Gracias. If you find this or any other answer useful, please consider awarding points. Thank you.
0 Kudos
Warrenjc
Contributor
Contributor

esto es un cluster nuevo ya que el el hardware de estos servidores es muy diff a los de las ya instalados mi SAN  tiene dos SP cada uno con dos puertos fiber SP A INTERFACE        VSAN    FCID          PORT NAME              NODE NAME -------------------------------------------------------------------------------- fc1/1            2    0xcd0100  50:06:01:68:41:e0:d8:7a 50:06:01:60:c1:e0:d8:7a fc1/7            2    0xcd0200  50:06:01:61:41:e0:d8:7a 50:06:01:60:c1:e0:d8:7a segundo SP B INTERFACE        VSAN    FCID          PORT NAME              NODE NAME -------------------------------------------------------------------------------- fc1/1            2    0x030200  50:06:01:60:41:e0:d8:7a 50:06:01:60:c1:e0:d8:7a fc1/7            2    0x030300  50:06:01:69:41:e0:d8:7a 50:06:01:60:c1:e0:d8:7a esta es la configuracion de las zonas primer servidor zone name CACRESXIPROD05_SP_B_SW3 vsan 2     pwwn 50:06:01:68:41:e0:d8:7a     pwwn 21:00:00:24:ff:44:82:dc   zone name CACRESXIPROD05_SP_A_SW3 vsan 2     pwwn 50:06:01:61:41:e0:d8:7a     pwwn 21:00:00:24:ff:44:82:dc   zone name CACRESXIPROD06_SP_B_SW3 vsan 2     pwwn 50:06:01:68:41:e0:d8:7a     pwwn 21:00:00:24:ff:44:83:0e   zone name CACRESXIPROD06_SP_A_SW3 vsan 2     pwwn 50:06:01:61:41:e0:d8:7a     pwwn 21:00:00:24:ff:44:83:0e zoneset activo e incluye todas las zonas segundo servidor zone name CACRESXIPROD05_SP_A vsan 2     pwwn 50:06:01:60:41:e0:d8:7a     pwwn 21:00:00:24:ff:44:82:dd   zone name CACRESXIPROD05_SP_B_SW4 vsan 2     pwwn 50:06:01:69:41:e0:d8:7a     pwwn 21:00:00:24:ff:44:82:dd   zone name CACRESXIPROD06_SP_A_SW4 vsan 2     pwwn 50:06:01:60:41:e0:d8:7a     pwwn 21:00:00:24:ff:44:83:0f   zone name CACRESXIPROD06_SP_B_SW4 vsan 2     pwwn 50:06:01:69:41:e0:d8:7a     pwwn 21:00:00:24:ff:44:83:0f zoneset activo e incluye  todas las zonas no se q otra informacion les puedo brindar  ya son varios los servidores q he agregado y es la primera q tengo este problema gracias por la ayuda

0 Kudos
Warrenjc
Contributor
Contributor

adjunto infor en un txt

saludos

0 Kudos
Warrenjc
Contributor
Contributor

gracias a todos,

me acabo de acordar q  la velociddad de los conectores de mi san son de 4 gigas y la puertos  nuevos de los nuevos servidores son de 8 gigas no si hay alguna restricion con esto

-------------------------------------------------------------------------------
Interface  Vsan   Admin  Admin   Status          SFP    Oper  Oper   Port
                  Mode   Trunk                          Mode  Speed  Channel
                         Mode                                 (Gbps)
-------------------------------------------------------------------------------
fc1/1      2      F      on      up               swl    F       4    --
fc1/2      2      F      on      up               swl    F       4    --
fc1/3      2      F      on      up               swl    F       4    --
fc1/4      2      F      on      up               swl    F       4    --
fc1/5      2      F      on      up               swl    F       4    --
fc1/6      2      F      on      up               swl    F       4    --
fc1/7      2      F      on      up               swl    F       4    --
fc1/8      2      F      on      up               swl    F       4    --
fc1/9      2      F      on      up               swl    F       4    --
fc1/10     2      F      on      up               swl    F       4    --
fc1/11     2      F      on      up               swl    F       4    --
fc1/12     2      F      on      up               swl    F       4    --
fc1/13     2      F      on      up               swl    F       8    --
fc1/14     2      F      on      up               swl    F       8    --
fc1/15     2      F      on      sfpAbsent        --     --           --
fc1/16     2      F      on      sfpAbsent        --     --           --

saludos,

0 Kudos
pcerda
Virtuoso
Virtuoso

Hola que tal,

Primero revisar si la zonificación fue bien realizada o no. 

Luego realizar el LUN Masking, que es basicamente asignar las LUNs a cada host en el Storage.  Si el Storage no puede "ver" a los nuevos hosts entonces debes revisar el Zoning de los fabric. 

Por los pasos que indicas que has realizado, no veo que hayas hecho el LUN Masking, por lo que al hacer el rescan de Datastores en los nuevos hosts, no podrán "ver" las LUNs, por lo que no podrán montarlas.

Saludos,

Regards / Saludos - Patricio Cerda - vExpert 2011 / 2012 / 2013
0 Kudos
Warrenjc
Contributor
Contributor

gracias a todos

correcto tenia q agregar los nuevos ESXI al Storage group en la SAN

saludos,

0 Kudos