MPalacios
Contributor
Contributor

Issue red ESX

Hola a todos. Se ha presentado un problema en mi ambiente ESX. Les cuento un poco:

Tengo 3 ESX v4.1 con 4 nics. En los 3 servidores la red esta configurada de la siguiente forma:

Nic1 Service Console

Nic 2 VM network/service Console

Nic3 vMotion

Nic4 FT

El total de las VMs que alojara este entorno no supera las 13.

4 switches de red Nortel, de los cuales 2 direccionan el trafico hacia el CoreSwitch un cisco 3750.  El segmento donde se ubican todos los servidores incluyendo los ESX es el mismo y se encuentra en una Vlan. 192.168.1.X

Todo parece ir  bien hasta que conectamos los switches nortel hacia el Cisco. Algunos de los servicios como el Web server y un servidor con SQL comienzan a aparecer fuera de linea para usuarios ubicados fuera de la Vlan mencionada 192.168.1.X por ejemplo usuarios en el segmento 192.168.8.X.

Y el problema se agrava cuando hacemos una migracion P2V de los  servidores standalone. Cabe señalar que existe actualmente alrededor de 10 Vlans.

Cuando desconecto el enlace de los switches (nortel/cisco). Los servicios aparecen nuevamente disponibles aunque tienen que reiniciar la conexion del servidor Intranet.

Alguien que haya pasado por algo similar, que habria que afinar??

BR

0 Kudos
12 Replies
Borja_Mari
Virtuoso
Virtuoso

Hola,

yo comprobaría los logs de por ejemplo los switch cisco (show log).

Lo más típico en estos casos suelen ser problemas de spanning-tree o de vtp.

------------------------------------------------------------------------------------------------- PLEASE CONSIDER AWARDING any HELPFUL or CORRECT reply. Thanks!! Por favor CONSIDERA PREMIAR cualquier respuesta ÚTIL o CORRECTA . ¡¡Muchas gracias!! VCP3, VCP4, VCP5-DCV (VCP550), vExpert 2010, 2014 BLOG: http://communities.vmware.com/blogs/VirtuallyAnITNoob
0 Kudos
pcerda
Virtuoso
Virtuoso

Hola,

Como ya dijeron aca, revisa la configuración de tus Switchs, puede ser un problema con Spanning-Tree

Regards / Saludos - Patricio Cerda - vExpert 2011 / 2012 / 2013
0 Kudos
MPalacios
Contributor
Contributor

Hey gracias desde ya por las ideas. Lo del STP en los switches Nortel ya lo descartamos. el STP en los uplink de estos swittches esta activado, de hecho por falta de puertos en el switch Cisco, estamos conectados a traves de un solo cable y en un solo switch por ahora.   La configuracion del Cisco no se ha revisado porque ese dispositivo lo configura un tercero.

Se agradecen todas las ideas. Saludos!

0 Kudos
FerrerDeCouto
Commander
Commander

Buenos días:

Debes comprobar que los puertos que están conectados a los puertos están en modo trunk para tener las diferentes VLANs. No podrás usar VTP ya que es propietario de Cisco y no funciona con Nortel.

Si no tienes bucle alguno también recordarte que cuando conectas un dispositivo a un equipo Cisco siempre tarda al menos 30 segundos en negociar a que velocidad trabajará.

Saludos.

José Luis Gómez Ferrer de Couto Founder of PiPo e2H Blog: http://blog.e2h.net Si encuentras que esta o cualquier otra respuesta fue de utilidad, por favor da el voto. Gracias. If you find this or any other answer useful, please consider awarding points. Thank you.
0 Kudos
MPalacios
Contributor
Contributor

Omiti un detalle, los servicios que tienen problemas al conectar el switch Nortel con el Cisco  (intranet, SQL e impresion) se encuentran en servidores standalone. Como bien comentas, vtp no es configurable en el Nortel, quisiera descartar que el problema esta del lado de los switches nortel, desde mi perspectiva el problema se encuentra en el switch cisco.

Saludos!

0 Kudos
Borja_Mari
Virtuoso
Virtuoso

Hola,

tal como te comenté antes, si te es posible, conectate a los switch cisco y revisa en los logs si aparece algún problema que justifique los cortes de comunicaciones.

------------------------------------------------------------------------------------------------- PLEASE CONSIDER AWARDING any HELPFUL or CORRECT reply. Thanks!! Por favor CONSIDERA PREMIAR cualquier respuesta ÚTIL o CORRECTA . ¡¡Muchas gracias!! VCP3, VCP4, VCP5-DCV (VCP550), vExpert 2010, 2014 BLOG: http://communities.vmware.com/blogs/VirtuallyAnITNoob
FerrerDeCouto
Commander
Commander

Hola,

Si tienes oportunidad haznos un dibujo del diseño de la infraestructura con la interconexión de los switches.

Saludos.

José Luis Gómez Ferrer de Couto Founder of PiPo e2H Blog: http://blog.e2h.net Si encuentras que esta o cualquier otra respuesta fue de utilidad, por favor da el voto. Gracias. If you find this or any other answer useful, please consider awarding points. Thank you.
0 Kudos
MPalacios
Contributor
Contributor

Hola Ferrer, anexo esquema. Para ver a detalle las conexiones del Cisco aun no tenenmos acceso. Agradezco el interes.

Saludos!

0 Kudos
FerrerDeCouto
Commander
Commander

Hola,

Desde un cliente de la 192.168.8.X deja un ping permanente al gateway de la 192.168.1.X y a un equipo de la 192.168.1.X (SIN TENER EL NORTEL CONECTADO). Comprueba que los dos pings a la red 192.168.1.X tanto gateway como dicho cliente es satisfactorio.

Posteriormente conecta el switch Nortel y comprueba si alguno de los dos pings a dejado de responder, todo esta estando únicamente el equipo Nortel conectado, es decir, no conectes ningún ESX(i) al Nortel que gestiona las SC.

¿No tendrás ningún conflicto de direcciones IPs entre alguna VM de los ESX(i) y los servidores standalone?

Saludos.

José Luis Gómez Ferrer de Couto Founder of PiPo e2H Blog: http://blog.e2h.net Si encuentras que esta o cualquier otra respuesta fue de utilidad, por favor da el voto. Gracias. If you find this or any other answer useful, please consider awarding points. Thank you.
MPalacios
Contributor
Contributor

Hola Ferrer, aun no hemos metido a produccion las VMs y no se ha definido direcciones IP en las mismas por lo que el conflicto quedaba descartado. El problema estaba en el Cisco, en la configuracion de los switches Nortel aparecia extrañamente tablas de enrutamiento, ademas de ARP cache del segmento 192.168.8.X.

Hechando un vistazo con el wireshark habia trafico ARP muy constante hacia el Default GAteway 192.168.8.254 por parte de la direccion Mac del switch Nortel, siendo que la configuracion IP de los switches Nortel quedaba definido con direcciones del segmento 192.168.1.X. Esta observacion se la hicimos notar al proveedor que se encarga de la configuracion del switch Cisco.

Misteriosamente al iniciar nuevamene pruebas, el problema parece aclararse. Llevamos ya un buen rato conectados al Core switch Cisco y no hay perdida de paquetes entre segmentos y las tablas y el ARP cache que muestra el Nortel solo hacen mencion al segmento 1 (192.168.1.X). El proveedor de Cisco menciona que el no hizo ningun cambio, pero me parece bastante extraño. A mi me suena a que realizo un cambio de Vlan.

Alguna idea de lo que pudo haber reconfigurado?

Gracias a todos!

0 Kudos
FerrerDeCouto
Commander
Commander

Hola MPalacios:

Si los switches Nortel son L2, el switch orientado a las SCs no debería ver la red 192.168.8.X en su tabla ARP ya que se supone que su puerto de UPLINK con el Cisco estaría en la VLAN nativa de la red 192.168.1.X

¿Los Nortel estaban en L3?

La opción por la que tal vez puedo decantarme más es que el Cisco tuviese Proxy ARP activado, por lo que estaría capturando todas las comunicaciones (incluso las de L2) entre dispositios y haciendo que pasen por él.

Saludos.

José Luis Gómez Ferrer de Couto Founder of PiPo e2H Blog: http://blog.e2h.net Si encuentras que esta o cualquier otra respuesta fue de utilidad, por favor da el voto. Gracias. If you find this or any other answer useful, please consider awarding points. Thank you.
0 Kudos
MPalacios
Contributor
Contributor

Los switches Nortel, son capa 2/3 y con configuracion plana,  y los parametros IP de los mismos quedaron completamente dentro del segmento 192.168.1.X.

Teniamos la intencion de configurar un Etherchannel Nortel-Cisco para balancear la carga y aumentar el Ancho de banda durante las migraciones P2V, ademas de tener redundancia de enlaces. Aunque con este issue que acabamos de pasar, la verdad es que nos la estamos pensando.

Saludos!

0 Kudos