BThunder
Contributor
Contributor

Forzar puerto ethernet a 1000 Full y HBA a 2Gb

Jump to solution

Hola a todos.

El viernes pasado me tocó instalar 2 ESX Server 3.0.2 Upd.1 en sendos HP DL360 G5 con una tarjeta de red adicional HP NC360T en cada uno (4 puertos Gb en total, 2 e1000 y los otros 2 Broadcom), y en uno de ellos también una HBA QLogic.

En el primero, con HBA, todo perfecto, tarjetas de red reconocidas sin problema, negociando a 1000 Full todos los puertos; la HBA reconocida como QLA2432... ¿cómo se puede saber la velocidad a la que sincroniza la HBA? ¿Se puede forzar a los 2Gb que se supone que soporta tanto la HBA como la cabina?

En el segundo, reconocidas sin problema las tarjetas de red, pero por algún motivo que desconozco, uno de los puertos de red sólo sincroniza a 100 Full, no a Gb. Hemos probado a cambiarlo de puerto en el switch físico (Cisco con 24 puertos Gb), pero no hay forma, siempre sincroniza a 100 Full, mientras su "hermano" de tarjeta lo hace a 1000 Full sin problemas.

¿Cuál creéis que podría ser la causa de que no pase de 100FD? ¿Cómo se puede forzar en el propio ESX para que sincronice a 1000FD? ¿Habría que tocar algo en el Cisco (o sería recomendable hacerlo para todos los puertos, no sólo el que falla) pese a que el resto de puertos sincronizan correctamente?

Gracias de antemano por vuestra ayuda.

Saludos.

Héctor

0 Kudos
1 Solution

Accepted Solutions
yuanca
Enthusiast
Enthusiast

Pues vas a tener que reiniciar el servidor, y puslsar CTRL-Q para acceder a los settings de la HBA.

View solution in original post

0 Kudos
8 Replies
BThunder
Contributor
Contributor

Añadir que si desde el ViClient se fuerza a 1000FD ese puerto, directamente se queda en "down", no lo levanta, si lo dejo en Auto, es cuando sincroniza a 100FD.

Saludos.

0 Kudos
Luis_F
Enthusiast
Enthusiast

Prueba a cambiar el latiguillo que va desde el servidor al switch. Prueba a ver si con ese latiguillo y en ese puerto del switch otros dispositivos conectan a giga. Si determinas que es la tarjeta, es que está averiada y deberái reemplazarse. Abre un ticket de soporte en HP

BThunder
Contributor
Contributor

Gracias Luis, ciertamente los más obvio es, a veces, en lo último que uno cae. Fue cambiar el latiguillo de red y todo resuelto, ya sincroniza a 1000FD; quizá no lo pensé en el momento en que falló porque todos los cables eran nuevos, sacados en ese momento de su bolsa... pero vaya, no es excusa 😛

Me queda la duda de la HBA. ¿En el ViClient o desde la propia consola del ESX Server se puede ver la velocidad a la que sincroniza? ¿Se puede modificar algún parámetro para forzarla a los 2Gb que da la cabina o esta configuración sólo se puede cambiar en la BIOS de la propia HBA, en el arranque del servidor?

Gracias y saludos.

Héctor

0 Kudos
Luis_F
Enthusiast
Enthusiast

No sé dónde se puede forzar eso ni si es forzable. Prueba a mirar en la BIOS de la HBA o en el switch de la fabric.

Saludos

0 Kudos
yuanca
Enthusiast
Enthusiast

Yo no cambiaría la velocidad a la que sincroniza la HBA. Si lo quisieras hacer podrías en el switch de Fibra.

Desde la Service Console puedes ver la velocidad a la que están funcionando: esxcfg-nics -l

Name PCI Driver Link Speed Duplex Description

vmnic4 02:03.00 bnx2 Up 1000Mbps Full Broadcom Corporation Broadcom NetXtreme II BCM5706 1000Base-SX

vmnic5 02:04.00 bnx2 Up 1000Mbps Full Broadcom Corporation Broadcom NetXtreme II BCM5706 1000Base-SX

vmnic2 08:00.00 bnx2 Up 1000Mbps Full Broadcom Corporation Broadcom NetXtreme II BCM5708 1000Base-SX

vmnic3 0a:00.00 bnx2 Up 1000Mbps Full Broadcom Corporation Broadcom NetXtreme II BCM5708 1000Base-SX

Con el comando: esxcfg-nics -s puedes forzar la velocidad. Las opciones de esxcfg-nics son las siguientes:

esxcfg-nics <options>

-s|--speed <speed> Set the speed of this NIC to one of 10/100/1000/10000.

Requires a NIC parameter.

-d|--duplex <duplex> Set the duplex of this NIC to one of 'full' or 'half'.

Requires a NIC parameter.

-a|--auto Set speed and duplexity automatically. Requires a NIC parameter.

-l|--list Print the list of NICs and their settings.

-r|--restore Restore the nics configured speed/duplex settings (INTERNAL ONLY)

Un saludo,

Juan Carlos Sánchez

BThunder
Contributor
Contributor

Gracias Juan Carlos. El tema es que el cliente quiere probar el rendimiento con una HBA comparándolo con el acceso iSCSI contra la cabina, por lo que de momento lo único que ha puesto es la HBA QLogic en uno de los ESX y conectada directamente a la conexión FC de la cabina, no existen fabrics intermedios.

Con el comando que me indicas, me muestra todos los vmnics y su velocidad (todos 1000 Full), pero no veo nada de la HBA. En el ViClient, en Storage Adapters, me aparece la HBA (QLA2432) y su WWPN... pero nada más, no puedo ver más información ni modificar nada.

¿Se me escapa algo o sólo se puede reiniciar el servidor y comprobar la configuración en la BIOS de la QLogic?

¡Gracias!

0 Kudos
yuanca
Enthusiast
Enthusiast

Pues vas a tener que reiniciar el servidor, y puslsar CTRL-Q para acceder a los settings de la HBA.

0 Kudos
BThunder
Contributor
Contributor

Hola a todos.

Disculpad esta temporadita de ausencia. Sobre este tema, sé que terminaréis diciéndome lo de "no comment", pues lo que finalmente sucedía era.... ¡tachán! el cliente no había metido en la cabina NetApp la licencia de uso de la conexión FC, por lo que nunca conseguía que le dejase "ver" al ESX que tenía conectado directamente con su HBA.

Y yo rompiéndome la cabeza y dándoos la tabarra a vosotros con el tema (tampoco tenía acceso a la cabina para poder revisarla)... en fin, algo habré aprendido para la próxima vez Smiley Happy

Gracias por vuestra ayuda.

Saludos.

Héctor

0 Kudos