coninpe
Enthusiast
Enthusiast

Error al abrir vSphere Client

Jump to solution

Hola buenas!

Al intentar conectarme con vmware vSphere client al vcenter, me aparece el siguiente mensaje de error.

Captura.JPG

He estado buscando informacion y parece ser que el problema esta en el puerto 443. He intentado abrir el puerto en el equipo (mediante las directivas del firewall) y no hay manera.

Tambien he comprobado, que si pongo mal la contraseña, el error es el mismo.

El equipo es un Windows 7 Professional x64.

a alguien le ha pasado esto?

Gracias de antemano y un saludo!

Leire

0 Kudos
1 Solution

Accepted Solutions
xacolabril
Expert
Expert

Ok, Hemos detectado el problema pues. Los servicios de vCenter no arrancan y por ello que no puedes conectarte desde la consola (no hay nadie escuchando por el puerto 443). El servicio "VMware VirtualCenter Server" debe estar arrancado, así como el resto de servicios relacionados.

Aparece algún evento en el eventvwr?

Como recomandación intenta reinstalar el servicio de vCenter desde los CD's.

Saludos.

Xavier Colomé Abril. VMware Certified Professional VCP3, VCP4 and VCP5. [Si encuentras que esta o cualquier otra respuesta ha sido de utilidad, vótalas. Gracias.] [If you find this or any other information helpful or correct, please consider awarding points. Thank you.]

View solution in original post

0 Kudos
19 Replies
xacolabril
Expert
Expert

Hola. Haz una cosa para descartar que sea un problema de comunicación entre tu equipo y el servidor de vCenter: Instala la consola de vSphere Client en el servidor de vCenter y conéctate desde allí localmente. ¿Te aparece ese mismo mensaje?

Saludos.

Xavier Colomé Abril. VMware Certified Professional VCP3, VCP4 and VCP5. [Si encuentras que esta o cualquier otra respuesta ha sido de utilidad, vótalas. Gracias.] [If you find this or any other information helpful or correct, please consider awarding points. Thank you.]
0 Kudos
MMorana
Enthusiast
Enthusiast

Sino podes desactivar temporalmente el Firewall de Windows y volver a probar.

Saludos.

0 Kudos
coninpe
Enthusiast
Enthusiast

He probado a desactivar el firewall y sigue fallando.

Xacorabril no entiendo donde quieres que pruebe a instalarlo.

Esta es la estructura que tengo instalada. En cada servidor tengo una maquina virtual.

Captura2.JPG

Gracias por las respuestas y un saludo!

Leire

0 Kudos
xacolabril
Expert
Expert

Hola Leire,

   dime si estoy equivocado:

  • Tienes servidor de vCenter. Su IP es la 192.168.0.250
  • Tienes dos hosts: Sus IPs son 192.168.0.110 y 192.168.0.111.
  • Te conectas con vSphere Client desde tu propio terminal de usuario (su IP será otra que no nos has dicho) hacia el vCenter.

En ese caso, lo que te comentaba es instalar el vSphere Client en el servidor de vCenter Server (IP 192.168.0.250) y probar la conexión ahí de forma local.

Quizá es lo que estás haciendo ya, debido a que no me quedó claro desde dónde intentas conectarte con el vSphere Client (si desde tu terminal de usuario o desde el propio servidor de vCenter).

En el caso que ya estés intentando realizar la conexión desde el propio servidor de vCenter, intenta poner en "IP address / Name" de autenticación el literal LOCALHOST.

Ya que veo que utilizas el usuario "Administrador" local del servidor de vCenter, otra prueba que puedes hacer es autenticarte entrando ese mismo usuario pero con el nombre de máquina de vCenter como dominio. Ejemplo:   [NOMBRE_SERVIDOR_VCENTER]\Administrator  y luego poner la contraseña. Que no sea que no es capaz de identificar el usuario administrador local del servidor como usuario local.

Ya nos dirás.

Saludos.

Xavier Colomé Abril. VMware Certified Professional VCP3, VCP4 and VCP5. [Si encuentras que esta o cualquier otra respuesta ha sido de utilidad, vótalas. Gracias.] [If you find this or any other information helpful or correct, please consider awarding points. Thank you.]
0 Kudos
coninpe
Enthusiast
Enthusiast

Efectivamente me conecto desde el propio vcenter.

Acabo de probar todo lo que me has dicho y no hay manera. ni con localhost, ni con el administrador local ni con el administrador de dominio

Por si sirve de algo, en el otro cliente que tengo montada esta misma estructura, si hago un telnet al puerto 443 del vcenter me da respuesta y en este no.

Gracias y un saludo,

Leire

0 Kudos
sanmarfe
Expert
Expert

Hola Leire, buenas tardes.

Disculpa las preguntas pero es dificil diagnosticar sin datos

Otra pregunta el servidor donde esta instalado vcenter es un Win 7?

Nos puedes pasar las versiones de esxi, vcenter y vsphere client que estas utilizando?

Pregunta, puedes fijarte si el servicio de vcenter esta levantado?

Espero que entre todos te podamos ayudar a solucionarlo.

Saludos,

Sanmarfe. VMware Certified Professional VCP3/VCP4/VCP5 VTSP4 / VTSP5 Si esta u otra respuesta es util, por favor marca su correspondiente notificador. Gracias/Regards
0 Kudos
xacolabril
Expert
Expert

En principio todo apunta a que el servicio de VMware vCenter Server está parado... ¿Se puede revisar esto?

Saludos.

Xavier Colomé Abril. VMware Certified Professional VCP3, VCP4 and VCP5. [Si encuentras que esta o cualquier otra respuesta ha sido de utilidad, vótalas. Gracias.] [If you find this or any other information helpful or correct, please consider awarding points. Thank you.]
0 Kudos
coninpe
Enthusiast
Enthusiast

Hola de nuevo,

Estos son los servicios que tengo en el equipo relacionados con vmware.

Captura3.JPG

He intentado arrancar los que estan parados pero en todos los casos me da uno de estos dos errores:

- error 1068: No se puede iniciar el servicio o grupo de dependencia.

- error 1067: El proceso ha terminado de forma inesperada.

He de decir que ha estado funcionando todo perfectamente durante unos 3 años hasta hara un par de meses.

La version de esxi y de todo es la 5.0 y la version de windows es 7 de 64 bits

Un saludo,

Leire

0 Kudos
xacolabril
Expert
Expert

Ok, Hemos detectado el problema pues. Los servicios de vCenter no arrancan y por ello que no puedes conectarte desde la consola (no hay nadie escuchando por el puerto 443). El servicio "VMware VirtualCenter Server" debe estar arrancado, así como el resto de servicios relacionados.

Aparece algún evento en el eventvwr?

Como recomandación intenta reinstalar el servicio de vCenter desde los CD's.

Saludos.

Xavier Colomé Abril. VMware Certified Professional VCP3, VCP4 and VCP5. [Si encuentras que esta o cualquier otra respuesta ha sido de utilidad, vótalas. Gracias.] [If you find this or any other information helpful or correct, please consider awarding points. Thank you.]

View solution in original post

0 Kudos
MMorana
Enthusiast
Enthusiast

quizas no inicie por un problema con el SQL Server, tenes iniciados los servicios de SQL Server?

Saludos.

0 Kudos
coninpe
Enthusiast
Enthusiast

Buenas tardes!

Perdonar por no haber respondido antes pero he estado bastante liada con otros temas....

Bueno, en el visor de sucesos hay un montón de errores de que los servicios no se han podido iniciar, pero no pone porque.

Los servicios de SQL están arrancados.

Encontré los CDs de instalación de otro cliente e intente instalar el vcenter server de nuevo, pero me dice que no es compatible con el sistema operativo.

Este sistema lo instalo una persona que ya no esta en la empresa y no tengo manera de saber como lo hizo.

Podríais pasarme un enlace para descargar vcenter y probar a ver si me lo instala bien?

He intentado buscarlo en la pagina de vmware pero no lo encuentro.

Recordar que la versión de ESXi que tengo es la 5.0 y el equipo es un Windows 7 x64

De nuevo, quiero daros las gracias por todas las respuestas Smiley Wink

Un saludo,

Leire

0 Kudos
e_espinel
Commander
Commander

Hola Leire.

Adjunto link donde puedes obtener el Vcenter Server 5.0, debes tener usuario de my vmware y el producto registrado (en vmware)  para poder bajarlo

VMware vSphere 5: Private Cloud Computing, Server and Data Center Virtualization

Lo mejor seria reinstlar todo desde cero (incluido el sistema operativo)

Adjunto link de las mejores practicas

VMware KB: Installing vCenter Server 5.0 best practices

Enrique Espinel
Senior Technical Support IBM, Lenovo and VMware vSphere.
VMware VSP-SV, VTSP-SV, VTSP-HCI
VMware VTSP 4, VTSP 5.
Please mark my comment as the Correct Answer/Kudos if this solution resolved your problem Thank you.
Пожалуйста, отметьте мой комментарий как "Правильный ответ/Кудос", если это решение решило вашу проблему. Спасибо.
0 Kudos
xacolabril
Expert
Expert

Buenas, el problema está entonces claro. Windows 7 no es compatible con vCenter Server. Puedes comprobarlo:

Observarás que ninguna versión de Windows 7 es compatible.

Saludos.

Xavier Colomé Abril. VMware Certified Professional VCP3, VCP4 and VCP5. [Si encuentras que esta o cualquier otra respuesta ha sido de utilidad, vótalas. Gracias.] [If you find this or any other information helpful or correct, please consider awarding points. Thank you.]
0 Kudos
coninpe
Enthusiast
Enthusiast

Hola a todos!

Buenas noticias... ya he conseguido instalarlo y que funcione!!!

Os cuento un poco....

Buscando informacion del proyecto, recorde que para instalar vCenter en Windows 7 el tecnico tuvo que hacer un "apaño" en el instalador para hacerlo compatible con el sistema.

Me he puesto a buscar informacion por internet y he dado con esto:

How to install vCenter Server and Update Manager 5.0 on Windows 7 64-bit

Bueno, pues despues de todo el rollo para reinstalarlo, ahora me encuentro con un problema de licencias.....

Al entrar en el vcenter, me aparece vacio. He creado el datacenter y al añadir los hosts me encuentro con el siguiente aviso:

Captura.JPG

No he querido continuar no vaya a ser que la lie...

La licencia que queria utilizar es la del cliente y como bien dice ya la tenia instalada antes de todo este lio.

Si continuo con esa licencia, que tendria que hacer para desactivar la antigua? o se desactiva por si sola?

Un saludete!

Leire

xacolabril
Expert
Expert

Buena noticia pues. Finalmente había una "manualidad" para que vCenter funcionase con Windows 7.

El mensaje que te muestra ahora, personalmente pienso que se trata de un mensaje orientado a temas legales. Es decir, te indica que quites la licencia de tu otro vCenter antes de ponerla en este. No creo que la "auto-desasigne" del otro.

Entiendo que tienes dos vCenter Server funcionando?

Saludos

Xavier Colomé Abril. VMware Certified Professional VCP3, VCP4 and VCP5. [Si encuentras que esta o cualquier otra respuesta ha sido de utilidad, vótalas. Gracias.] [If you find this or any other information helpful or correct, please consider awarding points. Thank you.]
0 Kudos
coninpe
Enthusiast
Enthusiast

Me detecta el que estaba instalado antes y que no funcionaba.

Ayer desinstale el vcenter y hoy lo he vuelto a instalar. el equipo sigue siendo el mismo. Ni lo he formateado ni nada.

0 Kudos
xacolabril
Expert
Expert

Si solo existe un vCenter y tienes su licencia, adelante con su inserción. Una vez hecho eso ya podrás gestionar los hosts de manera centralizada.

Ya nos dirás cómo acaba la historia.

Saludos.

Xavier Colomé Abril. VMware Certified Professional VCP3, VCP4 and VCP5. [Si encuentras que esta o cualquier otra respuesta ha sido de utilidad, vótalas. Gracias.] [If you find this or any other information helpful or correct, please consider awarding points. Thank you.]
0 Kudos
coninpe
Enthusiast
Enthusiast

Buenos dias a todos!

El viernes a la tarde volvi a instalar las licencias y parece que todo funciona perfectamente.

Muchas gracias de nuevo por vuestra ayuda!!

Leire

0 Kudos
xacolabril
Expert
Expert

Perfecto. Puedes votar la respuesta correcta o que te han ayudado, para cerrar el caso y valorar nuestros comentarios.

Saludos.

Xavier Colomé Abril. VMware Certified Professional VCP3, VCP4 and VCP5. [Si encuentras que esta o cualquier otra respuesta ha sido de utilidad, vótalas. Gracias.] [If you find this or any other information helpful or correct, please consider awarding points. Thank you.]
0 Kudos