dsoria
Contributor
Contributor

Duda con el performance de mi VM (Network)

Saludos cordiales.


Tengo una máquina virtual con un comportamiento "extraño" en el performance, esto por supuesto lo veo desde mi vSphere Client. Anexo una imagen del comportamiento de red.


La tarjeta de red de la máquina virtual es de tipo E1000

La versión del vCenter Server es la 4.1.0

Mis VM Ware Tools están OK


¿Que puede ocasionar tal comportamiento? justamente en ese momento, el aplicativo en esa VM presenta problemas de red, principalmente se cierran sockets de comunicación.



Agradezco la ayuda.



Saludos Cordiales desde MX



0 Kudos
4 Replies
DanielOprea
Hot Shot
Hot Shot

Buenas dsoria,

A ver, necesito que me des mas información para poderte ayudar.

Que S.O. y que versión tiene el guest ?

Que versión de vmware-tools tiene el guest ??

Pusiste algunos contadores en el S.O. ??

Las tarjetas E1000, son bastante obsoletas, ya que presentan varios errores entre ellas la perdida de paquetes:

VMware KB: The output of esxtop shows dropped receive packets at the virtual switch

Te recomiendo que cambies la tarjeta de red a la version VMXNET3 !

P.D. Te dejo este link donde puedes tener mas info sobre la elección de los adaptadores virtuales:

VMware KB: Choosing a network adapter for your virtual machine

PLEASE CONSIDER AWARDING any HELPFUL or CORRECT answer. Thanks!!

Por favor CONSIDERA PREMIAR cualquier respuesta ÚTIL o CORRECTA. ¡¡Muchas gracias!!

Blog: http://danieloprea.blogspot.com.es/

PLEASE CONSIDER AWARDING any HELPFUL or CORRECT answer. Thanks!! Por favor CONSIDERA PREMIAR cualquier respuesta ÚTIL o CORRECTA. ¡¡Muchas gracias!! Blogs: http://danieloprea.blogspot.com.es/ https://communities.vmware.com/blogs/doprea
leonhardtla
Expert
Expert

Tal como comenta el compañero, deberías de proporcionar mas información.

Seria ideal vmxnet3 puesto que es el mejor driver que hay hasta el momento Smiley Happy

A malas, si por alguna extraña razón no pouedes hacer uso de este driver, podrías añadir una segunda nic virtual a tu VM para un mejor balanceo.

Te aconsejo mirar esxtop del esxi donde corre esa VM, mayúscula V para listar las VM y luego presionas "n" para observar si tu VM dropea paquetes (%DRPTX & %DRPRX)

http://www.yellow-bricks.com/esxtop/

Un saludo.

----- Leandro Ariel Leonhardt: Virtualized System Architect at GrupoSothis.com. VSAN vExpert 2016, vExpert 2017/16/15/14/13, VMware Certified Instructor, VCAP5-DCA, VCP6/5-DCV, VCA-DCV, Nutanix NPP/NSEN & Nutanix Technology Champions (NTC). | Founder of BlogVMware Blog: https://www.blogvmware.com & Nutanix Course http://vExpert.me/Z0 Si encuentras que esta o cualquier otra respuesta fue de utilidad, por favor da el voto. Gracias. If you find this or any other answer useful, please consider awarding points. Thank you.
dsoria
Contributor
Contributor

Mil gracias por la respuesta, en efecto, el guest tiene instalada una versión de SUSE 10 Enterprise, mientras que la versión de las vmtools es la 8.3.12

La grafica que anexo es por tráfico de red? o por perdida de paquetes?

0 Kudos
leonhardtla
Expert
Expert

Lo mas probable es que si cambias a vmxnet te olvides de mas de algún dolor de cabeza Smiley Wink

Esa gráfica es por trafico que además puede conllevar perdida de paquetes.

Un saludo.

----- Leandro Ariel Leonhardt: Virtualized System Architect at GrupoSothis.com. VSAN vExpert 2016, vExpert 2017/16/15/14/13, VMware Certified Instructor, VCAP5-DCA, VCP6/5-DCV, VCA-DCV, Nutanix NPP/NSEN & Nutanix Technology Champions (NTC). | Founder of BlogVMware Blog: https://www.blogvmware.com & Nutanix Course http://vExpert.me/Z0 Si encuentras que esta o cualquier otra respuesta fue de utilidad, por favor da el voto. Gracias. If you find this or any other answer useful, please consider awarding points. Thank you.
0 Kudos