XARCOM
Contributor
Contributor

Al hacer una copia a otro Datastore

El escenario es un ESXi 3.5 U3, y cuando efectúo una copia a otro datastore, obtengo un error en el VMDK de la máquina de windows 2008, las otras 2 máquinas que tengo no hay problema, sólo me da el siguiente error en esta:

Cloning disk '/vmfs/volumes/datastore1/W2008/W2003_1.vmdk'...

Clone: 3% done.Failed to clone disk : Input/output error (327689).

Puede ser que este archivo *.vmdk tenga esté encima de algún sector defectuoso o puede ser que el archivo esté corrupto, por otro lado la máquina funciona correctamente

Alguien sabe debido a que puede ser??

Agradezco de antemano, gracias

Tags (4)
0 Kudos
8 Replies
Samquejo
Commander
Commander

Buenas

Si la máquina funciona correctamente, yo descartaría un error de disco.

Prueba a moverla con svmption.pl desde tu virtualcenter y luego a clonarla, porque mucho mas no te puedo decir con tan poca información (postea un log del pantallazo de error y luego saca la información de la pestaña task & events).

Saludos

Si esta u otra respuesta es util, por favor marca su correspondiente notificador. Gracias/Regards
0 Kudos
kailess1
Enthusiast
Enthusiast

Buenas XARCOM

Podrías darmos más datos de como estás haciendo la copia (la máquina está encendida, apagada.. datastores vmfs, nfs..)

Un saludo

0 Kudos
jose_maria_gonz
Virtuoso
Virtuoso

Hola Xarcom

Estos errores suelen estar provocados por colisiones en la red o por latencias altas. Ya sé que el link que te adjunto no es específico a ESX pero reporta el mismo error.

http://kb.vmware.com/selfservice/viewContent.do?externalId=2116375&sliceId=1

Saludos,

Jose Maria Gonzalez,

-


VMware vExpert 2009

-


If you find this or any other answer useful please consider awarding points by marking the answer helpful or correct.

[http://www.josemariagonzalez.es|http://feedproxy.google.com/ElBlogDeVirtualizacionEnEspanol]

0 Kudos
XARCOM
Contributor
Contributor

Hola Samquejo y Kailess1, gracias por vuestras prontas respuestas:

Os paso información de cómo nos sale este error. Gracias de antemano.

Tenemos un servidor ESXi 3.5 U4. el cuál está fomado por un PIV3.4 Ghz s.775, con 4 Gb RAM, y 2 HDs 500Gb SATA2, con una tarjeta de red independiente Intel PRO 1000 PCI, en él tenemos 2 máquinas virtuales funcionando una para windows 2008 y otra para Ubuntu Server. Las dos máquinas funcionan correctamente, arrancan bien y todo eso, queremos copiar toda la carpeta donde está la máquina de windows 2008, para efectuar una copia de seguridad a otro datastore que está en la misma máquina y si hacemos un SCP o un CP o un vmkfstools -i , me da el error que antes he comentado, la máquina puede estar encendidaal hacer la copia, antes de empezar crea un snapshot automático, os recuerdo el error:

Cloning disk '/vmfs/volumes/datastore1/W2008/W2003_1.vmdk'...

Clone: 3% done.Failed to clone disk : Input/output error (327689).

Y si lo hago desde el infrastructure el error que da es "general fault caused bye the file .../w2003_1.vmdk"

Gracias a todos por vuestra ayuda

0 Kudos
XARCOM
Contributor
Contributor

Hola Jose María, nosotros no efectuamos copia a través de la red, simplemente de un Datastore1 que es un disco SATA2 a un Datastore2 que es otro igual. No creo que tenga nada que ver, y sólo me pasa con esa máquina, con la de ubuntu (donde tengo el correo) no me pasa.

Si me equivoco dímelo

Gracias por tu ayuda.

0 Kudos
Samquejo
Commander
Commander

Buenas

Debo entender que usas un ESXi sin VC.

Tambien debo entender que clonas la máquina encendida y que tienes un backup por si acaso.

Trata de realizar eso mismo con svmotion.pl desde tu equipo (es un componente de rcli). Lo que va a hacer es crearte una snapshot del disco con los movimientos (hazlo en un momento valle para no tener a la máquina escribiendo deltas constantemente) que luego consolidará una vez copie toda la máquina.

Si te es posible apagarla, haz un simple cp origen/MV/* destino/MV/* y registras de nuevo en el destino.

Saludos

Si esta u otra respuesta es util, por favor marca su correspondiente notificador. Gracias/Regards
jose_maria_gonz
Virtuoso
Virtuoso

Perdona Xarcom, llevas razón. Hay veces que ya no se no lo que digo Smiley Sad

En todo caso, entiendo que los datastores están en usa SAN, verdad?

Saludos,

Jose Maria Gonzalez,

-


http://www.JmGVirtualConsulting.com

http://www.josemariagonzalez.es

VMware vExpert 2009

-


If you find this or any other answer useful please consider awarding points by marking the answer helpful or correct.

[http://www.josemariagonzalez.es|http://feedproxy.google.com/ElBlogDeVirtualizacionEnEspanol]

0 Kudos
XARCOM
Contributor
Contributor

Gracias a todos, el problema lo tenía en que la controladora de la máquina física estaba rota.

Gracias por vuestro apoyo.

0 Kudos