VMware Support Community
arbyfourohfive
Contributor
Contributor
Jump to solution

SHD 4.0 -> 4.0.1 Update not being initiated

Trying to update SHD from 4.0 to 4.0.1 but can't seem to be able to initiate the update/patch process. I have downloaded the patch via the "Download Updates" option in the tool, verified the manifest/patch files are present, and verified their SHA1 is correct as well. /opt/vmware-shd/vmware-shd/log/vmware-shd-update.log doesn't indicate that it is aware that a patch has been downloaded. I have restarted the vmware-shd service as well as rebooted the appliance with no avail. Any ideas to get this patch update process to initiate? 

Thanks

Reply
0 Kudos
1 Solution

Accepted Solutions
anshumansingh
VMware Employee
VMware Employee
Jump to solution

Hi @arbyfourohfive , @Penobscot , @PetrMai 

Can you please try the below step and let us know if the upgrade from 4.0.0 -> 4.0.1 works afterward, you can run the following copy command and restart the service. 


cp /opt/vmware-shd/vmware-shd/app/apiserver/common/updater.so /opt/vmware-shd/vmware-shd/app/apiserver/

View solution in original post

7 Replies
PetrMai
Contributor
Contributor
Jump to solution

Hello,

I´am also not able to upgrade 4.0.0 (previously upgraded from 3.5.2) to 4.0.1.
I tried online and offline method but both ends with 4.0.0 after the appliance was restarted.

In the update log there is no error.

Reply
0 Kudos
Penobscot
Enthusiast
Enthusiast
Jump to solution

Same problem here.

Reply
0 Kudos
anshumansingh
VMware Employee
VMware Employee
Jump to solution

Hi @arbyfourohfive , @Penobscot , @PetrMai 

Can you please share SHD support log bundle for further analysis, you can collect the SHD log bundle from SHD client UI directly by 
Settings -> Help & Support -> Support Bundle.

Reply
0 Kudos
anshumansingh
VMware Employee
VMware Employee
Jump to solution

Hi @arbyfourohfive , @Penobscot , @PetrMai 

Can you please try the below step and let us know if the upgrade from 4.0.0 -> 4.0.1 works afterward, you can run the following copy command and restart the service. 


cp /opt/vmware-shd/vmware-shd/app/apiserver/common/updater.so /opt/vmware-shd/vmware-shd/app/apiserver/

Penobscot
Enthusiast
Enthusiast
Jump to solution

Penobscot_0-1695641477629.png

 

anshumansingh
VMware Employee
VMware Employee
Jump to solution

Thanks @Penobscot  for the quick confirmation on WA for upgrade from 4.0.0 -> 4.0.1 

Reply
0 Kudos
arbyfourohfive
Contributor
Contributor
Jump to solution

This worked for me as well -- thank you !

arbyfourohfive_0-1695654879589.png

 

Reply
0 Kudos