John_Xiong
Contributor
Contributor

After change IP in Photon OS , the SHD use both new IP & old IP

Jump to solution

Hi 

I have deployed a SHD(2.0.4) with static IP, as network plan adjust, I change IP in Photon . After change I can access SHD with old and new IP at the same time . but ip addr output isn't list the old IP.

I tried uninstall SHD and install SHD again, reboot vm. still have this issue

eth0.pngip addr.pnglod ip.pngnewip.png

0 Kudos
1 Solution

Accepted Solutions
ksram
VMware Employee
VMware Employee

Thanks for the update. I don't see the attachment in you post. 

One question: Did you restart the network services (systemctl restart systemd-networkd) post changing the configuration file?

Thanks

-Ram

 

View solution in original post

0 Kudos
6 Replies
ksram
VMware Employee
VMware Employee

Hi John,

SHD doesn't directly manage the network/listening interfaces. Webserver (nginx) configuration does not explicitly specify the IP address to bind.

Can you please check if there is a possibility of having duplicate appliances running SHD? If you have a client workstation on same netwrok, you can verify neighbor table to validate the MAC address for both of these address

--Thanks

Ram

0 Kudos
John_Xiong
Contributor
Contributor

Hi Ksram

I am sure there is no duplicate appliances running SHD, cause when I power off the VMs, both IP can not access.  
After power off VM for 12 hours then power on the appliance, The old IP can not access. the issue disappears.I create a appliation running SHD and try to reproduce the issue. it happened again.
My environment vCenter 17137327 ESXi 17167734 SHD 2.0.4

Thanks.

0 Kudos
ksram
VMware Employee
VMware Employee

Thanks for the update. I tested this with following workflow

  1. Deploy VM and install Photon
  2. Install SHD
  3. Test the SHD UI
  4. Change the network configuration via updating the file: /etc/systemd/network/99-dhcp-en.network
  5. Restart network by running: systemctl restart systemd-networkd
  6. Restart nginx and vmware-shd services (systemctl restart vmware-shd;systemctl restart nginx)
  7. Test the SHD UI with old IP address
  8. Test the SHD UI with new IP address

At step 7 I was not able to reach the UI via browser, At step 8 as expected UI was accessible using new IP address.

I don't see any persistence of old IP post restart of the network service. I fact reboot has the same effect as restarting the service so we should not be able to access the VM with old IP address. 

If some sort of caching to be in play here, you can test it by accessing the UI on a different machine post change of IP address/restart. 

 

-Thanks

Ram

0 Kudos
John_Xiong
Contributor
Contributor

Hi Ksram,

Thank you very much for your help. I re-tested it over the weekend. Here are the steps and video of my test
Attached is a video of my test(created a new switch without uplink)
install SHD .auto partition/ set static address/ set hostname /enable ssh for root user
attachment is video for this issue

0 Kudos
ksram
VMware Employee
VMware Employee

Thanks for the update. I don't see the attachment in you post. 

One question: Did you restart the network services (systemctl restart systemd-networkd) post changing the configuration file?

Thanks

-Ram

 

View solution in original post

0 Kudos
John_Xiong
Contributor
Contributor

Hi Ksram,

Thanks a lot and sorry for late replay as I was so busy last week. Yes I have restart network service.
It seems that   issue not happened every times and does not affect the function. I decided to ignore this thing.
Thanks for your great help again.

0 Kudos