Highlighted
Contributor
Contributor

Cannot add vCenter Server to Skyline 2.5.0 - Couldn't login the client. -> General failure. -> Unexpected status code: 503

Hi All,

I'm trying to add a new vCenter to Skyline, but am receiving the following error.

skyline_error.png

Both Skyline (2.5.0) and vCenter (6.7.0.44000 Build 16046470) are brand new, fresh deployments.

I've tried rebooting both and using different vCenter user accounts, but it all results in the same error. I can login to vCenter manually without any issue at all.

Any assistance would be appreciated.

0 Kudos
4 Replies
Highlighted
VMware Employee
VMware Employee

@linxandrewmoore

Welcome to Skyline Communities!

Would request to validate the below so that we can add the vCenter.

a) Are we using an external PSC?

If so, toggle the ‘Use Custom SSO’ button and enter the PSC Host Address. You don’t have to complete the ‘Advanced Options’ fields as the domain is the default (vSphere.local).

b) Are we able to reach (ping) vCenter FQDN from Skyline collector and is vCenter FQDN resolvable from Skyline Collector?

c) Please ensure the Port 443 is open from Skyline Collector to vCenter Server. We can use the below command to validate. curl -v telnet://<ip address/fqdn>:443

d) Are we able to login to the vSphere web client with the same ‘Username’ which is being used to add the vCenter?

e) Validate that there is no time sync issue between vCenter Server and Skyline Collector.

VMware Skyline Collector User Guide

https://docs.vmware.com/en/VMware-Skyline-Collector/2.5/GUID-0BA69B94-8DA0-446D-B77E-E7A8AEC95066-1-...

Sincerely Srikanth HS Skyline Support Moderator
0 Kudos
Highlighted
Contributor
Contributor

Hi, thanks for the reply. Answers to your suggestions below.

a) No, it's an embedded PSC.

b) Yes, I can ping the vCenter and resolve both forward and reverse DNS from the Skyline collector.

c) Yes, the curl command succeeds.

root@skyline [ ~ ]# curl -v telnet://192.168.202.203:443

* Rebuilt URL to: telnet://192.168.202.203:443/

*  Trying 192.168.202.203...

* TCP_NODELAY set

* Connected to 192.168.202.203 (192.168.202.203) port 443 (#0)

d) I can manually login to the vSphere web client successfully with the Skyline service account. I have also tried authenticating Skyline with the Administrator@vsphere.local account, but that still results in the 503.

e) vCenter and Skyline are syncing from the same NTP server. I have verified that the time is exactly the same on both.

Please let me know if there's anything else you need.

0 Kudos
Highlighted
VMware Employee
VMware Employee

@linxandrewmoore,

Thank you for the information. Please share your contact details in the below link so that we can connect to work further

https://app.smartsheet.com/b/form/9e31b64730f2419ba2aa50f6c72e66a3

Sincerely Srikanth HS Skyline Support Moderator
0 Kudos
Highlighted
VMware Employee
VMware Employee

@linxandrewmoore,

Thank you for the information. Please share your contact details in the below link so that we can connect to work further

https://app.smartsheet.com/b/form/9e31b64730f2419ba2aa50f6c72e66a3

Hi linxandrewmoore​,

We haven't received a response on the above Smartsheet link. We'll need that information to check our backend and help you resolve this issue.

Please let us know if you're still facing this issue. We'll be more than happy to help.

linxandrewmoore

Thanks and regards, Edwin Fernandez Manager, Skyline Support
0 Kudos