dinakeano
Contributor
Contributor

SRM plug-in 6.5 in vRO 7.4

I'm trying to configure SRM local sites. But I get the error : "URL of the local Platform Services Controller is not valid".

I have 2vCenter with 2 external PSC's and my 2 Vcenters are configured in vRO.

Do I have to code something extra in the workflow script (Configure Local Sites) : SrmUrls = SRMPluginConfig.getSrmUrls();

I have also tried it with SRMPluginConfig.registerLocalSites('<hostname PSC>',443,'https://<PSC>/lookupservice/sdk',<admin>,<passwd>) but than I get the error :

"There is syntax error in SRM configuration for PSC"

The vRO is embedded in the vRA 7.4

With Library > SRM > Configuration Workflow=Configure Local Sites , I get the error :

[2018-07-05 13:21:40.844] [E] Error in (Workflow:Configure Local Sites / Get SRM Urls (item1)#1) URI of the local Platform Services Controller is not valid

[2018-07-05 13:21:40.888] [E] Workflow execution stack:

***

item: 'Configure Local Sites/item1', state: 'failed', business state: 'null', exception: 'URI of the local Platform Services Controller is not valid (Workflow:Configure Local Sites / Get SRM Urls (item1)#1)'

workflow: 'Configure Local Sites' (5dedb8cb-5f1f-415f-b534-c59e5f211aa2)

|  'attribute': name=SrmUrls type=Array/string value=__NULL__

|  'attribute': name=UrlError type=string value=

|  'attribute': name=errorCode type=string value=

|  'input': name=IgnoreWarnings type=boolean value=false

|  'no outputs'

*** End of execution stack.

0 Kudos
0 Replies