VMware Cloud Community
MICDROP
Enthusiast
Enthusiast

SRM page shows internal error message.

Hi, all.

I'm using SRM 8.2 and configuration was completely finished.

However, often when I log in to web UI, SRM page can't load information with below error messages.

1. site recovery manager [com.ctc.wstx.exc.WstxLazyException] Read timed out

2. Failed to retrieve pairs from extension server at https://m02srm02a:443/drserver/vcdr/vmomi/sdk.Failed to connect to Site Recovery Manager Server at https://m02srm02a:443/drserver/vcdr/vmomi/sdk. Reason: https://m02srm02a:443/drserver/vcdr/vmomi/sdk invocation failed with "java.net.SocketTimeoutException: Read timed out"

  

Refreshing multiple times displays the SRM page, but this is not correct.

What can I do?

Regards.

Reply
0 Kudos
5 Replies
ashilkrishnan
VMware Employee
VMware Employee

Hi

I would suggest checking the following:

1. Login to SRM from one of the sites using it's IP address (https://SRMIPaddr/dr) and check if both sites are connected

2. Perform the same task from 2nd SRM server

3. Try reconnect/reconfigure site pairing to see if that gets the sites connected

4. If UI still reports errors are still reported, you might want to check the SRM client logs:

SRM appliance: /var/log/vmware/srm-client/dr.log

SRM Windows: C:\ProgramData\VMware\VMware SRM\runtime\logs\dr.log

Reply
0 Kudos
MICDROP
Enthusiast
Enthusiast

Thanks for  your reply.

Sites are connected .

Retrieve properties failed for ManagedObjectReference: type = AuthorizationManager, value = AuthorizationManager, serverGuid = 7226bf07-f23d-4d41-af56-8f6c4c6acadb.
Failed to connect to vCenter Server at https://m02vc02.cloud.aos.local:443/sdk. Reason: https://m02vc02.cloud.aos.local:443/sdk invocation failed with "java.net.SocketTimeoutException: Read timed out" Read timed out

I also saw the error message above.

Additional, I reinstalled the entire SRM server. but the same error message occurs even after reinstallation...……………..

Reply
0 Kudos
ashilkrishnan
VMware Employee
VMware Employee

This could be a port connectivity issue or caused due to stale service registrations

1. Check if SRM can connect to both vCenter servers on port 443

2. On vCenter run these commands to check if there are duplicate service registrations for SRM servers:

/usr/lib/vmidentity/tools/scripts/lstool.py list --url http://localhost:7080/lookupservice/sdk --type vcDr

/usr/lib/vmidentity/tools/scripts/lstool.py list --url http://localhost:7080/lookupservice/sdk --type vrUi

Ensure these commands list just one IP/FQDN for each SRM server. If there are more than one, we need to un-register them.

Reply
0 Kudos
ymurcia
VMware Employee
VMware Employee

Hello, did you solve this issue?, Can you please tell me how you solved it?

Reply
0 Kudos
Quang-TT
Contributor
Contributor

How can do Sites are connected ?

Reply
0 Kudos