ncentech
Enthusiast
Enthusiast

SRM in NetApp

Jump to solution

Hi all, I am getting ready to setup SRM in a 3.5 U 3 and V.C. 2.5 Environment and I would just like to know what I would need to do in order to prep the NetApp SANs FAS3070 and FAS270. I mean igroup configurations, Volumes, Aggregates, de-duplication, etc... If anyone can point me in the right direction I will greatly appreciate it. The only document I found was the administration guide, does anyoby have any documenets from NetApp that might shed some light on my inquiry.

Thanks

0 Kudos
1 Solution

Accepted Solutions
HyperViZor
Enthusiast
Enthusiast

Hi,

you may want to have a look into this document published by VMware:

if you would like to do this first on a PC with VMware workstation, then you can use this guide:

Hany Michael

HyperViZor.com | Virtualization, and everything around it

Hany Michael
HyperViZor.com | The Deep Core of The Phenomena

View solution in original post

0 Kudos
4 Replies
HyperViZor
Enthusiast
Enthusiast

Hi,

you may want to have a look into this document published by VMware:

if you would like to do this first on a PC with VMware workstation, then you can use this guide:

Hany Michael

HyperViZor.com | Virtualization, and everything around it

Hany Michael
HyperViZor.com | The Deep Core of The Phenomena

View solution in original post

0 Kudos
dergin
Contributor
Contributor

Hi,

I have recently implemented SRM over 2 production sites on FAS 2050S. I am not entirely sure about the SAN configurations apart from that our Netapp guys configured some volumes with VMware type and snapshot scheduling etc. (sorry not a SUN expert).

But there are a few issues you need to be careful of on ESX and SRM;

1- SRM 1.0.0 (pre U1) is not supported on ESX 3.5 U3 (or even on U2) and VC 2.5 U2.

2- SRM 1.0 U1 latest release has ESX 3.5 U3 support but it has a problem with NetApp therefore VMware is recommending customers with NetApp not to upgrade to U1. (KB 1008068)

As you are on ESX 3.5 U3 even though you install SRM 1.0.0 pre U1 you will be on an unsuported platform. So you are pretty much stuck in a rock and a hard place unless you can downgrade your ESX to U1 ( I dont think you would be able to do that unless you have recently installed ESX)

I have managed to get SRM 1.0.0 working on ESX 3.5 U3 though (unfortunatelly I did not have much option) but there are a few things you need to look out for:

- I have observed that if you configure the recovery plan with auto network adapter during the "test mode" SRM crashes. I suggest you create a manual isolated network on your recovery site and configure the recovery plan connect to the isolated network on "recovery mode".

- Ensure that your LUNs have at least 20% free space.

- When running the recovery plan on "test mode" it doesnt always attach the VMs on the recovery site to isolated network (half of them just stay attached to their mapped networks).

- If you have set up DRS rules on the recovery site while running the recovery plan it simply deletes them so you would have to set them up after recovering the VMs on the recovery site.

Apart from above issues I come across you can indeed get it working. I guess due to the above issues (and maybe a few more I did not observed) VMware simply says SRM 1.0 is not supported on ESX 3.5 U2 and U3.

Apearently you got 50% chance that SRM 1.0 U1 may work on Netapp so if you have the luxury you might just have a go and downgrade if it doesnt work. with U1 basically you can not configure the arrays as it simply does not detect he replicated arrays.

Hope this helps.

ncentech
Enthusiast
Enthusiast

that is exactly want I wanted. Thank you very much HyperVizor.

0 Kudos
HyperViZor
Enthusiast
Enthusiast

You are most welcome.

Hany Michael

HyperViZor.com | Virtualization, and everything around it

Hany Michael
HyperViZor.com | The Deep Core of The Phenomena
0 Kudos