cef2lion
Contributor
Contributor

SRM discovery LUN issue

We are setting up SRM with a Dell AX4/5. I have SRM loaded on both sides with EMC SRA. Dell setup the mirror. The ESX hosts can see the mirrored LUNs from the primary side but when I scan the fiber channel the ESX host thinks the LUNs are empty and wants to format them.

Craig

0 Kudos
6 Replies
udaykumar-blr
Contributor
Contributor

Hi,

Did you change these settings in ESX Advanced settings..

Go to Advanced Options ...>>> LVM ... >>>and change these values to 0

LVM.Disallowsnapshotlun=0

LVM.enableresignature=0

After these changes rescan the esx servers. It should work.

Note: Mnay times chnaging the value of - LVM.enableresignature=0 , is not required..

It works without that too. You can use this as a last option along with disallowsnapshotlun.

--Uday

0 Kudos
cef2lion
Contributor
Contributor

I had a talk with a VMware person on this. They thought that the luns being seen but as raw sounded normal on the failover side. We are using an EMC SAN. The SRA has a tool called MirrorView Insight. I ran that tool on our SRM server that has the EMC SRA installed. It seems to be showing some Mirror issue with a few of our luns. We had the mirrors setup for us. I'm currently reviewing things to see if there is some design or config issue with the luns.

On the protected side I have a Storage Group for each ESX host on that SAN. But on the Recovery side I use just one strorage group for all ESX hosts on the recovery side. I'm thinking having one storage group is what I should be doing. Wondering if this could contribute to my issues? Since the protected sight is in production collapsing the storage groups on the protected side will take some time.

Craig

0 Kudos
Itzikr
Enthusiast
Enthusiast

Hi,

attached is the CLARiiON SRM guide..please make sure whoever set it up followed the instructions..mainly to the way the test recovery luns should be named..

Itzik Reich

Solutions Architect

VCI, VCP,VTSP,MCTS,MCITP,MCSE,CCA,CCNA

EMC²

where Information Lives

If you find this information useful, please award points for "correct" or "helpful".

Itzik Reich
cef2lion
Contributor
Contributor

Thanks for the guide. I did have the guide and have been going over it.

I have been running the EMC SRA Insight tool. We have 5 luns that setup in a mirror from the A to B SAN. In Navi Manger they show that they are in sync. The Insight tool only sees on LUN of the 5 and its data store to the ESX hosts. Not sure why the Insight tool only shows one of 5. SRM array manager setup confirms what the Insight tool is seeing. The mirrow was setup by Dell.

Craig

0 Kudos
Michelle_Laveri
Virtuoso
Virtuoso

The other 4 LUNs do have VMFS on them - and populated with virtual machines?

Regards

Mike Laverick

RTFM Education

http://www.rtfm-ed.co.uk

Author of the SRM Book:http://stores.lulu.com/rtfm

Free PDF or at-cost Hard Copy

Regards Michelle Laverick @m_laverick http://www.michellelaverick.com
0 Kudos
cef2lion
Contributor
Contributor

That is what is odd. All 5 luns have VMFS on them with vms from our protected site. Only the third lun is being seen by the EMC SRA Insight tool and SRM. We do have a storage group per ESX host on the protected sight. On the recovery sight I used just one storage group. Not thinking that should be the issue. The mirroring looks ok and says all luns are in sync.

Craig

0 Kudos