Highlighted
Contributor
Contributor

SRM and IBM DS3500

Hello everyone,

We currently have 2 sites that  we have (at each site) 2 IBM x3650 M3 vSphere4.1 attached to an IBM  DS3524 SAS Bay, an IBM x3550 M3 server vCenter.

Bay DS3524 Site #1 replicates the bay DS3524 Site #2 by ERM (Enhanced Remote Mirroring) fiber.

We want to automate the switch between the two sites with SRM.

According to document our srm_storage_partners.pdf DS3524 is compatible with SRM

Before investing in the product, I'm doing tests with SRM.
I installed SRM on my two servers vCenter and I set the connection between the two.
I then setting the option "Array Managers" on the first screen I set the options of the DS3524 array of Production:

M1.3.jpg

Then on the next screen, the options in the Bay DS3524 Backup:

M1.4.jpg

My problem is that the next screen I have nothing.

I'm doing "Rescan Arrays" I have nothing that appears.

M1.5.jpg

Could someone help me?

thank you in advance

0 Kudos
21 Replies
Highlighted
Hot Shot
Hot Shot

I recall there was problem with SRM and IBM DS storage if you use the same LUN id on both the storage, in this case seems that SRM is unable to resolve the array since "confuse" the LUN id of both the storage.

If it is possible I would try to give th backup storage a different LUN id and retry.

Alex

0 Kudos
Highlighted
Enthusiast
Enthusiast

Hi,

Did u check your storage array with VMware Hardware compatibility List? As per my understanding, u are working with SAS storage. I think IBM FC Storage only compatible with SRM server.

Thanks,

0 Kudos
Highlighted
Commander
Commander

i agree with Alex, the two entries should be different to avoid any confusion at the storage level.

also make sure that storage replication is taking place properly between the two arrays

If U find my answer useful, feel free to give points by clicking Helpful or Correct. Subscribe yourself at walkonblock.com
0 Kudos
Highlighted
Contributor
Contributor

thank you for answers.
I'll try to change the ID on the backup

0 Kudos
Highlighted
Commander
Commander

ur welcome..dont forget to makr points in case if you found it helpful Smiley Happy

If U find my answer useful, feel free to give points by clicking Helpful or Correct. Subscribe yourself at walkonblock.com
0 Kudos
Highlighted
Enthusiast
Enthusiast

Have you managed to sort out the issue? In my case we use SAS host connectivity but FC replication.

0 Kudos
Highlighted
Hot Shot
Hot Shot

Hi Bisti,

can you give me a little bit more info? I suspect (since you says you got the same issue) that even in your case you got 2 storage with same lun id and when you add the secondary storage the DR lun is not visible...is it correct?

Alex

0 Kudos
Highlighted
Enthusiast
Enthusiast

Nope, but thanks for idea anway. The problem as mentioned by vijayagce was that we used SAS for host connectivity. When switched to FC everything was fine.

0 Kudos
Highlighted
Contributor
Contributor

Hi,

can you please tell me which version of SRA did you use and on what version of Windows did you install SRM?

Because I'm having some troubles with this storage. Thanks.

0 Kudos
Highlighted
Enthusiast
Enthusiast

I think it was version 01.01.35.06 and Windows 2008 R2 Standard (64-bit EN). What is the issue?

0 Kudos
Highlighted
Contributor
Contributor

Hi,

SRA SMSRAInstaller-WS32-01.01.35.06 and Windows 2008 R2

we switched to the fiber channel and since everything works.

SAS does not work

0 Kudos
Highlighted
Contributor
Contributor

When I try to install this SRA on the Win2008R2 I get error - "Unsupported system configuration" from the SRA installer and the installation failed.

I've tried to "hack" this and run the installer in compatibility mode Win2003 and the installation was successfully completed, but I cannot see any replicated datastore in SRM array manager. I get this:

SRA.PNG

Did you face this kind of issue too?

0 Kudos
Highlighted
Enthusiast
Enthusiast

How do you connect ESXi hostts to your storage array? SAS / FC / iSCSI?

0 Kudos
Highlighted
Contributor
Contributor

All hosts and mirroring are on FC.

0 Kudos
Highlighted
Enthusiast
Enthusiast

Hi,

We have worked with SRM4.0 on Windows 2003 Server 32 bit and IBM SRA  32bit version which is you are using..

Thanks,

Vijaya

0 Kudos
Highlighted
Contributor
Contributor

My current configuration is:

- 2x vCenter 5 (Win2008R2)

- 2x SRM 4.1.2 (Win2008R2) with SRA SMSRAInstaller-WS32-01.01.35.06

- 2x DS3524

0 Kudos
Highlighted
Enthusiast
Enthusiast

Have you tried doing the configuration from the other site? Maybe you mixed up sites Smiley Happy? Or do you have two way replication? And what is the replication status on the storage array?

0 Kudos
Highlighted
Contributor
Contributor

Well I did not try to configure it from the other side, I can try that, but I think I didn't mixed the sides.

I have just one way replication PRIMARY --> RECOVERY and it is fully synchonized now. Does SMR require synchonized replication or can I use asynchonized replication? Maybe here is the problem...

0 Kudos
Highlighted
Enthusiast
Enthusiast

I remeber something about a-sync replication not beeing supported with SRM and this storage array but I can`t find anything official about it now, so I might be wrong. Let us know if setting up SRM form the other site helped.

0 Kudos