sawag
Enthusiast
Enthusiast

SRM Test Recovery plan issue

Jump to solution

Hello,

we have two sites with ESXi hosts 5.5 and vCenter 6 and SRM 6 installed and configured on both the sites. we are using IBM Storwize v7000 storage on both the sites. I have configured SRM with array based replication. Everything looks fine but when i run the recovery plane in test recovery mode, it generates error on stem 4;

--------------

Failed to create snapshots of replica devices.

Cause:

Failed to create snapshot of replica consistency group Test.

Cause:

SRA command 'testFailoverStart' failed for consistency group 'Test'.

Cause:

The replication might have been terminated as a result of a previous failover operation.

Refer to IBM SAN Volume Controller troubleshooting

------------

Attached is the snapshot also. Please any one advise how to resolve this issue.

thanks in advance..

0 Kudos
1 Solution

Accepted Solutions
rcporto
Leadership
Leadership

Try delete the file SRA-STATUS located in C:\Program Files\VMware\VMware vCenter Site Recovery Manager\storage\sra\IBMSVC and then refresh/rescan your Array Managers.

---

Richardson Porto
Senior Infrastructure Specialist
LinkedIn: http://linkedin.com/in/richardsonporto

View solution in original post

0 Kudos
20 Replies
rcporto
Leadership
Leadership

You're using the preconfigured or non_preconfigured mode for your SRAs?

---

Richardson Porto
Senior Infrastructure Specialist
LinkedIn: http://linkedin.com/in/richardsonporto
0 Kudos
sawag
Enthusiast
Enthusiast

I just installed SRA on both SRM Servers and added them into Array pair through SRM console. Do I need to do any other configuration on SRA itself?

0 Kudos
rcporto
Leadership
Leadership

You have to configure the SRA and select if you will use the preconfigured or non_preconfigured, here is a screen:

sra.JPG

Check here for additional details: http://www-01.ibm.com/support/knowledgecenter/HSG_SVC_SRA_230/PDFs/Storwize_Family_Replication_Adapt...

---

Richardson Porto
Senior Infrastructure Specialist
LinkedIn: http://linkedin.com/in/richardsonporto
0 Kudos
sawag
Enthusiast
Enthusiast

I am using non-preconfigured environment. Both SRA are paired successfully in Array paired tab and are doing the volumes in consistency group.

0 Kudos
sawag
Enthusiast
Enthusiast

I have a question, do we need to stop relationship in storage while doing a Test Recovery or no? I dont stop the relationship in consistency group and the disk remains read-only on the recovery site. Do we need to stop and then start again after finishing the Test Recovery?

0 Kudos
rcporto
Leadership
Leadership

Since you're using the non-preconfigured, you don't need do anything on storage, the SRA will do the work for you.

---

Richardson Porto
Senior Infrastructure Specialist
LinkedIn: http://linkedin.com/in/richardsonporto
0 Kudos
sawag
Enthusiast
Enthusiast

No it is not doing unfortunately. When I am running the Test Recovery, it is generating the error on step 4 as mentioned in the above attached snapshot.

0 Kudos
El_VM_Dude
Contributor
Contributor

I had a similar issue but my environment uses EMC.

I had to install and use an EMC Plug-In for vSphere like this one for IBM:

https://www.ibm.com/developerworks/community/blogs/anthonyv/entry/ibm_storage_management_console_for...

 

I logged onto the vSphere Windows Client (Not web client) , navigated to the VM that I was going to test and selected the "EMC VSI" Tab.

Then I chose my snapshot that I wanted to use (most recent for test) that hadn't expired.

-Hopefully this is a little relevant and helps. I haven't used IBM. Good luck

- Franky
0 Kudos
sawag
Enthusiast
Enthusiast

I am using SRM 6 with vCenter 6 and host version is 5.5.. I paired both the site arrays successfully and those are properly communicating to the storage. but when running the Test Recovery, getting an error message.

0 Kudos
El_VM_Dude
Contributor
Contributor

I'm using SRM 6, vCenter Server 5.5, ESXi 5.1

- Franky
0 Kudos
rcporto
Leadership
Leadership

Please, take a screenshot of your SRA configuration and attach the SRM logs.

---

Richardson Porto
Senior Infrastructure Specialist
LinkedIn: http://linkedin.com/in/richardsonporto
0 Kudos
sawag
Enthusiast
Enthusiast

Attached are the log files of SRA and SRM

0 Kudos
sawag
Enthusiast
Enthusiast

This is the exact error message i am getting;

--------------

Failed to create snapshots of replica devices.

Cause:

Failed to create snapshot of replica consistency group Test.

Cause:

SRA command 'testFailoverStart' failed for consistency group 'Test'.

Cause:

The replication might have been terminated as a result of a previous failover operation.

Refer to IBM SAN Volume Controller troubleshooting

------------

Please advise how to resolve the issue

0 Kudos
rcporto
Leadership
Leadership

Try delete the file SRA-STATUS located in C:\Program Files\VMware\VMware vCenter Site Recovery Manager\storage\sra\IBMSVC and then refresh/rescan your Array Managers.

---

Richardson Porto
Senior Infrastructure Specialist
LinkedIn: http://linkedin.com/in/richardsonporto

View solution in original post

0 Kudos
sawag
Enthusiast
Enthusiast

Attached are the latest vmware log file.

0 Kudos
sawag
Enthusiast
Enthusiast

attached is latest log file

0 Kudos
sawag
Enthusiast
Enthusiast

Ok I will check and post the result.

0 Kudos
sawag
Enthusiast
Enthusiast

Even though the solution is working but will you please tell me what is the logic behind why we need to delete SRA-STATUS file?

0 Kudos
sawag
Enthusiast
Enthusiast

the "Test Recovery Plan" went successfully but "Plan Recovery" generating some issues. The Recovery plan is successfully running but when I am rescanning my SRA, it shows status "Failover in progress" instead "synced or completed" and after some time it shows Unknown status as per the snapshot. Please see the attached snapshot and advise;

Appreciated in advance.

0 Kudos