toobulkeh
Contributor
Contributor

SRM Test Recovery Plan Fails on Preparing Storage

I have an evaluation testbed setup with SRM using two EMC Symmetrix arrays (DMX3 protected and VMAX recovery). I have configured SRM to the point of no warnings or errors following the evaluator's guide 4.0. I'm using vCenter and SRM 4.1 on separate boxes (with a separate remote database for each). The arrays have been setup using 2-way mirror devices on a thin pool that is replicated over RAs using SRDF. The SRDF Adapater (installed on top of SE) is on the local vm to each SRM.

Here is the error thrown in SRM about 5 seconds after clicking test:

Prepare Storage for Test
BLOK-DR-VC-2
Non-fatal error information reported during execution of SRA: testFailover Output:
08/25 11:02:56 01096 CopyLuns.cpp 0463 CopyLuns::GetCopyInfo
: A valid CopyInfo block could not be found in the options file that has
Symm x. Exiting with failure 08/25 11:02:56 01096 CopyLuns.cpp
-- 0021 CopyLuns::CopyLuns-- : Failed to fetch CopyInfo
from the options file. Exiting with failure 08/25 11:02:56 01096 EmcSrdfSra.cpp
-- 0998 wmain-- : Failed to test failover luns.
Exiting with failure Error: .

Attached are the SRDF related log snips.

My searching has lead me to believe that this is a permissions or XML error, but im not sure where these permissions are missing. I personally think it's the array configuration in that I was never able to mount the replicated away, but that can be reasoned as a feature (so you don't write to a replicated array) or as an error (configuration problem).

Any ideas? Thanks.

0 Kudos
6 Replies
toobulkeh
Contributor
Contributor

I'm going to bump this thread. Does anyone know what a CopyInfo Block is?

0 Kudos
barrif
Contributor
Contributor

Hello,

I have got the same problem. Do you have the solution?

Thanks

Regards

0 Kudos
toobulkeh
Contributor
Contributor

barrif, when using EMC's SRDF Adapter (SRA), you have different requirements for testing a recovery plan and executing a recovery plan. With your current config (if it mirrors mine) you should be able to execute the recovery plan without any issues. But when you test it you get the errors mentioned above. For one, SRM SRA requires you to either manually edit the XML file or to install EMC's Virtual Storage Integrator. VSI adds new tabs on the host and VM views in vSphere client.

The XML file is located on the recovery SRM server at: “c:\program files\VMware\VMware vCenter

Site Recovery Manager\scripts\SAN\EMC Symmetrix\EmcSRDFraOptions.xml." I was not able to successfully edit this, but VSI and executing the recovery plan instead of testing it was good enough for my purposes.

Another problem with my configuration is VSI requires TimeFinder (Snap, Mirror, Clone, etc...) in order to do the local test without touching the production server.

Hope this helps.

0 Kudos
curioso
Contributor
Contributor

Were you able to fix this. What was your solutions?

0 Kudos
smithjr
Contributor
Contributor

anybody ?? I have the same problem.

0 Kudos
toobulkeh
Contributor
Contributor

All,

it has been awhile since I was working on this project. But here's what I remember:

1. Our storage was misconfigured. The backup luns should not be presented anywhere. VMware SRM takes care of the backup lun presentation reconfigure while the recovery process takes place. This, along with some tweaking of timeout variables in SRM, was what fixed the long timeout waits.

2. There was an internal bug which should be fixed by 4.2 / 5.1 vCenter and SRM that VMware support continued to referred to. Hopefully if you have support (as I'm currently in a partner situation and our support is often ignored), you'll get a straight answer.

Best of luck,

Dan

0 Kudos