nathanw
Enthusiast
Enthusiast

SRM 5.0.1 installation woes. ODBC error (42S01)

I’m trying to install SRM with VR.

I am installing the first SRM server, this is a windows 2008R2 VM.

The Database is an SQL 2008 R2 DB on a remote server using SQL authentication.

On installation right as its about to create the database I get the following error;

     C:\Users\Administrator\AppData\Local\VMware’ is not a directory – yep it does not exist!

I click Retry and I am presented with a lovely dialog with an ODBC error;

-----------Dialog----------------

Failed to create the database tables.

Details:

There was an error creating the sequence: “ODBC error: (42S01) – [Microsoft][SQL Server Native Client 10.0][SQL Server]There is already an object named ‘dr_table_catalog’ in the database.“ is returned when executing SQL statement “create table dr_table_catalog (name varchar(255) PRIMARY KEY NOT NULL)”

Press Retry to try again or press Cancel to exit installation.

-----------Dialog----------------

Ok sounds like I using a database that is already got SRM taking to it, the thing is, this is a new SQL server, New environment and SRM has never been installed previously.

I can delete and recreate the database but to no avail. The same happens.

Any suggestions?

Nathan VCP
9 Replies

As far as I know SRM uses the same DB which is for vcenter. No need to create db again for SRM.

Regards, ABFS
0 Kudos
nathanw
Enthusiast
Enthusiast

No i do not think this is correct, the vCenter DB cannot be used by multiple users and SRM DB Account must own the SRM database.

Thanks for you reply.

Nathan VCP
0 Kudos
vMario156
Expert
Expert

SRM is using a seperate DB with a seperate ODBC-DSN.

If you are not trying to make a upgrade, delete the existing one (or take another name, of course with other DSN) and create a new DB (and make sure the ODBC DSN works).

Regards,

Mario

Blog: http://vKnowledge.net
0 Kudos
vMario156
Expert
Expert

Sorry I was to quick reading your first post.

You wrote that you never installed SRM before, so on which DB are you pointing SRM (or better said the ODBC DSN which you select during the SRM installation)?

You defenitly need to create a seperate DB with ODBC-DSN first!

Regards,

Mario

Blog: http://vKnowledge.net
0 Kudos

yeah, just went through a document. It does need its own db. Thanks for the information. I almost forgot how I have installed srm in my test lab before.

Regards, ABFS
0 Kudos
nathanw
Enthusiast
Enthusiast

Hi Mario, thanks for the replys.

I think this has got a little off track here. I have an OBCD DSN created using the SQL native client, this connects to the SRM DB successfully.

I select the ODBC DSN during install from the drop down list and enter the DB credentials, all good here.

The app installs but the last step in installation is the DB creation this is where I get the error.

Nathan VCP
0 Kudos
nathanw
Enthusiast
Enthusiast

Ok I have managed to work it out with thanks to this post http://virtualistmanifesto.com/2011/10/11/vcenter-site-recovery-manager-5-0-and-sql-server-configura....

What I did to resolve the issue;

On the SQL server  | SRM database | Create a schema the same name as the SRM DB user name i.e. service_srm

the user account Service_SRM set the default schema to service_srm and check it as owned.

I then re ran the installer without error.

As I am not an SQL expert I guess the line in the Admin guide that states "The DB schema name must be the same as the DB user name" is really where my issue was.

I hope this can help somebody else.

Nathan VCP
mkondratyev
Enthusiast
Enthusiast

Thank you buddy! It's realy helped me!

0 Kudos
ikiris
Enthusiast
Enthusiast

Thanks for the tip.

I have a test environment where I am sharing a SQL express server between a primary and recovery server.

I was setting up a second instance and i ran into the same issue and it wouldn't work until I created schemas that matched the names.

Oddly enough, the first primary and recovery databases are just mapped to dbo schema

-Chris- http://www.twitter.com/ikiris http://blog.chrischua.net
0 Kudos