cmaurer
Contributor
Contributor

SRM 1.0.1 Startup Error

I'm a developer working with EMC storage and SRM. I had a pair of virtual centers that were working just fine with SRM 1.0.1 (Celerra iSCSI SRA). I didn't use SRM for a while (3 months), but when I went back to do some work, the SRM service was down. OK, so I went to start the service, and I get a generic windows service startup error, and the service doesn't start. When I try to start the service on the command line, I get the following error:

C:\Documents and Settings\Administrator>"C:\Program Files\VMware\VMware Site Recovery Manager\bin\vmware-dr.exe" -d "C:\Program Files\VMware\VMware Site Recovery Manager\bin
" -s "C:\Program Files\VMware\VMware Site Recovery Manager\config\vmware-dr.xml"

Failed to start service control dispatcher: 1063

Google shows nothing useful. Anybody have any ideas?

Chip

0 Kudos
7 Replies
TimOudin
Hot Shot
Hot Shot

How about the SRM logs, anything more useful there?

Tim Oudin

Tim Oudin
0 Kudos
cmaurer
Contributor
Contributor

From : C:\Documents and Settings\All Users\Application Data\VMware\VMware Site Recovery Manager\Logs

There are two types of entries in the log:

This:

Log for VMware Site Recovery Manager, pid=6080, version=1.0.1, build=build-128004, option=Release, section=2

Failed to start service control dispatcher: 1063

And this:

Log for VMware Site Recovery Manager, pid=4420, version=1.0.1, build=build-128004, option=Release, section=2

Failed to create console writer

Set dump dir to 'C:\Documents and Settings\All Users\Application Data\VMware\VMware Site Recovery Manager\DumpFiles'

Intializing the DBManager

Current working directory: C:\Program Files\VMware\VMware Site Recovery Manager\bin

TaskMax=10, IoMin=1, IoMax=21

Trying DrExternalRecoveryApi

Plugin 0 path: dr-external-recovery-api.dll

Plugin 0 absolute path: C:\Program Files\VMware\VMware Site Recovery Manager\bin\dr-external-recovery-api.dll

Trying RecoverySecondary

Plugin 1 path: dr-secondary-recovery.dll

Plugin 1 absolute path: C:\Program Files\VMware\VMware Site Recovery Manager\bin\dr-secondary-recovery.dll

Trying SanProvider

Plugin 2 path: dr-san-provider.dll

Plugin 2 absolute path: C:\Program Files\VMware\VMware Site Recovery Manager\bin\dr-san-provider.dll

Trying TestProvider

Plugin 3 path: dr-test-provider.dll

Plugin 3 absolute path: C:\Program Files\VMware\VMware Site Recovery Manager\bin\dr-test-provider.dll

DrExtApi Service Instance is initialized.

Plugin started.

Provider 'SanProvider' has MoRef 'dr.primary.SanReplicationProvider:PrimarySanProvider'.

Registered provider 'SanProvider'

Provider 'SanProvider' has MoRef 'dr.secondary.SanReplicationProvider:SecondarySanProvider'.

Registered provider 'SanProvider'

Plugin started.

Provider 'TestProvider' has MoRef 'dr.PrimaryTestProvider:primary-test-provider'.

Registered provider 'TestProvider'

Provider 'TestProvider' has MoRef 'dr.SecondaryTestProvider:secondary-test-provider'.

Registered provider 'TestProvider'

Plugin started.

LocalSite already installed - Good!

Vmacore::InitSSL: doVersionCheck = true, handshakeTimeoutUs = 120000000

VC Connection: Logging in as user 'Administrator'

VC Connection: Logged in session F8180158-7363-42E6-893F-5CEA18CDD337

Minimum free disk space: 100 Mb

Maximum CPU usage: 80 %

Minimum available memory: 32 Mb

Check interval: 60 sec

Event frequency: 600 sec

Started monitoring local site

Loading remote sites from database...

Free disk space: 935 Mb

CPU usage: 0 %

Available memory: 3059 Mb

Created Inventory Mapper for site 'site-24'

Configuration parameter checkInterval is not specified

Check interval: 60 sec

Configuration parameter warningDelay is not specified

Time delay before raising low priority event: 120 sec

Configuration parameter panicDelay is not specified

Time delay before raising high priority event: 300 sec

Configuration parameter panicRepeatDelay is not specified

Time delay before raising repeated high priority event: 300 sec

Attempting to connect to remote site

Wait authorization manager to wake up!

Failed to connect to remote site: Unexpected MethodFault (dr.fault.InvalidState) {

dynamicType = <unset>,

msg = ""

}

Received notification of broken DR connection

Failed to ping remote site

Received notification of broken VC connection

Attempting to reconnect

Attempting to connect to remote site

Wait authorization manager to wake up!

Failed to connect to remote DR: Unexpected MethodFault (dr.fault.InvalidState) {

dynamicType = <unset>,

msg = ""

}

Changing to state: DrEvalState

Evaluation Source: Remaining Evaluation Hours: 0

FlexLM: Created license job with server '27000@lrmb022.lss.emc.com'

FlexLM: The feature 'PROD_SRM' is not present on the license server or has expired.

FlexLM: The feature 'SRM_PROTECTED_HOST' is not present on the license server or has expired.

FlexLM: The feature 'PROD_SRM' is not present on the license server or has expired.

Changing state from: DrEvalState to DrUnlicensedState

FlexLM: Freeing all licenses from job: '27000@lrmb022.lss.emc.com'

Evaluation Source: Remaining Evaluation Hours: 0

FlexLM: Created license job with server '27000@lrmb022.lss.emc.com'

FlexLM: The feature 'PROD_SRM' is not present on the license server or has expired.

FlexLM: The feature 'SRM_PROTECTED_HOST' is not present on the license server or has expired.

FlexLM: The feature 'PROD_SRM' is not present on the license server or has expired.

Evaluation Source: Checked out PROD_SRM licenses of '1'

1 licenses of the feature: 'PROD_SRM' are overallocated.

1 licenses of the feature: 'PROD_SRM' have expired.

Evaluation Source: Checked in PROD_SRM licenses of 1

Evaluation Source: Checked out PROD_SRM licenses of '1'

1 licenses of the feature: 'PROD_SRM' are overallocated.

1 licenses of the feature: 'PROD_SRM' have expired.

FlexLM: The feature 'PROD_SRM' is not present on the license server or has expired.

Evaluation has ended.Please install a valid 'PROD_SRM' license into VC's license server. Exiting.

Shutting down due to Licensing Errors.

Stopped monitoring local site

Plugin stopped.

Plugin stopping.

Unregistered provider 'SanProvider'

Unregistered provider 'SanProvider'

Plugin stopping.

Unregistered provider 'TestProvider'

Unregistered provider 'TestProvider'

0 Kudos
TimOudin
Hot Shot
Hot Shot

FlexLM: The feature 'PROD_SRM' is not present on the license server or has expired.

Evaluation Source: Checked out PROD_SRM licenses of '1'

1 licenses of the feature: 'PROD_SRM' are overallocated.

1 licenses of the feature: 'PROD_SRM' have expired.

Evaluation Source: Checked in PROD_SRM licenses of 1

Evaluation Source: Checked out PROD_SRM licenses of '1'

1 licenses of the feature: 'PROD_SRM' are overallocated.

1 licenses of the feature: 'PROD_SRM' have expired.

FlexLM: The feature 'PROD_SRM' is not present on the license server or has expired.

Evaluation has ended.Please install a valid 'PROD_SRM' license into VC's license server. Exiting.

Shutting down due to Licensing Errors.

This looks significant...

Tim Oudin

Tim Oudin
0 Kudos
cmaurer
Contributor
Contributor

Well I feel like a chump. In 2008, I had a temp license that expired, and it failed to start up with this error:

<![endif]><![if gte mso 9]>

C:\Documents and

Settings\Administrator.PIANO&gt;"C:\Program Files\VMware\VMware Site Recovery

Manager\bin\vmware-dr.exe" -d "C:\Program Files\VMware\VMware Site Recovery

Manager\bin
" -s "C:\Program Files\VMware\VMware Site Recovery

Manager\config\vmware-dr.xml"

[2008-08-20

23:12:06.500 'App' 4132 error] The Site Recovery Manager Product has Expired.

I didn't get that error this time, but I did have a 1 yr license that has expired., so I did apply a new SRM license to our license server. In virtual center, it does not show up. Check out the attached screen capture that shows my licensed applications. No SRM.

I wonder why my license is not being recognized?

And I wonder why it didn't error out with a license error?

0 Kudos
cmaurer
Contributor
Contributor

Oh look, the license server is telling me a little more:

Users of PROD_SRM: (Error: 1 licenses, unsupported by licensed server)

Users of SRM_PROTECTED_HOST: (Error: 16 licenses, unsupported by licensed server)

0 Kudos
cmaurer
Contributor
Contributor

Now it makes sense. It wasn't using the default license file in C:\Program Files\VMware\VMware License Server\Licenses. That is where I put the updated SRM license. The license server is configured to use a different license file, and the license tool is not very obvious about that.

Tim, thanks for your help.

0 Kudos
TimOudin
Hot Shot
Hot Shot

Yet another reason why the Flex license server can **** ** ***. Smiley Happy

A vSphere upgrade will fix that nuisance for you.


Tim Oudin

Tim Oudin
0 Kudos