kaylingovenderp
Contributor
Contributor

Place holder create error SRM 8.1.1

Good day,

I have installed vsphere replication 8.1.1 with SRM 8.1.1 and after pairing the two sites and completing replication of indivdual VMs using vsphere replication when i try to add the VMs to a protection group I get the following error " Placeholder Create Error: Unable to find a placeholder datastore for the host/cluster DR Cluster. Any placeholder datastores registered with the SRM server that were deleted and recreated in the vCenter Server will need to be removed and re-added as a new placeholder datastore with the SRM server as well." this is after completing the mappings. I have done the following troubleshooting :

1. removed the placeholder datastores and re added them

2. restarted the vcenter servers at both sites, removed the VM protection and re added the VMs and restarted SRM services

3. restored all placeholder VMs and restarted SRM services

4. recreated the placholder restarted SRM services

But i am still faced with the same error. Any assistance with be helpful. Both SRM and vsphere replication are running on vCenter 6.7

pastedImage_4.png

Regards

Kaylin

5 Replies
virtualg_uk
Leadership
Leadership

I have fixed this before by restarting the SRM services and vCenter VMs at both sites but it seems like you have already tried it.

Can you confirm that the placeholder datastore is on the target (DR) site and configured in SRM as such?


Graham | User Moderator | https://virtualg.uk
0 Kudos
kaylingovenderp
Contributor
Contributor

Hi Graham, yes i can confirm that the target datastore is configured at the DR site and configured in SRM, please see below

pastedImage_0.pngpastedImage_1.png

0 Kudos
Daniel_Georgiev
VMware Employee
VMware Employee

Hi,

one important thing for clusters is that the placeholder datastores must be visible to all hosts in the cluster or your DR_Placeholder_Vol should be visible to all hosts.

You can check this in Placeholder Datastores view -> Host/Cluster tab.

Hope this helps,

Daniel G.

kaylingovenderp
Contributor
Contributor

Hi Daniel, I can confirm that the datastore is visble in the cluster and from the host, at the moment we only have one host in the cluster. Will the licensing of the host be a problem at our DR as our production site has four host that are licensed with vsphere enterprise plus and configured with vSAN and at our dr site the one host is licensed as vsphere standard and is direct attached to a Dell/EMC compellent SAN.

Cluster View

pastedImage_0.png

Host View

pastedImage_1.png

0 Kudos
kaylingovenderp
Contributor
Contributor

Thanks for assistance guys in the end i found out it was the vm hardware version that was a problem. On our protected site our hosts are running 6.7 and all the VMs are runing hardware version 14 but on our DR site our host was are running 6.5. After upgrading the host to 6.7 all the vm were able to be protected.