sannew
Contributor
Contributor

Location of XML scripts used by SRA during test failover

Hi,

I am trying to test failover in SRM using Hitachi Storage.

The test fails during "Prepare Storage" step showing the error in the script that SRA executes in search of the paired storage.

I observed that the command doesnt have group name of the paired storage.

Is there any way to update the script manually?

Where does the SRA executes the script from?

Regards,

Sanjeev

0 Kudos
8 Replies
vijayagce
Enthusiast
Enthusiast

Hi,

By default SRA codes will be under the folder "C:\Program Files (x86)\VMware\VMware vCenter Site Recovery Manager\scripts\SAN"..

Thanks,

Vijaya

0 Kudos
sannew
Contributor
Contributor

Hi Vijaya,

Thanks for your reply.

I am searching for the testfailover code but i am not able to find the same in the default location.

Any idea where the code is avialable.

thanks,

Sanjeev

0 Kudos
vijayagce
Enthusiast
Enthusiast

some adapters will use failover.pl code for testfailover.pl also.. check failover.pl is there..

Thanks,

0 Kudos
sannew
Contributor
Contributor

I am only able to find command.pl in that location and that is not having the information i needed.

Just to know, what files are installed in that location during installation of SRA?

0 Kudos
vijayagce
Enthusiast
Enthusiast

Hi,

Please reinstall your SRA adapter and check.. because with 4 important pl file adapter wont work.. like discoverArray.pl, discoverLuns.pl, testfailover.pl or failover.pl and command.pl

Thanks,

0 Kudos
sannew
Contributor
Contributor

Hi,

I am not able to get the files that you have mentioned after re-installing the SRA for Hitachi storage.

Anyways, do we need to do any modification to the .pl files like adding groupname for the failover to work?

0 Kudos
vijayagce
Enthusiast
Enthusiast

As per my understanding these 4 perl scripts will be there and some exe which will execute array based operations will be in SRA code. May be some exe will do all the operations..

Thanks,

sannew
Contributor
Contributor

Hi,

Thanks alot for your reply.

Actually the scripts are not showing in the default location of SRA for Hitachi. But as you mentioned, those scripts are automatically executed when we run a test. We need not modify anything in those scripts.

Thanks once again....

0 Kudos