AndrewP27
Contributor
Contributor

Failed to sync data on replica consistency group

Hi,

We've got an issue with a SRM Recovery Plan we have just created where during a Test it will not proceed past the first step of Sychronizing the Storage. It fails every time with a message "Failed to sync data on replica consistency group '15725743990x72092424a3e5e3a' Failed to create snapshot".


I've tried everything i can think of including destroying the consistency group and all the actual TDEV's involved. All the recovery plans and protection groups in SRM were removed as well. And i basically started from scratch comparing it to another existing group and SRM Protection group/Recovery Plan and it still fails with this error.

I've done tests with Recover Point when this particular consistency group is not under SRM control and replication seems to work fine. The datastores in the Protected site automatically mount and i can browse them when i enable image access. So i am happy that the basics of RecoverPoint are working and think this is something within the SRM/SRA configuration. But since i am learning SRM as i go i am not 100% confident of that fact.

Don't know if it makes any difference but normally the LUN's in the protected site are visible to the ESX if i look under Configuration->Storage->Devices on any of the hosts, but they are not mounted. If i test image access in RecoverPoint when the consistency group is not under SRM control it automatically mount the LUN's which i assume is the same way SRM would work? Or would you expect that the LUN's in the protected site are mounted as datastores all the time?

I've logged a call with EMC but if anyone has any thoughts/ideas on what could be causing this i would welcome them.


Thanks

Tags (2)
4 Replies
vbrowncoat
VMware Employee
VMware Employee

Were you able to resolve this? Just curious what EMC support came back with.

0 Kudos
AndrewP27
Contributor
Contributor

Yep we sorted it. There is a setting within the RecoverPoint user set up where you can specify which consistency groups a user has access to. You can leave it un-ticked so it assumes it will have admin rights to every consistency group. Unfortunately this tick box had been selected so it would only grant admin rights for the SRM user to specific consistency groups. And of course the consistency group i was working on was not one of them. So we removed that option to allow the SRM user admin rights to all consistency groups and hey presto it worked.

Bit annoying that we had to find that and it wasn't something EMC asked us to check. Spent ages getting logs collected, getting them sanitized for a simple tick box Smiley Sad

0 Kudos
vbrowncoat
VMware Employee
VMware Employee

Glad to hear you figured it out. From what I see SRAs are very often where SRM runs into problems. Thank you for sharing, hopefully it will help someone else in a similar situation.

Cheers!

jsbtecniux
Contributor
Contributor

Hi Andrew,

We have an issue that looks like this one.

Could you shared us steps to change that checkbox for RP user ?

Thanks in advance.