VirtualAerospac
Contributor
Contributor

EMC SRDF adapter

Jump to solution


Hi all

I am attempting to install the pluggins for SRM so I can start using SRM and testing it before putting it into production.

Our EMC colleague gave me 3 pluggins to install.

These two had to be installed on the vCentre which was done successfully:

emc-vsi-pm-5.3.0-vmware-vsphere-WINDOWS-x86

emc-vsi-sv-5.3.0-vmware-vsphere-WINDOWS-x86

I was then given this and told to install once the top two where installed:

emc-vsi-sra-5.3.0-vmware-vsphere-WINDOWS-x86

But of course it doesnt work and returns message which is attached.

We had an EMC person which was suppose to assist us with this but this did not happen and due to time constraints I have to continue and try it myself.

Our set up

vCentre 5.0 in primary site

vCentre 5.0 in recovery site

SRM 5.0 installed on own server in primary site

SRM 5.0 installed on own server in recovery site

Both sites are linked through SRM successfully.

EMC symmetrix

I have mapped folders, datacentres in the SRM between sites but I am now at the array replication part.

Any help would be great.

Hope I have covered enough information...

0 Kudos
1 Solution

Accepted Solutions
codyhosterman
Enthusiast
Enthusiast

You would need to look at the SRA log to find what the actual issue is. the log is in C:\Program Data\VMware\Site Recovery Manager\SRAs\EMC Symmetrix. I would suspect either the storsrvd daemon isnt configured properly or doesnt have the correct gatekeepers.

View solution in original post

0 Kudos
7 Replies
mal_michael
Commander
Commander

Hi,

Have you already installed SRDF SRA on your SRM servers?

VSI SRA Utility should be installed after the SRA installation.

Michael.

0 Kudos
VirtualAerospac
Contributor
Contributor

Hi Mal_Michael

We are having issues trying to find the SRDF to install.

Do you know where we can get this downloaded?

0 Kudos
codyhosterman
Enthusiast
Enthusiast

Go to the VMware Site Recovery Manager download page and click "View Download" and the next page will have the SRM install to download and below that all of the SRAs. The SRDF SRA is called EMCSRDFSRA_5.1.0.0.zip

VirtualAerospac
Contributor
Contributor

Hi Codyhosterman

Thanks, I found that and installed it.

For a second there thought I got it but no Smiley Sad

Next error message is attached as EMC SRDF Error, it mentions it requires EMC Solutions enabler 32bit 7.4.0 or later.

EMC SRDF error.png

I then went back to the vmware site and downloaded EMC_VNX_SRA_with_Enablers-64-bit-A, it contained the following .exe

     EMC_Mirrorview_Enabler_for_VNX_SRA_v5.0.22_64bit

     EMC_VNX_Replicator_Enabler_for_VNX_SRA_v5.0.15_64bit

     EMC_VNX_SRA_v5.0.1

is it one of these I need to install?

Am I getting any closer?

Thanks

0 Kudos
codyhosterman
Enthusiast
Enthusiast

Yeah you need Solutions Enabler installed locally on the SRM server in order for the SRDF SRA to communicate with the VMAX array. You can download Solutions Enabler on the support.emc.com website. Make sure you download the 32-bit version of Solutions Enabler (regardless to the architecture of the SRM server itself) Here is a direct link to the correct version to help:

https://download.emc.com/downloads/DL46940_se7600-WINDOWS-x86.exe.exe

Have you downloaded and read my Techbook for using SRDF with SRM? The install and configure chapter should make this a lot easier. You need to make sure you have Solutions Enabler servers configured on both sides etc. and this goes through all of that:

http://www.emc.com/collateral/software/technical-documentation/h10553-sra-vmware-5-0-tb.pdf

VirtualAerospac
Contributor
Contributor

Hi codyhosterman

That you so much for the help! Finally got it all installed and working.

But if you dont mind helping me with the next error.

I followed your document (thanks for that btw) and started to create the array manager. I entered the local symAPI server name and the remote symAPI server name.

But it returns with the following error.

Untitled.png

Something else to note is that the local symAPi and remote are vritual servers running on a standalone esx box. The 2 servers are windows 2008 and I added the SRMservice account as local admins just to make sure it wasnt that.

Where can i find the logs to check them for more detail?

0 Kudos
codyhosterman
Enthusiast
Enthusiast

You would need to look at the SRA log to find what the actual issue is. the log is in C:\Program Data\VMware\Site Recovery Manager\SRAs\EMC Symmetrix. I would suspect either the storsrvd daemon isnt configured properly or doesnt have the correct gatekeepers.

View solution in original post

0 Kudos