VMware Cloud Community

After SRM 8.8 upgrade

I recently upgraded to SRM   After the upgrade, both my SRM servers show this under the issues

sites.configure.telemetry.vcsa.name  sites.configure.telemetry.vcsa.notAccessible         sites.configure.telemetry.vcsa.siteIssueType

I never saw this message/error on an previous upgrades I have performed, so I am going to assume that telemetry is new in SRM 8.8.  Note that I was previously on SRM 8.6.   

I do see there are telemetry settings under advanced settings, but there is no option to just disable it.  Is this message/error because my SRM servers cannot talk to VMware?  I do see traffic being blocked in my firewall trying to go to a vmware address.  Is it possible to disable telemetry entirely?  Or do I need to just ignore this message?



Labels (1)
0 Kudos
1 Reply

You can ignore this telemtery service warning and it won't impact SRM services if still you you need troubleshoot  follow below :


Verify if vCenter Server can access vcsa.vmware.com via HTTPS/443.

To test if HTTPS Port 443 access is enabled:
1. Connect to the vCenter Server appliance through SSH or console.
2. Test the connectivity:
# curl -v https://vcsa.vmware.com

A successful connection should show "Connected to vcsa.vmware.com...port 443" along with some certificate information.
Please note that the text "403 Forbidden" in the results is also expected in a successful connection. Connecting to https://vcsa.vmware.com/ requires authentication parameters that are not passed by curl. Using curl to test connectivity will result in "403 Forbidden" but this still validates that vCenter can reach https://vcsa.vmware.com/
If result is an "error" message, then HTTPS port 443 access is likely not enabled.

Note: If your vCenter cannot directly communicate with the internet (e.g., your organization blocks the access to the internet by a firewall), you can still use vSphere Health Service as it is not required for the service to function.

If needed, you can configure vCenter to communicate via an HTTP proxy by following the steps described in this article. 

Click Configuration on vcenter VAMI.
Click Proxy.
Click Add Proxy.
Enter the Proxy Server IP Address.
Enter the Proxy Server Port.
If needed, enter the Proxy Server username.
If needed, enter the Proxy Server password for the user name specified in the previous step.
Click Add Proxy Configuration.


I guess  you can ignore this telemtery service warning and it won't impact SRM services if still you you need troubleshoot  follow below .

SRM 8.8 has made some default port  assignment during upgrade  so kindly change telemetry setting under SRM Site pair Advance Setting .

Remove telemetry.proxyHost --

Remove telemetry.proxyport --0

Remove telemetry.proxyUseSsl -- false

Restart vcenter mgmt services and restart SRM services and reconfigure SRM and reconnect site pair . Should be able to see warning is no more.

0 Kudos