unknown_man
Contributor
Contributor

[solved] vib install on esx 5.1

Jump to solution

Добрый день коллеги!

Возникла проблемка. Не могу установить vib пакет на esxi хост. Пакет представляет собой утилиту командной строки для IBM MegaRaid. (MegaCli-8.04.07.vib)

Делаю:

esxcli software vib install /vmfs/volumes/datastore1/vmware-esx-MegaCli-8.04.07.vib

Получаю:

Error: Unknown command or namespace software vib install /vmfs/volumes/datastore1/vmware-esx-MegaCli-8.04.07.vib

Помогите пожалуйста. Какие данные еще предоставить чтобы решение моего вопроса шло быстрее?

0 Kudos
1 Solution

Accepted Solutions
VMadmin4eg
Hot Shot
Hot Shot

Контроллер какой?

Драйвера точно для ESXi 5.x подходят?

View solution in original post

0 Kudos
8 Replies
VMadmin4eg
Hot Shot
Hot Shot

А если так?

esxcli software vib install -d "/vmfs/volumes/datastore1/directory/name.zip"

Ссылка на документацию:

http://pubs.vmware.com/vsphere-50/topic/com.vmware.vsphere.upgrade.doc_50/GUID-1E773360-CB1C-4BC2-B2...

0 Kudos
unknown_man
Contributor
Contributor

Could not download from depot at zip:/vmfs/volumes/datastore1/ibm_utl_sraidmr_megacli-8.04.07_vmwesx4_32-64.zip?index.xml, skipping (('zip:/vmfs/volumes/datastore1/ibm_utl_sraidmr_megacli-8.04.07_vmwesx4_32-64.zip?index.xml', '', 'Error extracting index.xml from /vmfs/volumes/datastore1/ibm_utl_sraidmr_megacli-8.04.07_vmwesx4_32-64.zip: "There is no item named \'index.xml\' in the archive"'))
        url = zip:/vmfs/volumes/datastore1/ibm_utl_sraidmr_megacli-8.04.07_vmwesx4_32-64.zip?index.xml
Please refer to the log file for more details.

0 Kudos
VMadmin4eg
Hot Shot
Hot Shot

А так?

esxcli software vib install –v /vmfs/volumes/datastore/async-driver.vib

Existing ESXi installation using esxcli and async driver VIB file:

http://kb.vmware.com/selfservice/microsites/search.do?language=en_US&cmd=displayKC&externalId=200520...

0 Kudos
unknown_man
Contributor
Contributor

Unknown command or namespace software vib install –v /vmfs/volumes/datastore1/vmware-esx-MegaCli-8.04.07.vib

Smiley Sad

0 Kudos
unknown_man
Contributor
Contributor

Интересный факт

когда набираю просто 


esxcli software vib install

выдает

[Exception]
No VIBs specified with -n/--vibname or -v/--viburl.
Please refer to the log file for more details.

0 Kudos
Sladky
Virtuoso
Virtuoso

Прямо неделю назад инсталил VIB файлик для 10-гигабитных сетевушек. Всё прошло успешно. Тока я клал в папочку TEMP через WinSCP. После установки оно написало, что всё в порядке и само грохнуло исходник.

Делал вот по этой инструкции:

VMware ESX 5.0 VIB Installation Instructions

VMware uses a file package called a VIB (VMware Installation Bundle) as the
mechanism for installing or upgrading software packages on an ESX server.

The file may be installed directly on an ESX server from the command line, or
through the VMware Update Manager (VUM).


COMMAND LINE INSTALLATION

New Installation
----------------

For new installs, you should perform the following steps:

1. Copy the VIB to the ESX server.  Technically, you can
           place the file anywhere that is accessible to the ESX console shell,
           but for these instructions, we'll assume the location is in '/tmp'.

           Here's an example of using the Linux 'scp' utility to copy the file
           from a local system to an ESX server located at 10.10.10.10:
             scp VMware_bootbank_net-driver.1.1.0-1vmw.0.0.372183.vib root@10.10.10.10:/tmp

2. Issue the following command (full path to the VIB must be specified):
              esxcli software vib install -v {VIBFILE}
      
           In the example above, this would be:
              esxcli software vib install -v /tmp/VMware_bootbank_net-driver.1.1.0-1vmw.0.0.372183.vib

Note: Depending on the certificate used to sign the VIB, you may need to
      change the host acceptance level.  To do this, use the following command:
  esxcli software acceptance set --level=<level>
      Also, depending on the type of VIB being installed, you may have to put
      ESX into maintenance mode.  This can be done through the VI Client, or by
      adding the '--maintenance-mode' option to the above esxcli command.


Upgrade Installation
--------------------

The upgrade process is similar to a new install, except the command that should
be issued is the following:

esxcli software vib upgrade -v {VIBFILE}


VUM INSTALLATION

The VMware Update Manager (VUM) is a plugin for the Virtual Center Server
(vCenter Server).  You can use the VUM UI to install a VIB by importing
the associated offline bundle package (a ZIP file that contains the VIB and
metadata).  You can then create an add-on baseline and remediate the
host(s) with this baseline.  Please see the vCenter Server documentation for
more details on VUM.

VCP5
0 Kudos
VMadmin4eg
Hot Shot
Hot Shot

Контроллер какой?

Драйвера точно для ESXi 5.x подходят?

View solution in original post

0 Kudos
unknown_man
Contributor
Contributor

прощу прощения , дейтсвительно этот драйвер не подходит для esxi51, сставлю для тестов 4,1 но это уже совсем другая песня

0 Kudos