windzeit
Contributor
Contributor

ping DUP!

Имеем:
Хостовая ОС Windows 2008 R2 server standard x64, Vmware server 2.0.2
Поднята гостевая ОС windows 2003 R2 enterprise.

Сетевое соединение в режиме Bridged.

При пинге гостевой ОС из локальной сети видим следующее:
PING 10.0.0.3 (10.0.0.3): 56 data bytes
64 bytes from 10.0.0.3: icmp_seq=0 ttl=127 time=1.222 ms
64 bytes from 10.0.0.3: icmp_seq=0 ttl=128 time=1.226 ms (DUP!)
64 bytes from 10.0.0.3: icmp_seq=0 ttl=127 time=1.228 ms (DUP!)
64 bytes from 10.0.0.3: icmp_seq=0 ttl=128 time=1.230 ms (DUP!)
64 bytes from 10.0.0.3: icmp_seq=1 ttl=127 time=0.619 ms
64 bytes from 10.0.0.3: icmp_seq=1 ttl=128 time=0.623 ms (DUP!)
64 bytes from 10.0.0.3: icmp_seq=1 ttl=127 time=0.626 ms (DUP!)
64 bytes from 10.0.0.3: icmp_seq=1 ttl=128 time=0.628 ms (DUP!)
64 bytes from 10.0.0.3: icmp_seq=2 ttl=127 time=1.819 ms
64 bytes from 10.0.0.3: icmp_seq=2 ttl=128 time=1.822 ms (DUP!)
64 bytes from 10.0.0.3: icmp_seq=2 ttl=127 time=1.970 ms (DUP!)
64 bytes from 10.0.0.3: icmp_seq=2 ttl=128 time=1.973 ms (DUP!)

При этом сама хостовая ОС пингуется нормально:

PING 10.0.0.2 (10.0.0.2): 56 data bytes
64 bytes from 10.0.0.2: icmp_seq=0 ttl=128 time=0.322 ms
64 bytes from 10.0.0.2: icmp_seq=1 ttl=128 time=0.139 ms
64 bytes from 10.0.0.2: icmp_seq=2 ttl=128 time=0.322 ms
64 bytes from 10.0.0.2: icmp_seq=3 ttl=128 time=0.318 ms

Vmware tools на гостевой ОС установлены. Пробовал менять тип сетевого адаптера для
гостевой ОС на e1000, проблема остается.

В чем может быть причина?

0 Kudos
6 Replies
Deshifrator
Enthusiast
Enthusiast

Посмотрите здесь (похожая ситуация)

AWo пишет :

That happens

\- if you ping a broadcast address, because you send one ping and get many answers back.

\- if two or more systems have the same IP and both send an answer back.

\- if your NIC is in promiscious mode and you have a not so smart switch (or hub) which sends the ping also back to the pinging system.

Вы попробуйте сделать пинг из ВМ (проверьте будут ли дубликаты). Так же покажите arp -a хоста и ВМ.

Как вариант причины возникновения DUP - это дублированный MAC. Либо единый MAC на две машины.

------------- http://communities.vmware.com/blogs/Deshifrator
0 Kudos
windzeit
Contributor
Contributor

Про МАКИ я в первую очередь подумал, но:

arp -a с машин:

Хостовая:
Interface: 10.0.0.2 --- 0xd
  Internet Address      Physical Address      Type
  10.0.0.1              3c-4a-92-7c-7c-01     dynamic
  10.0.0.3              00-0c-29-c3-86-9c     dynamic

Гостевая:
Интерфейс: 10.0.0.3 --- 0x2
  IP-адрес              Физический адрес      Тип
  10.0.0.1              3c-4a-92-7c-7c-01     динамический
  10.0.0.2              d4-85-64-4c-5d-41     динамический

Машина с которой пингую:                                                                                 
(10.0.0.2) at d4:85:64:4c:5d:41 on bge1
(10.0.0.3) at 00:0c:29:c3:86:9c on bge1

Для теста соединил кроссовым кабелем напрямую машину с Vmware с тестовым компом,
результат такой же Smiley Sad Дубли не пропали.

Поднял еще одну гостевую. Хост и другие гостевые пингует нормально, все что в локалке - тоже с DUP.

По ссылке смотрел еще до того как открыть тему. Не помогло Smiley Sad

Вечером попробую поиграться с настройками хостовой сетевухи, о результатах отпишусь.

0 Kudos
windzeit
Contributor
Contributor

Попробовал - безрезультатно Smiley Sad

0 Kudos
VTsukanov
Virtuoso
Virtuoso

RRAS-а на хостовой OS нет случайно? Когда использовал VM Server, то сталкивался, и для себя решил, что проблема не с гостями, а с самим хостом (роутинг, драйвера VMware, драйвер физической сетевой карты).

0 Kudos
windzeit
Contributor
Contributor

Нет, RRAS отсутствует, ошибки маршрутизации исключены. А на хостовой ОС нужно ставить какие-либо утилиты типа vmware tools и т.д.? Я не ставил Smiley Happy

Вот что еще заметил: при обращении к гостевой ОС по сети загрузка процессора на гостевой прыгает до 50-80%, загружает Hardware interrupts.

При этом наблюдаются потери пакетов.

Вечером попробую обновить драйвера на сетевой плате хостовой.

0 Kudos
VTsukanov
Virtuoso
Virtuoso

.... Я не ставил ....

Раз ставили VMware Server, значит ставили и VMware Virtual Ethernet Adapter for VMnet(x), об этих драйверах и речь Smiley Happy

0 Kudos