Highlighted
Contributor
Contributor

VMWare Horizon Client на Linux Mint

Коллеги, доброго дня.

Прошу помочь советом.

В организации развернули сеть машин на VMWare Horizon.

Закупка тонких клиентов будет в перспективе.

А пока тонкие клиенты решено поднимать на старых машинках (2004-2006 года выпуска).

Pentium 4 ОЗУ 2 GB

На машинку поставили Linux Mint 19.2 (XFCE) 32-bit

VMWare Horizon Client for Linux устанавливается без проблем, дополнительные библиотеки тоже.

Подключение по протоколу RDP через клиент идёт, но не подходит. Не пробрасываются USB и диски.

А подключение через PCoIP или VMWare Blast при подключении вызывают только чёрный экран.

На более новой машине или на виртуалке подключение проходит штатно.

Проблема только со старыми машинами

Судя по требованиям к машине на Linux, подключение должно проходить.

Может есть какие то мнения?

0 Kudos
8 Replies
Highlighted
Enthusiast
Enthusiast

Может быть проблема в CPU.

В старых CPU нет новых инструкций.

По этой причине некоторые программы на новых машинах запускаются, а на старых нет (либо работают некорректно).

0 Kudos
Highlighted
Contributor
Contributor

Требования к инструкциям с сайта: Процессор на базе x86 или x64 с расширениями SSE2, с частотой процессора 800 МГц или выше.

Мои старички вроде соответствуют: x68 SSE, SSE2, SSE3 частота 3000 МГц и 2Гб ОЗУ...

0 Kudos
Highlighted
Champion
Champion

Добрый день!


Попробуйте убунту запустить на железе, где наблюдаются проблемы

System Requirements for Linux Client Systems

И потестировать подключение

Помимо этого посмотрите в лог работы клиента и агента, когда возникает черный экран. Наверняка там есть ошибки, которые приведут к источнику проблем.

0 Kudos
Highlighted
Contributor
Contributor

Попробуйте убунту запустить на железе, где наблюдаются проблемы

Это уже пробовали. Тот же результат...

0 Kudos
Highlighted
Champion
Champion

Окей, дальше можно вооружиться методологией траблшутинга VMware Knowledge Base

И проверять порты, драйверы и конфигурацию.

И заглянуть в логи Smiley Happy

Обычно чудес не бывает.

0 Kudos
Highlighted
Contributor
Contributor

Окей, дальше можно вооружиться методологией траблшутинга

Так и не выходит...

Все варианты испробовали. На машинках при отсутствии 64 разрядных инструкций, чёрный экран и всё.

Может, кто боролся уже с этой проблемой?

И знает решение...

0 Kudos
Highlighted
Champion
Champion

Потратить деньги и купит клиентское оборудование посовременнее Smiley Happy

Если нет сложных задач, которые решаются в VDI, можно хоть на raspberry pi делать

0 Kudos
Highlighted
Enthusiast
Enthusiast

доброго дня!

На более новой машине или на виртуалке подключение проходит штатно.

у вас новые и старые машины в одной подсети?

Черный экран возможен тогда, когда закрыты порты.

Все протоколы используют разные номера портов, посмотрите документацию.

0 Kudos