carhoth
Contributor
Contributor

Horizon 7 Linked Clones

Доброго времени суток ,камарады!

     Столкнулся с проблемой установки линкед клонов.Создаю пул в vshpere 100% завершения .В евенте Горизонта прилетает ошибка "Unable to launch from Pool rdserver for user domain\user: The broker encountered an error while processing the request, please contact support for assistance".

Подскажите куда смотреть .Если мало информации готов выдать не знаю что важно.

0 Kudos
16 Replies
NathanosBlightc
Commander
Commander

Hi

Did you ever entitle your considered users/group of AD to that linked-clone anyway?

As I understand you successfully create your Pool so you have at least one ready VM for that pool, is it correct? can you send more details about this issue, for example check the status of horizon view services and agent that are deployed inside that VM belongs to your linked-clone desktop pool?

and also check list of deployed machine in the connection server web portal, is this machine in "Available" status or not ?

Please mark my comment as the Correct Answer if this solution resolved your problem
0 Kudos
carhoth
Contributor
Contributor

Yes, I have been given the rights to the domain group for this pool. I created replica machines, but they disappeared in the connection server console after completion. And a red cross appeared on the pool itself. I can start the replica machine from the vsphere console and it works. horizon client I see my pool but when I start, I see the error this desktop currently has no desktop sources available.

0 Kudos
NathanosBlightc
Commander
Commander

can you provide a screen from your linked clone pool settings and put it here to show more detail?

and also status of list of machine in the connection server web console

Please mark my comment as the Correct Answer if this solution resolved your problem
0 Kudos
carhoth
Contributor
Contributor

Screens

0 Kudos
carhoth
Contributor
Contributor

screens

0 Kudos
carhoth
Contributor
Contributor

0 Kudos
NathanosBlightc
Commander
Commander

Until these images it's seems everything is normal but in the next image you got this error: view composer fault: 60

Please check this VMware View Composer resolution guide and investigate step by step each of troubleshooting questions. I hope it can resolve your problem, it seems you have a delay between your composer server and vcenter server.

Please mark my comment as the Correct Answer if this solution resolved your problem
0 Kudos
NathanosBlightc
Commander
Commander

For the last point you have two replica object in list of VM (vSphere screen) did you create another linked-clone desktop pools? What is the situation for that?

Please mark my comment as the Correct Answer if this solution resolved your problem
0 Kudos
carhoth
Contributor
Contributor

pool win10gold does not work. The rdserver pool is running. This is an rds farm. Win10gold is a linked clone pool in which there are 2 machines.
0 Kudos
carhoth
Contributor
Contributor

There is a suspicion that my domain administrator account does not have any rights in vsphere with which I added cvsa to horizon
Tell me what rights you need to give the account.

0 Kudos
NathanosBlightc
Commander
Commander

To avoid complexity in your troubleshooting procedure, first try one time with your administrator@vsphere.local for vCenter connection (not any user from any added domain name) and also add composer server with an local or domain admin (full access to that member server) then try again for recomposing in the linked-clone desktop pools.

However if you want to know what permissions are required, check the following links. Link 1 tell you exactly what privilege do you require for this matter:

Privileges Required for the vCenter Server User

Configure a vCenter Server User for Horizon 7 and View Composer

Please mark my comment as the Correct Answer if this solution resolved your problem
0 Kudos
Finikiez
Champion
Champion

Добрый день!

У вас на скриншоте ошибка по утилизации места на датасторе


Есть понятие допустимого оверкомита по месту на датасторе под линкед клоны.

Скорее всего это ваш случай Storage Overcommit for View Composer Linked-Clone Virtual Machines

0 Kudos
carhoth
Contributor
Contributor

Очистил хранилище осталась 1 ошибка Error during provisioning: View Composer Fault: 60

Реплики создаются рабочие (запускал в ручном режиме)

0 Kudos
carhoth
Contributor
Contributor

При созднании реплики говорит что

    

There is no network assigned to this virtual machine.

это нормально?

0 Kudos
Finikiez
Champion
Champion

Реплика - это такая неполноценная ВМ. Ее запускать не нужно, с нее создаются дельты.

По самой ошибке композера - стоит пойти и почитать лог относительно времени появления ошибки. Так будет проще и быстрее.

0 Kudos
DoctorDeath
Enthusiast
Enthusiast

1) судя по ошибкам - у Вас сторедж заполнен на 98% , при таком заполнении создаваться нове вритуальные машины небудут каике бы параметру слежения за стореджем Вы бы не установили 

2) ошибка создания пула, - у Вас не хватает прав для соединения композера с вицентром (есть подозрение что предыдущий администратора ввел там свою УЗ , а при увольнении ее заблокировали или сменили пароль.

0 Kudos