CS2020
Contributor
Contributor

6.0.0 Update 2 (Build 4192238) не меняется firmware виратульной машины

Jump to solution

Здравствуйте.
На хосте стоит ESXi 6.0.0 Update 2 (Build 4192238).
Несколько дней назад создал виртуальную машину(Version 11), в свойствах машины режим firmware назначил EFI. Несколько дней работал с ней, настраивал, перезагружал. Сегодня понадобилось перезагрузить хост. После перезагрузки хоста режим firmware у машины стал почему-то BIOS. Попытки поменять его обратно на UEFI ни к чему не приводят - в журнале появляется запись о том, что машина успешно переконфигурирована, но режим так и остается BIOS.
Машина, естественно, не грузится.
Почему не меняется режим Firmware?
Как решить проблему?

0 Kudos
4 Solutions

Accepted Solutions
e_espinel
Commander
Commander

Здравствуйте.
Версия 6.0 очень старая и не поддерживается, для этой и других проблем следует обновиться до сборки (Build) 15517548 ESXi600-202002001


Прикрепленные ссылки для скачивания и история версий

https://my.vmware.com/group/vmware/patch#search

https://kb.vmware.com/s/article/2143832

Вы должны планировать обновление до версии 6.5 или 6.7 в зависимости от имеющегося у вас оборудования и вашего лицензионного соглашения.

 

Enrique Espinel
Senior Technical Support IBM, Lenovo and VMware vSphere.
VMware VSP-SV, VTSP-SV, VTSP-HCI
VMware VTSP 4, VTSP 5.
Please mark my comment as the Correct Answer/Kudos if this solution resolved your problem Thank you.
Пожалуйста, отметьте мой комментарий как "Правильный ответ/Кудос", если это решение решило вашу проблему. Спасибо.

View solution in original post

0 Kudos
e_espinel
Commander
Commander

Здравствуйте.
К сожалению, ваше аппаратное обеспечение (Server) очень старое, и в старых матрицах аппаратной совместимости оно поддерживалось только до 4-й версии. Но это только означает, что VMware не тестировала это оборудование для других более высоких версий VMware vSphere.

Если сервер без проблем работает в версии 6.0, то, по крайней мере, у него есть некоторый шанс работать в версии 6.5, но это является риском.

Я рекомендую обновить версию 6.0 из командной строки с помощью команды обновления (Update), прикрепленной link

https://kb.vmware.com/s/article/2008939

 

 

Enrique Espinel
Senior Technical Support IBM, Lenovo and VMware vSphere.
VMware VSP-SV, VTSP-SV, VTSP-HCI
VMware VTSP 4, VTSP 5.
Please mark my comment as the Correct Answer/Kudos if this solution resolved your problem Thank you.
Пожалуйста, отметьте мой комментарий как "Правильный ответ/Кудос", если это решение решило вашу проблему. Спасибо.

View solution in original post

e_espinel
Commander
Commander

Здравствуйте.
Извините за задержку с ответом.

Файл VMware-ESXi-6.0.0-2494585-depot.zip это базовая версия 6.0, вероятно, использовали ее при обновлении с версии 5.X до версии 6.

Другие файлы *.vib - это драйверы контроллера диска для версии 5, если вам нужно место или вы не хотите запутаться, вы можете удалить их.

Первым шагом является обновление до последней доступной версии 6.0, через командную строку с помощью команды
esxcli software vib update -d "/vmfs/volumes/datastore/ESXixxxxx-xxxx.zip".

Все виртуальные машины должны быть выключены, а сервер должен находиться в режиме обслуживания.

https://kb.vmware.com/s/article/2008939

Следующие команды помогут вам определить адаптеры хранения, распознанные в ESXi, драйвер, который он использует (загружен), и установленный(ые) драйвер(ы) (файлы *.vib).

# esxcli storage core adapter list

# vmkload_mod -s HBADriver |grep Version

# esxcli software vib list | grep HBADriver

 

 

Enrique Espinel
Senior Technical Support IBM, Lenovo and VMware vSphere.
VMware VSP-SV, VTSP-SV, VTSP-HCI
VMware VTSP 4, VTSP 5.
Please mark my comment as the Correct Answer/Kudos if this solution resolved your problem Thank you.
Пожалуйста, отметьте мой комментарий как "Правильный ответ/Кудос", если это решение решило вашу проблему. Спасибо.

View solution in original post

0 Kudos
e_espinel
Commander
Commander

Здравствуйте.
Вы обновляете ESXi 6.0 до последнего доступного уровня (ESXi600-202002001.zip) и посмотрим, как он поведет себя после этого обновления.
Прилагаю ссылку, где вы можете получить

https://my.vmware.com/group/vmware/patch#search

 

Enrique Espinel
Senior Technical Support IBM, Lenovo and VMware vSphere.
VMware VSP-SV, VTSP-SV, VTSP-HCI
VMware VTSP 4, VTSP 5.
Please mark my comment as the Correct Answer/Kudos if this solution resolved your problem Thank you.
Пожалуйста, отметьте мой комментарий как "Правильный ответ/Кудос", если это решение решило вашу проблему. Спасибо.

View solution in original post

0 Kudos
18 Replies
e_espinel
Commander
Commander

Здравствуйте.
Версия 6.0 очень старая и не поддерживается, для этой и других проблем следует обновиться до сборки (Build) 15517548 ESXi600-202002001


Прикрепленные ссылки для скачивания и история версий

https://my.vmware.com/group/vmware/patch#search

https://kb.vmware.com/s/article/2143832

Вы должны планировать обновление до версии 6.5 или 6.7 в зависимости от имеющегося у вас оборудования и вашего лицензионного соглашения.

 

Enrique Espinel
Senior Technical Support IBM, Lenovo and VMware vSphere.
VMware VSP-SV, VTSP-SV, VTSP-HCI
VMware VTSP 4, VTSP 5.
Please mark my comment as the Correct Answer/Kudos if this solution resolved your problem Thank you.
Пожалуйста, отметьте мой комментарий как "Правильный ответ/Кудос", если это решение решило вашу проблему. Спасибо.
0 Kudos
CS2020
Contributor
Contributor

Спасибо.

Так и подозревал, что в версии дело. Есть и другие проблемы.

При создании машины через веб-интерфейс не удается ее создать, неактивна кнопка "Finish".

Временно решил проблему созданием новой виртуальной машины и подключением к ней диска от созданной ранее машины. Опытным путем установил, что при после следующей перезагрузки хоста или переконфигурации машины(не обязательно опции, касающейся firmware), настройки слетают на BIOS.

Про обновление задумывались и ранее.

В VMware Compatibility Guide своего оборудования не нашел.

Сервер ASUSTek RS300-E7-PS4, 4 CPUs x Intel(R) Xeon(R) CPU E31270 @ 3.40GHz.
RAID-контроллер LSI MegaRAID SAS PCI Express ROMB, Firmware Version 2.120.183-1415, BIOS Version 3.23.00 (Build September 15, 2011). Больше пока не нашел информации.

Как понять, до какой версии можем обновиться на таком железе?

И еще вопрос - обновляться лучше через загрузку с предварительно созданного загрузочного носителя или можно как-то через установленную систему скачать обновление?

Tags (1)
0 Kudos
e_espinel
Commander
Commander

Здравствуйте.
К сожалению, ваше аппаратное обеспечение (Server) очень старое, и в старых матрицах аппаратной совместимости оно поддерживалось только до 4-й версии. Но это только означает, что VMware не тестировала это оборудование для других более высоких версий VMware vSphere.

Если сервер без проблем работает в версии 6.0, то, по крайней мере, у него есть некоторый шанс работать в версии 6.5, но это является риском.

Я рекомендую обновить версию 6.0 из командной строки с помощью команды обновления (Update), прикрепленной link

https://kb.vmware.com/s/article/2008939

 

 

Enrique Espinel
Senior Technical Support IBM, Lenovo and VMware vSphere.
VMware VSP-SV, VTSP-SV, VTSP-HCI
VMware VTSP 4, VTSP 5.
Please mark my comment as the Correct Answer/Kudos if this solution resolved your problem Thank you.
Пожалуйста, отметьте мой комментарий как "Правильный ответ/Кудос", если это решение решило вашу проблему. Спасибо.
CS2020
Contributor
Contributor

Здравствуйте.

Скажите пожалуйста, если установка ESXi производилась с интегрированием  стороннего драйвера RAID-контроллера, то обновление так же можно производить по инструкциям в ссылке или есть какие-то нюансы?

Я вообще точно не уверен, был ли интегрирован драйвер или нет. Это как-то можно понять? И как узнать модель контроллера?

В vSphere Client, в Configuration-Storage вижу "Controller 5000EA61C0006650 (LSI MegaRAID SAS PCI Express ROMB)", в веб-интерфейсе, в Hardware - LSI / Symbios Logic MegaRAID SAS GEN2 Controller. В обозревателе datastore вижу файлы vib, очень похожие на драйверы от контроллера - 500.04.V0.53-0003.vib и LSI_bootbank_lsiprovider-500.04.V0.38-0006.vib и еще есть архив VMware-ESXi-6.0.0-2494585-depot.zip.

0 Kudos
CS2020
Contributor
Contributor

Здравствуйте.

С обновлением в пределах версии 6.0.0 разобрался. Как посмотреть версию установленного драйвера на контроллер - то же.

Остался вопрос - как понять до какой версии 6.5 стоит обновляться и как это лучше делать? Тоже из командной строки или лучше с установочного носителя?

Как все-таки понять, какая модель контроллера у меня стоит?

0 Kudos
e_espinel
Commander
Commander

Здравствуйте.
Извините за задержку с ответом.

Файл VMware-ESXi-6.0.0-2494585-depot.zip это базовая версия 6.0, вероятно, использовали ее при обновлении с версии 5.X до версии 6.

Другие файлы *.vib - это драйверы контроллера диска для версии 5, если вам нужно место или вы не хотите запутаться, вы можете удалить их.

Первым шагом является обновление до последней доступной версии 6.0, через командную строку с помощью команды
esxcli software vib update -d "/vmfs/volumes/datastore/ESXixxxxx-xxxx.zip".

Все виртуальные машины должны быть выключены, а сервер должен находиться в режиме обслуживания.

https://kb.vmware.com/s/article/2008939

Следующие команды помогут вам определить адаптеры хранения, распознанные в ESXi, драйвер, который он использует (загружен), и установленный(ые) драйвер(ы) (файлы *.vib).

# esxcli storage core adapter list

# vmkload_mod -s HBADriver |grep Version

# esxcli software vib list | grep HBADriver

 

 

Enrique Espinel
Senior Technical Support IBM, Lenovo and VMware vSphere.
VMware VSP-SV, VTSP-SV, VTSP-HCI
VMware VTSP 4, VTSP 5.
Please mark my comment as the Correct Answer/Kudos if this solution resolved your problem Thank you.
Пожалуйста, отметьте мой комментарий как "Правильный ответ/Кудос", если это решение решило вашу проблему. Спасибо.
0 Kudos
CS2020
Contributor
Contributor

Благодарю, с обновлением в пределах версии разобрался, проблем возникнуть не должно.

Чем, кстати различаются варианты обновления esxcli software vib update и esxcli software profile update?

0 Kudos
CS2020
Contributor
Contributor

Команда esxcli storage core adapter list:
HBA Name Driver Link State UID Capabilities Description
-------- ------------ ---------- -------------- ------------ ------------------------------------------------------------------------
vmhba2 megaraid_sas link-n/a unknown.vmhba2 (0000:04:00.0) LSI / Symbios Logic MegaRAID SAS GEN2 Controller

Команда vmkload_mod -s HBADriver:
vmkload_mod: Can not find module HBADriver: Not found

Команда esxcli software vib list показывает, что установлен драйвер:
Name Version Vendor Acceptance Level Install Date
----------------------------- ------------------------------------ ------ ---------------- ------------
lsiprovider 500.04.V0.53-0003 LSI VMwareAccepted 2014-10-28

С ключом | grep HBADriver эта команда ничего не выдает.

0 Kudos
e_espinel
Commander
Commander

Здравствуйте.
Кажется, я забыл детализировать HBADriver - это Драйвер, который использует адаптер в списке, полученном с помощью первой команды (колонка 2).
В вашем случае это megaraid_sas
Тогда следующими командами будут:

# vmkload_mod -s  megaraid_sas |grep Version

# esxcli software vib list | grep megaraid_sas

Мы используем esxcli software vib update, когда собираемся установить патч (группу исправлений (grup fixes)), но без изменения версии, он также используется для установки или обновления продукта например Driver, tools.


Мы используем esxcli Software profile, когда собираемся изменить полный базовый образ, это эквивалентно методу обновления ISO и используется, когда мы меняем версию, например  с версии 6 на версию 7.

 

Enrique Espinel
Senior Technical Support IBM, Lenovo and VMware vSphere.
VMware VSP-SV, VTSP-SV, VTSP-HCI
VMware VTSP 4, VTSP 5.
Please mark my comment as the Correct Answer/Kudos if this solution resolved your problem Thank you.
Пожалуйста, отметьте мой комментарий как "Правильный ответ/Кудос", если это решение решило вашу проблему. Спасибо.
0 Kudos
CS2020
Contributor
Contributor

Команда vmkload_mod -s megaraid_sas |grep Version:
Version: Version 6.603.55.00.1vmw, Build: 2494585, Interface: 9.2 Built on: Feb 5 2015

Команда esxcli software vib list | grep megaraid_sas ничего не выдает, но я выше написал уже какая версия драйвера стоит:

Name Version Vendor Acceptance Level Install Date
----------------------------- ------------------------------------ ------ ---------------- ------------
lsiprovider 500.04.V0.53-0003 LSI VMwareAccepted 2014-10-28

Это единственный сторонний vib, который установлен.

0 Kudos
e_espinel
Commander
Commander

Здравствуйте.
Вы обновляете ESXi 6.0 до последнего доступного уровня (ESXi600-202002001.zip) и посмотрим, как он поведет себя после этого обновления.
Прилагаю ссылку, где вы можете получить

https://my.vmware.com/group/vmware/patch#search

 

Enrique Espinel
Senior Technical Support IBM, Lenovo and VMware vSphere.
VMware VSP-SV, VTSP-SV, VTSP-HCI
VMware VTSP 4, VTSP 5.
Please mark my comment as the Correct Answer/Kudos if this solution resolved your problem Thank you.
Пожалуйста, отметьте мой комментарий как "Правильный ответ/Кудос", если это решение решило вашу проблему. Спасибо.
0 Kudos
CS2020
Contributor
Contributor

Здравствуйте.

Да, спасибо, я знаю, где взять патч. К этому обновлению я готов, уже протестировал эту процедуру на другом сервере.

0 Kudos
CS2020
Contributor
Contributor

Здравствуйте.
Обновился до до сборки (Build) 15517548 ESXi600-202002001.
В целом все прошло нормально, изначальная проблема ушла, в свойствах машины режим загрузки поменял на UEFI.
Через какое-то время после обновления меня выбило из веб-интерфейса(появилось окно "соединение потеряно"),а при повторном логоне он отображался некорректно - был доступен только раздел с виртуальными машинами. Я повторно перезагрузил хост и после этого эта проблема не повторялась(прошло уже несколько часов). Возможно вообще дело было в браузере - над было почистить кеш и т.д.
Сейчас вроде бы все нормально работает, но смущает несколько моментов:
1. В VMware vSphere Client на вкладке Summary висит надпись "Configuration issues".
2. В веб-интерфейсе в Monitor-Hardware-System-Sensors напротив VMware Rollup Health State статус - Red. Возможно это связано с тем, что не работает один из вентиляторов - напротив одного из них тоже статус Red.
3. В этом же разделе большинство пунктов начинаются с Unspecified. Например - Unspecified 0 CPU1 Temperature и т.д.
4. В Logs в /var/log/vmkwarning.log есть разные сообщения об оборудовании. Например - cpu2:38890 opID=50ad5b33)WARNING: CBT: 2056: Unsupported ioctl 61 или cpu5:33212)WARNING: ScsiScan: 1706: Failed to add path vmhba2:C0:T1:L0 : Not found или cpu4:32949)WARNING: NMP: nmpUnclaimPath:1590: Physical path "vmhba36:C0:T0:L0" is the last path to NMP device "Unregistered Device". The device has been unregistered. Но наверное это не очень критично, так как подобные сообщения были и до обновления, судя по дате.
В целом же пока все работает, спасибо вам еще раз.

Как теперь понять, стоит ли обновляться до 6.5 и как это лучше сделать?
На сколько я понимаю, нужно все-таки как-то узнать модель контроллера и попытаться найти последние драйверы под него?

0 Kudos
CS2020
Contributor
Contributor

Немного поискал в Интернете.

Для того, чтобы RAID-массив определился, не нужно никаких сторонних файлов vib.

А тот vib, что стоит сейчас, отвечает только за мониторинг состояния массивов.

0 Kudos
e_espinel
Commander
Commander

Здравствуйте.
Выполните следующую команду и представьте результат
# esxcli hardware ipmi sdr list
С помощью этого мы увидим, есть ли на сервере ASUS устройства, работающие как BMC или IPMI. и есть ли у него возможность показывать различные датчики.

Драйверы  inbox (Native) - это драйверы, предоставляемые VMware, которые обычно являются более старыми.
и основные.


Драйверы Async (Partner) предоставляются производителем адаптера или сервера и являются более современными и полными.


Обычно рекомендуется использовать драйверы производителя.

Enrique Espinel
Senior Technical Support IBM, Lenovo and VMware vSphere.
VMware VSP-SV, VTSP-SV, VTSP-HCI
VMware VTSP 4, VTSP 5.
Please mark my comment as the Correct Answer/Kudos if this solution resolved your problem Thank you.
Пожалуйста, отметьте мой комментарий как "Правильный ответ/Кудос", если это решение решило вашу проблему. Спасибо.
0 Kudos
CS2020
Contributor
Contributor

Здравствуйте.

esxcli hardware ipmi sdr list
Node-Sensor Description Entity-Instance Computed Reading Base Unit Raw Reading Timestamp/Comment Raw
----------- -------------------------------- --------------- ---------------- ----------- ----------- ------------------- ---
0.79 Unspecified 0 ChassisIntrusion 0 0.0 N/A unspecified 0 2021-05-21T10:14:52
0.49 Unspecified 0 CPU1 Temperature 0.0 41 degrees C 41 2021-05-21T10:14:52
0.51 Unspecified 0 MB1 Temperature 0.0 31 degrees C 31 2021-05-21T10:14:52
0.204 Unspecified 0 TR1 Temperature 0.0 0 degrees C 0 2021-05-21T10:14:52
0.52 Unspecified 0 VCORE1 0.0 1.016 Volts 127 2021-05-21T10:14:52
0.56 Unspecified 0 +12V 0.0 12.192 Volts 127 2021-05-21T10:14:52
0.54 Unspecified 0 +3.3V 0.0 3.312 Volts 207 2021-05-21T10:14:52
0.55 Unspecified 0 +5V 0.0 5.08 Volts 127 2021-05-21T10:14:52
0.66 Unspecified 0 +1.5V 0.0 1.464 Volts 183 2021-05-21T10:14:52
0.64 Unspecified 0 +3VSB 0.0 3.408 Volts 213 2021-05-21T10:14:52
0.60 Unspecified 0 VBAT 0.0 3.36 Volts 210 2021-05-21T10:14:52
0.160 Unspecified 0 CPU_FAN1 0.0 4080 RPM 51 2021-05-21T10:14:52
0.162 Unspecified 0 FRNT_FAN1 0.0 4240 RPM 53 2021-05-21T10:14:52
0.163 Unspecified 0 FRNT_FAN2 0.0 4400 RPM 55 2021-05-21T10:14:52
0.164 Unspecified 0 FRNT_FAN3 0.0 4000 RPM 50 2021-05-21T10:14:52
0.166 Unspecified 0 REAR_FAN1 0.0 0 RPM 0 2021-05-21T10:14:52

Доступ к IPMI у меня есть по веб-интерфейсу, но в нем ничего критичного не вижу кроме одного неработающего вентиятора.

0 Kudos
e_espinel
Commander
Commander

Здравствуйте.
Я думаю, что это все, что мы можем сделать, поскольку версия 6.0 прекратила поддержку, я не думаю, что мы сможем найти более обновленные драйверы или драйверы, которые работают на этой версии.

Я рекомендую вам как можно скорее заменить вышедший из строя вентилятор.

 

Enrique Espinel
Senior Technical Support IBM, Lenovo and VMware vSphere.
VMware VSP-SV, VTSP-SV, VTSP-HCI
VMware VTSP 4, VTSP 5.
Please mark my comment as the Correct Answer/Kudos if this solution resolved your problem Thank you.
Пожалуйста, отметьте мой комментарий как "Правильный ответ/Кудос", если это решение решило вашу проблему. Спасибо.
0 Kudos
CS2020
Contributor
Contributor

Спасибо.

Стоит ли пробовать обновляться до 6.5?

В этой ветке форума пишут, что RAID-контроллеры этой версии поддерживаются даже версией 6.7, при этом служба мониторинга состояния работает нормально в 6.5 https://communities.vmware.com/t5/Russian-Discussions/LSI-SMIS-%D0%BD%D0%B0-ESXi-6-7/m-p/2823535/hig...

Если да, то как это лучше сделать?

0 Kudos