shaverdoff
Contributor
Contributor

проблема с обращением к вкладке performance на хостах

До не давнего времени вкладка performance на хостах на кнопке overview работала успешно.

теперь вот такое окошко постоянно.

не пойму что же я отключил?

какой сервис грохнул не в значай?

error.png

vcenter  имеет айпи 192.168.1.38 как раз

по доменному имени резолвится.

на вкладке plug-in manager

появились две ошибки

plugin.png

как их устранить?

однажды я ставил всфер вебклиента на машину вцентр. после того как насмотрелся на его прожорливость - грохнул. но помнится и до установки всфер вебклиента вкладка чтото отображала.

0 Kudos
14 Replies
VTsukanov
Virtuoso
Virtuoso

Ошибка - больше всего похоже на Enabling the Virtual Server Service status and hardware status plugins fails , но сначала проверьте что у вас на порту 8443 таки работает томкат (telnet 192.168.1.38 8443) и сервис "VMware VirtualCenter Management Webservices" работает.

Performance - если томката нет, будет приблизительно такая реакция


shaverdoff
Contributor
Contributor

да ошибка именно та же. пару раз натыкался на нее. сервиса такого нет. томкат прожорливый гад.. и java.exe аш 3 штукик по 500 метров  кушают. подвопрос - как их ограничить в потреблении? томката то нету.. почему ява осталась не понятно.

0 Kudos
VTsukanov
Virtuoso
Virtuoso

Что значит "томката нету"? Что то слушает на порту 8443? (netstat -anb)

(+)

Что касается подвопроса - требования в 4.1 были такие

VMware VirtualCenter Management WebServices requires 128Mb to 1.5GB of memory which is allocated at startup.

В принципе ограничить потребление памяти можно с помощью опций командной строки java, но я бы вам не рекомендовал трогать java.

0 Kudos
shaverdoff
Contributor
Contributor

после установки вебклиента всфер томкат не появился 8443 порт никто не слушает..

0 Kudos
shaverdoff
Contributor
Contributor

по поводу явы понял. увеличу памать вцентру. а вот с томкатом как быть не пойму. вебклиент поставил через веб все показывается. даже консоль машинок..

0 Kudos
VTsukanov
Virtuoso
Virtuoso

В сервисах Windows ищите VMware VirtualCenter Management Webservices и разбирайтесь почему не работает

0 Kudos
shaverdoff
Contributor
Contributor

у меня и этой службы нет.

0 Kudos
VTsukanov
Virtuoso
Virtuoso

И куда ж воно делось ...

А VI client (обычный, не web) вообще работал нормально?

C:\Program Files\VMware\Infrastructure\tomcat - есть?

А директория logs внутри?

0 Kudos
shaverdoff
Contributor
Contributor

обычный клиент нормально работает

переставил вебклиент. на порто 9090 и 9443 отвечает

tomcat - нет такой директори..

я так понимаю что при попытке удаления вебклиента вфсер я еще и томкат грохнул. а он ставится вместе с вцентр сервером?

0 Kudos
VTsukanov
Virtuoso
Virtuoso

Да, это часть инсталляции vCenter. А вы сносили руками?

0 Kudos
shaverdoff
Contributor
Contributor

да. видимо прийдется вцентр переставлять.... эх елыпалы и ведь бэкапы как назлоперезаписались того дня

0 Kudos
VTsukanov
Virtuoso
Virtuoso

А вы сносили руками?

да....

"Ну вы блин даете..." (c) не мой

Я не знаю как восстановить "VMware VirtualCenter Management Webservices" аккуратно (без перестановки vCenter), может кто то из коммунити такое делал......

0 Kudos
shaverdoff
Contributor
Contributor

славо богу пока в продакшин не вводил так эксперименты и экспириенс...

поставим вцентр на новую машину правильно отвинченную. натравим все что положено сделаем клон и не будем трогать

0 Kudos
VTsukanov
Virtuoso
Virtuoso

Ну раз окружение тестовое то легче

0 Kudos