ooott
Contributor
Contributor

Установка Windows server 2016 на ESXi-6.5.0-20170104001-standard ( HELP !!! )

Доброго всем дня.
Пытаюсь установить на ESXi-6.5 О.С. Windows server 2016.
Создаю VM, Выбираю тип контроллера VMware Paravirtual, подключаю дистрибутив Win. и VMware-tools как DVD приводы.
Грузится инсталятор, жму установить, ругается на отсутствие драйвера,  с диска с  VMware-tools подставляю драйвер и получаю ошибку "Новые драйверы устройств не найдены"!!!
Что детать?

13 Replies
Finikiez
Champion
Champion

Добрый день!

Смонтированный ISO с тулзами вы откуда-то отдельно скачивали?

Попробуйте описанный способ с одним CD\DVD VMware Documentation for Windows Server 2016

Как альтернативный вариант можно установить с LSI контроллером и затем заменить его на PVSCSI VMware Knowledge Base  раздел To configure an existing Windows boot disk to use a PVSCSI adapter

0 Kudos
ooott
Contributor
Contributor

Добрый день.
ISO с тулзами брал из самого ESXi и качал с сайта WMware, контроллеры перебрал все. Результат =0


0 Kudos
IT_pilot
Expert
Expert

LSI контроллер должен видеть в любом случае.

Попробуйте еще раз с самого начала.

Как поставите систему и установите тулзы выключаете ВМ, добаваляете паравиртуальный контроллер. Включаете. Windows сам устанавливает драйвера. Затем опять выключаете и заменяете LSI на Paravirtual.

http://it-pilot.ru
Finikiez
Champion
Champion

Создайте пустую машину с контроллером LSI Logic SAS. Оставьте 1 CD\DVD-ROM.

Запустите инсталлятор Windows.

ОС должна видеть этот контроллер без проблем.


Если не видит, то вопрос - что за ISO образ Windows вы используете?

0 Kudos
ooott
Contributor
Contributor

Качаю еще раз с Microsoft Evaluation Center
Возможно битый образ, windows 10 установился без проблем. 

0 Kudos
ooott
Contributor
Contributor

С 2016 server
история повторяется.

0 Kudos
Finikiez
Champion
Champion

Полагаю, что все-таки что-то корраптится при скачивании или попытки ISO загрузить куда-либо.

Проверьте MD5 чек суммы.

Как пример аналогичной проблемы esxi 6.5: Windows 2012/2016 "A media driver your computer needs is missing"

0 Kudos
ARXITEKTOR
Contributor
Contributor

Попробуй:

1. Если это первая виртуалка на хосте переставь ESXi.

2. Как говорили: скачай образ из другого источника или скачай другой билд.

На тех же торрентах есть оригинальные образы.

После загрузки проверь контрольную сумму несколькими программами

3. Что за конфигурация хоста ? HDD на хосте или хранилка ?

4. как закидываешь isoшник на хост ? можеь бъёться по дороге.

0 Kudos
ooott
Contributor
Contributor

Все манипуляции с контроллерами и драйверами потерпели фиаско.
Достиг необходимого результата путем обновления 2012R2 до 2016, сроки жмут...
Как разберусь в чем дело было, обязательно напишу.

0 Kudos
atom134
Contributor
Contributor

Надеюсь у вас удалось разобраться. Если так - поделитесь пожалуйста опытом решения.

0 Kudos
ruschestor
Contributor
Contributor

Недавно столкнулся с идентичной проблемой, но на vSphere 6.0 и vCenter 6.5. Как оказалось, проблема состоит из двух частей:

1. ISO c Windows Server 2016 загрузился на Datastore через vCenter WebClient (с помощью IE) не полностью. Загрузилось примерно 4 ГБ или 5 ГБ (при повторной загрузке IE даже крашнулся), но в то же время установщик запускался. Решается загрузкой ISO через Chrome или Firefox. После загрузки проверяйте размер!

2. Отсутствие драйвера VMware Paravirtual. Его надо подключить во время установки через VMware Tools. Вы это уже делали, но на всякий случай полная инструкция - Windows Server 2016 VM with a VMware Paravirtual SCSI controller – 4sysops

Также столкнулся с проблемой невозможности загрузить установщик после переключения в режиме UEFI вместо BIOS.

Надеюсь, что это поможет решить проблему.

0 Kudos
Ivan_0
Contributor
Contributor

У меня такая же проблема при установке Win Server 2016 на SSD (NVMe и SATA)..

Думаю что в Server 2016 просто нет драйверов на "десктопные" версии дисков - своего рода предупреждение что не стоит этого делать!))

0 Kudos
Ivan_0
Contributor
Contributor

Нашёл в чем у меня был косяк, выше об этом писали..))

Образ как-то не весь перекинулся на datasore в vmware - был 5.7 а перекинулось 4 ГБ..

0 Kudos