Volff
Contributor
Contributor

Не определяется Trim на одном из дисков.

Здравствуйте, наблюдаю странную ситуацию с поддержкой Trim на дисках.

Имеется ESXi 6.5

на нём стоят 2 SSD диска одного и того же вендара на

240 и 480 Гб одного и того же года выпуска.

[root@esx1:~] esxcli storage core device vaai status get

mpx.vmhba32:C0:T0:L0

   VAAI Plugin Name:

   ATS Status: unsupported

   Clone Status: unsupported

   Zero Status: unsupported

   Delete Status: unsupported

t10.ATA_____SSD_240GB_______________________________201910210027________

   VAAI Plugin Name:

   ATS Status: unsupported

   Clone Status: unsupported

   Zero Status: supported

   Delete Status: supported

mpx.vmhba0:C0:T0:L0

   VAAI Plugin Name:

   ATS Status: unsupported

   Clone Status: unsupported

   Zero Status: unsupported

   Delete Status: unsupported

t10.ATA_____SSD_480GB_______________________________SCRW19111905F0035___

   VAAI Plugin Name:

   ATS Status: unsupported

   Clone Status: unsupported

   Zero Status: supported

   Delete Status: unsupported

На 240 esxi видит TRIM

На 480 нет.

Вполне возможно ошибка прошивки.

Есть ли возможность принудительно его включить в esxi ?

Смена портов контроллера не помогла. Статус ползает вместе с диском.

Под виндой трим работает без проблем.

При создании толстого диска с агрессивным занулением , диск создаётся долго в отличие от.240-го.

esxtop показывает ошибку.

DEVICE                                                             CLONE_RD CLONE_WR  CLONE_F MBC_RD/s MBC_WR/s      ATS ATSF     ZERO   ZERO_F MBZERO/s   DELETE DELETE_F  MBDEL/s

mpx.vmhba0:C0:T0:L0                                                       0                   0                 0            0.00             0.00           0        0             0              0             0.00                0                   0          0.00

mpx.vmhba32:C0:T0:L0                                                     0                   0                 0            0.00             0.00           0        0             0              0             0.00                0                   0          0.00

t10.ATA_____SSD_240GB_______________                  0                   0                 0            0.00             0.00           0        0             0              0             0.00      254190                   0          0.00

t10.ATA_____SSD_480GB_______________                  0                   0                 0            0.00             0.00           0        0             0      20481             0.00                0                   0          0.00

Если таблица поломалась, то:

  ZERO_F = 20481

на диске с 480гб

Фактически zerored не работает.

[root@esx1:~] esxcli storage vmfs unmap --volume-label=Datastore_480

Devices backing volume 5e4ece54-3ccaa494-fa31-001b212953c7 do not support UNMAP

У кого какие идеи?

Сообщение отредактировано: Denis Volkov

Tags (2)
0 Kudos
1 Reply
Finikiez
Champion
Champion

Добрый день!

Подскажите вендора\модель дисков, о которых вы говорите.

0 Kudos