ne4HUk
Contributor
Contributor

Не могу добавить роль пользователю

Jump to solution

Доброго дня!

vsphere 6.7 кластер, две ноды.

Пытаюсь сделать read only пользователя для мониторинга, пользователя создал, но когда хочу привязать к нему соответствующую роль получаю облом в виде пустого списка ролей, точнее он не активный.

Как победить?

Tags (1)
1 Solution

Accepted Solutions
Finikiez
Champion
Champion

Очевидно, что группа Administrators в SSO должна быть.

Предлагаю начать с просто - перезагрузки VC.

Если не помогает, то надо погружаться в логи: vpxd, SSO, vsphere-client и дебажить по временной метки, когда вы пытаетесь открыть список ролей.

View solution in original post

0 Kudos
10 Replies
Finikiez
Champion
Champion

Добрый день!

Это вы пытаетесь сделать на стэндэлон хосте или через vcenter?

0 Kudos
ne4HUk
Contributor
Contributor

Через vcenter.

0 Kudos
Finikiez
Champion
Champion

С какими правами вы залогинены в web client?  administrator@vsphere.local?

Другим браузером пробовали пользоваться? почистить кэш\куки и т.п.?


Альтернативно попробуйте через web client (flex) те же самые действия.

0 Kudos
ne4HUk
Contributor
Contributor

Логинюсь: administrator@vsphere.local

Другими браузерами пробовал, альтернативны клиентом пробовал.

0 Kudos
Finikiez
Champion
Champion

Сами роли при этом существуют?

Можете показать скриншоты со списком ролей?

Если сделать новую кастомную роль, получается назначить пользователя?

Раньше это работало?

VC с нуля поставлен или обновлен с какой-то версии?

0 Kudos
ne4HUk
Contributor
Contributor

Интересно... Список ролей пустой, создать роль не могу, кнопки создания/редактирования не активны.

Работало раньше или нет не знаю, не проверял. Система ставилась "с нуля".

0 Kudos
Finikiez
Champion
Champion

Проверяйте права доступа на vcenter для пользователя administrators@vsphere.local, а именно  какая роль ему назначена

И кто входит в группу administrators  в single sign on?

0 Kudos
ne4HUk
Contributor
Contributor

У Administrator роль Administrator

В single sign on не вижу группу Administrators, хотя в ролях она есть.

0 Kudos
Finikiez
Champion
Champion

Очевидно, что группа Administrators в SSO должна быть.

Предлагаю начать с просто - перезагрузки VC.

Если не помогает, то надо погружаться в логи: vpxd, SSO, vsphere-client и дебажить по временной метки, когда вы пытаетесь открыть список ролей.

View solution in original post

0 Kudos
ne4HUk
Contributor
Contributor

Спасибо! Перезагрузка действительно помогла.