Contributor
Contributor

czesciowo nie dziala integracja z AD w ESX 4.1

Jump to solution

Witam

Wczoraj spotkala mnie koeljna niespodzianka. Mam dwa serwery ESX, oba byly dodane do AD, do maszyn na tych ESXach userzy byli przypisani z AD  - wszystko dzialalo. Teraz proba wyszukania usera w AD konczy sie bledem: "Call "UserDirectory.RetrieveUserGroups" for object "UserDirectory" on vCenter Server "srv2.uczelnia.local" failed."

Jezeli na poziomie serwera ESX wchodze w configuration> Authentication services widze  ze jest wybrany typ Active Directory, wskazana jest moja domena, ale w Trusted Domain Controler PUSTO, na 100% byla tam nazwa jednego z moich kontrolerow domeny.

Czego  nie rozumiem - ano tego ze niby jakim sposobem laczac sie z vCenter za pomoca dedykownae klineta uzywam logowania z domena i to dziala.

Zeby nie bylo latwo, te dwa esx to Dell, mialem zainstalwoana OMSA na nich - dzisiaj probuje sie zalogowac - blad - OMSA tez nie widzi domeny i tym samym uzywajac domenowego konta nie mozna sie zalogowac. uzywaja lokanlego konta - nieznany blad.

W AD w ADUC widze te dwa serwery ESX.

Ma ktos pomysl co moglo sie stac i jak to naprawic (nie niszczac konfoguracji uprawnien)?

ODpiecie od domeny i dopiecie pewnie usunie przypisane uprawnienia userom domenowym.

0 Kudos
1 Solution

Accepted Solutions
Enthusiast
Enthusiast

Miałem podobne problemy z tym że na linuxowym vCenter appliance. W moim przypadku jedyne co pomagało to ponowne dodatnie do domeny.

Natomiast nasuwa mi się zasadniczo inne pytanie - w jakim celu dodawałeś ESXi do domeny? Pytam o to dlatego że osobiście wydaje mi się że jest to uzasadnione jedynie po to aby dodać uprawnienia dla grupy administratorów, jest to relatywnie prosta konfiguracja bo dodajemy jedną grupę do administratorów na ESXach i ponowienie takiej konfiguracji nie wymaga wiele czasu. Bardziej skomplikowane konfiguracje, związane z uprawnieniami do zasobów, powinny być moim zdaniem konfigurowane na vCenter które posiadasz.

W mojej konfiguracji ESXi dodanych do domeny, pole "Trusted Controllers" również jest puste i nie wpływa to na działanie (parametr ten ma inna funkcję).

Odnośnie logowania, to owszem do vCenter logujesz się za pomocą AD, natomiast już vCenter z ESXi komunikuje się bez udziału uprawnień AD (vCenter tak naprawdę zakłada sobie dodatkowe konto na ESXi).

View solution in original post

0 Kudos
6 Replies
Leadership
Leadership

Sprawdz godzinę i serwer DNS.

http://blog.inleo.pl @maciejlelusz
0 Kudos
Contributor
Contributor

DNS poprawnie ustawione i rozwizuja nazwy

czas u mnie zawsze jest z NTP - tez poprawny

w zalaczniku zrzut ekranu z konfiguracja domeny z vCenter

Czy u Was jest wypisana nazwa serwera w trusted domain controller?

0 Kudos
Enthusiast
Enthusiast

Miałem podobne problemy z tym że na linuxowym vCenter appliance. W moim przypadku jedyne co pomagało to ponowne dodatnie do domeny.

Natomiast nasuwa mi się zasadniczo inne pytanie - w jakim celu dodawałeś ESXi do domeny? Pytam o to dlatego że osobiście wydaje mi się że jest to uzasadnione jedynie po to aby dodać uprawnienia dla grupy administratorów, jest to relatywnie prosta konfiguracja bo dodajemy jedną grupę do administratorów na ESXach i ponowienie takiej konfiguracji nie wymaga wiele czasu. Bardziej skomplikowane konfiguracje, związane z uprawnieniami do zasobów, powinny być moim zdaniem konfigurowane na vCenter które posiadasz.

W mojej konfiguracji ESXi dodanych do domeny, pole "Trusted Controllers" również jest puste i nie wpływa to na działanie (parametr ten ma inna funkcję).

Odnośnie logowania, to owszem do vCenter logujesz się za pomocą AD, natomiast już vCenter z ESXi komunikuje się bez udziału uprawnień AD (vCenter tak naprawdę zakłada sobie dodatkowe konto na ESXi).

View solution in original post

0 Kudos
Contributor
Contributor

Dear Sender

Thank You for Your email. I'm on Business Trip till June 3rd in Time Zone GMT -8. Please accept some delays in answering Your email.

Kindly Regards

Krzysztof Szafer

0 Kudos
Contributor
Contributor

Ja mam vCenter na w2k8r2 zainstalowane.

Ale ja nigdzie nie pisalem ze mam ESXi - mam "pelna" wersje ESX 4.1

Dodalem je (moze niepotzrebnie) po to zeby autiryzowac userow dobierajacych sie do VM przez web access - potrzebne to bylo do logowania zintegrowanego z domena. Z tym ze nic z tego nie wyszlo po tym jak sie okazalo ze mozna im przydzielic tylko role root albo gosc.

0 Kudos
Contributor
Contributor

ehh - przy okazji rozwiaazywania innego problemu kilka mieisiecy temu vmware vcenter serwer dzialal na uprawnieniach admina domenowego. Haslo wygaslo i stad problem z wyszukiwaniem. A ze nie restartowalem vCenter od dawna to dopiero przy restarcie uslugi na okolicznosc zwiekszenia czasu timeout sprawa wyszla.

http://kb.vmware.com/selfservice/microsites/search.do?language=en_US&cmd=displayKC&externalId=103132...

0 Kudos