pkolacz
Contributor
Contributor

ESXi 5.0 utracony dostęp zdalny

Jump to solution

Witam wszystkich.

Mam problem z dostępem zdalnym do hosta ESXi 5.0. Ale może zacznę od początku.

Wszystko było OK aż do przeresetowania całej maszyny. Utraciłem zdalne zarządzaniem serwerem ESXi.

Przestało działać:

- nie mogę otworzyć strony informacyjnej przez www, https://ip_serwer

- nie mogę połączyć się zdalnie przez ssh (np. putty)

- nie łącze się za pomocą VMware vSphere Client

Co działa?

- wszystkie zwirtualizowane systemy działają bez zarzutu,

- ping na ip_serwer odpowiada

- badanie portów telnetem ip_server: port 80 nie odpowiada, port 902 OK

- mogę pracować lokalnie (ESXi Shell)

Co zrobiłem do tej pory:

- w TrobleShooting Mode Option; ssh i ESXi Shell jest Enabled, Timeout ustawione na 0, wykonałem również Restart Management Agents

- sprawdziłem usługi hostd i vpxa (działają) ale mimo to wykonałem ich restart (/etc/init.d/usługa restart)

- dodatkowo services.sh restart

- blokada Lockdown Mode jest na szaro (czyli nie aktywna)

- wyświetliłem role firewala na hoście ESXi - wyglądają poprawnie,

- ustawienia mojego komputera, raczej są OK, mogę korzystać z dostępu zdalnego do innych serwerów ESXi

Reasumując. Wszystko co udało mi się sprawdzić działa ok, ale dalej nie mogę się połączyć. Praca z każdą pierdołą w serwerowni nie jest przyjemna. :(

Z góry dzięki za szybką i rzeczową pomoc.

0 Kudos
1 Solution

Accepted Solutions
inleo
Leadership
Leadership

Oki, sorki za te pierwsze w sumie nie sprawdziłem :smileygrin:

Masz w firewall domyślną polityke DROP... spróbuj ją zmienić na przepuszczanie wszystkiego, za pomocą komendy:

esxcli network firewall set --defaultaction true

Ewentualnie weź go na chwilę wyłącz:

esxcli network firewall unload

i daj znać czy działa Smiley Happy

http://blog.inleo.pl @maciejlelusz

View solution in original post

0 Kudos
6 Replies
inleo
Leadership
Leadership

Podeslij wyniki dwóch komend:

netstat -npea

ps aux

i może trzeciej:

esxcli network firewall get

http://blog.inleo.pl @maciejlelusz
0 Kudos
pkolacz
Contributor
Contributor

Dzięki za natychmiastową reakcję Smiley Wink

Ale chyba Twoja pomoc dotyczy innej wersji oprogramowania albo ja robię coś nie tak.

Ale wracając do tematu:

netstat -nppea

polecenie mi nie działa, samo netstat nie zwraca pomocy tylko informację: -sh: netstat: not found.

ps aux

tutaj system odpowiada: ps: no non-option arguments i podaje listę dopuszczalnych argumentów.

W pomocy wmvare przy wersji ESX  często jest wykorzystywane polecenie ps -ej | grep nazwa_usługi. W ESXi niestety to nie działa posiłkuje się ps | grep nazwa_usługi. I tak polecenie ps | grep aux zwróciło:

18131 18131 sfcb-vmware_aux /sbin/sfcbd

18132 18131 sfcb-vmware_aux /sbin/sfcbd

18133 18131 sfcb-vmware_aux /sbin/sfcbd

18134 18131 sfcb-vmware_aux /sbin/sfcbd

18135 18131 sfcb-vmware_aux /sbin/sfcbd

18136 18131 sfcb-vmware_aux /sbin/sfcbd

Wynik jest identyczny (oprócz nr) jak w innym sprawnie działającym hoście.

esxcli network firewall get zwraca

Deflaut Action: Drop

Enabled: true

Loaded: true

Ten wynik jest również identyczny z sprawnym hostem.

0 Kudos
inleo
Leadership
Leadership

Oki, sorki za te pierwsze w sumie nie sprawdziłem :smileygrin:

Masz w firewall domyślną polityke DROP... spróbuj ją zmienić na przepuszczanie wszystkiego, za pomocą komendy:

esxcli network firewall set --defaultaction true

Ewentualnie weź go na chwilę wyłącz:

esxcli network firewall unload

i daj znać czy działa Smiley Happy

http://blog.inleo.pl @maciejlelusz

View solution in original post

0 Kudos
pkolacz
Contributor
Contributor

Sprawdzałem role ściany - wyglądały na takie same jak w działających hostach ale o przepuszczeniu wszystkiego po prostu nie pomyślałem (wstyd się przyznać). Smiley Wink

Sprawdzę w poniedziałek (zew zbliżającej się imprezy mocniejszy :smileygrin:) - i odpowiem jakie efekty.

Raz jeszcze dzięki za zaangażowanie.

0 Kudos
inleo
Leadership
Leadership

To miłego wieczoru, ciesze się, że pomogło. Jak uznasz ze problem rozwiązany zamarkuj moją odpowiedz jako poprawną - może to komuś ułatwić szukanie Smiley Happy

http://blog.inleo.pl @maciejlelusz
0 Kudos
pkolacz
Contributor
Contributor

Witam w poniedziałek. Smiley Wink

Zacznę trochę od tyłu:

esxcli network firewall unload

Nie zadziałało. Odpowiedź sytemu, była że firewall jest zajęty.

Pierwsze polecenie, czyli:

esxcli network firewall set --defaultaction true

po małej modyfikacji na:

esxcli network firewall set -d true

zostały otwarte porty.

Bez problemu połączyłem się z hostem za pomocą vSphare Client.

Korzystając z zakładki Configuration/Security Profile Firewall Properties, ustawiłem właściwą konfigurację.

Na koniec

esxcli network firewall set -d false

I wszystko działa jak należy Smiley Happy

Wielkie dzięki za pomoc. Gwiazdka zamarkowana Smiley Wink

0 Kudos