msully
Contributor
Contributor

ovftool VM->ova/f fails with SHA1 digest of file . . . disk.iso does not match manifest"

I'm trying to create an OVA file from an installed VM.  If I try creating it with ovftool 3.5, it downloads everything completely then gives me the following error:

SHA1 digest of file https://172.31.68.10:443/ha-nfc/52cca89a-6cde-c7a7-0810-25ff2197d3d6/disk-1.iso does not match manifest
and then deletes the file(s) it generated.

I am using compress=0 and --noImageFiles so i don't get the install iso.

If I manually go into Edit Settings and remove the cdrom, then 3.5 creates the ova correctly.

If I use ovftool 2.0, it succeeds even without manually removing the cdrom iso.

I've seen posts where users get the same error I do when they are going ova/f to vm and the answer is to delete the manifest.   Since all of the files are deleted after the error message, I don't have the option to delete the locally created manifest.

Is there a way to keep the files around even after a manifest error?

Does anyone know why ovftool 3.5 would fail in this case and 2.0 would word?  Has there been some deprecation between the two of them?

Thanks,
Mike

2 Replies
GonenG
Contributor
Contributor

Was able to go around this problem in ovftool v3.5.2 by adding the flag '--skipManifestCheck'

which does create a manifest file, but does not check its validity, for example:

ovftool --machineOutput   --overwrite  --compress=9  --noImageFiles  --skipManifestCheck  --targetType=OVA  ...

It looks like a bug: The manifest-checking part of the tool is not aware of the fact that the ISO was left out,

tries to validate its key, and fails because the ISO is not there at all...

Cheers

Kemacal
Contributor
Contributor

Thanks mate! This worked well for me.

0 Kudos