dnance
Contributor
Contributor

Error Installing OVFTool on Ubuntu 14 WorkStation Guest


I am trying to install ovftool 4.1.0 on a Ubuntu guest I have on my Windows host.  I downloadedd the ovftool bundle changed permission to +x, started the bundle, and accepted the license.  It says it is ready to install and I press enter.  Then I get the below and ovftool is never installed.


 


Rolling back VMware installer component 2.1.0


Removing files..


Uninstalling VMware installer component 2.1.0


Deconfiguring...


 


Any ideas? The bundle I have is the 'VMware-ovftool-4.1.0-2459827-lin.x86_64.bundle' on Ubuntu 14


 

3 Replies
PippiLong
Contributor
Contributor

I have the same issue. I don't know why it start prematurely rolling back.

0 Kudos
stephben
Contributor
Contributor

Hello,

I do have the same issue ...

I will be very happy to get any clue about that.

# sh ./VMware-ovftool-4.1.0-2459827-lin.x86_64.bundle

Extracting VMware Installer...done.

You must accept the VMware OVF Tool component for Linux End User

[...]

Do you agree? [yes/no]: yes

The product is ready to be installed.  Press Enter to begin

installation or Ctrl-C to cancel.

Rolling back VMware Installer Component 2.1.0

    Removing files...

Uninstalling VMware Installer Component 2.1.0

    Deconfiguring...


Nothing of matter in the /tmp/vmware-root logfile,

0 Kudos
fnielsen
Contributor
Contributor

I'd been having this problem on multiple versions of Ubuntu for quite some time too, but found the answer in an post regarding a similar issue with a different VMware product - it has to do with how the VMware installer tries to use the Curses library.  Try something like this to see if it fixes your issue:

TERM=dumb /bin/sh ./VMware-ovftool-4.2.0-4586971-lin.x86_64.bundle