NSX-V FTP Load Balancer

Hi NSX experts,

I am trying to get some help since I am not able to set up an LB using NSX-V for my FTP service. 

I am following a TOI presentation however I am seeing the following outouts:


Loadbalancer Pool Statistics:

POOL ftp-test
| LB METHOD round-robin
| LB PROTOCOL L7  <---------------------- even when acceleration is enabled.
| Transparent disabled
| SESSION (cur, max, total) = (0, 0, 0)
| BYTES in = (0), out = (0)
+->POOL MEMBER: ftp-test/member-1, STATUS: UP
| | HEALTH MONITOR = BUILT-IN, default_tcp_monitor:L4OK
| | | LAST STATE CHANGE: 2022-03-14 20:23:45
| | SESSION (cur, max, total) = (0, 0, 0)
| | BYTES in = (0), out = (0)

Also I have the ALG configures as 

allow any any and in service I selected FTP.

I took some packet captures at the pool member level and I can see when I bypass the LB the communication working fine, but when I use the LB the request does not even reach the pool, seems like it is not passing the ESG.

Best Regards.

0 Kudos
1 Reply

Configuring NSX Advanced Load Balancer
To configure NSX Advanced Load Balancer for load balancing passive FTP, follow the steps below:

Configuring health monitor for FTP

Configuring pool with the required FTP servers

Configuring Layer 4 response DataScript for FTP

Configuring Layer 4 virtual service with port configuration for the data channel

Configuring Health Monitor
To configure an external health monitor for FTP, on NSX Advanced Load Balancer UI navigate to Templates > Profiles > Health Monitors and click Create.

Enter a name for the health monitor.

Click the dropdown for Type and select External.

Enter a relevant value in the Send Interval field.

Under External Settings,

Enter port number 21 in the Health Monitor Port field.

Paste the below bash script for the FTP health monitor in the Script Code section.
curl -s ftp://$IP/$path --ftp-pasv -u $user:$pass

Enter the Username, Password, and the Filepath in the Script Variables section. MyTHDHR Schedule

0 Kudos