Contributor
Contributor

Vmware ESXI within Hyper-v (server 2012) networking issue

I am trying to get esxi running within hyper-v and it won't recognize the virtual switch even though I got it setup properly and it works with any other VMs on this system.

http://i.imgur.com/4rCA3.png

Hyper-V-Virtual-Switch-Issue-421.PNG

I only have one NIC but it works fine with other VMs.

189 Replies
Contributor
Contributor

I checked and there are no options in the virtual switch manager of hyper-v Smiley Sad

I'll try to get this working.

If I have to I can pick up a cheap wireless USB dongle and see if I can try to route with that and see if that will help.

0 Kudos
Contributor
Contributor

I am able to get as far as to get an IP from my router to the esxi/vsphere VM but no DNS/internet connectivity works.

I am able to ping my router, however no DNS resolves.

0 Kudos
Contributor
Contributor

XML file for your VM.

I am not sure where best to try this.  The first place I would suggest is under the <global_settings> node.  Add the line:

<allow_promiscuous_mode type="boolean">TRUE</allow_promiscuous_mode>

THIS WORKED!!!

0 Kudos
Enthusiast
Enthusiast

This really works.

Never trust a computer you can't throw out a window
0 Kudos
Contributor
Contributor

Am i the only one getting a black screen after using the legacy adapter, and the tulip vib for a custom image, after boot but before the install?

I'd take a screenshot, but it's really just a black screen.

0 Kudos
Contributor
Contributor

Please try to use the regular adapter.

0 Kudos
Contributor
Contributor

Still no luck with the regular adapter.

Even tried recreating the VM with the changed settings, with no difference in result.

arrr

0 Kudos
Contributor
Contributor

Do you have the remote fx role installed?

0 Kudos
Contributor
Contributor

ESX is running but no network ping to any device on the network.

Ping within ESX to own ipadres = ok

Did use the option in XML:

<global_settings>

   <allow_promiscuous_mode type="string">TRUE</allow_promiscuous_mode>
   <devices>

Used a networkcard (no wireless dongel) where other VM's see/ping each other

Any suggestions??

Thx.

RemoteFX option no installed

0 Kudos
Contributor
Contributor

Can you ping any domain name on the internet?

I can ping to internet domain names but I cannot ping other machines on the network.

I also cannot activate windows either. I have Internet Access as indicated by the windows networking manager.

0 Kudos
Contributor
Contributor

Has anyone managed to get this to work?  I made it all the way to provideing a pasword for root but it then does an additionasl scan and fails with an error telling me that it only have one CPU core wich is less than the two CPU cores that is recommended (CPU_CORES ERROR).  Anyone have any idea what that means?

Thanks

Bert

0 Kudos
Contributor
Contributor

You must have a dual core emulated processor or higher for the vm in Hyper-V.

To do that please go to the following:

Vm list>right click the vmware vm>properties>Processor>set the number to 2 or more virtual processors>ok

Please note: the above cannot be performed if you saved the VM state.

0 Kudos
Contributor
Contributor

Thanks for the reply but I should have explained that I tried that already.  The first time, I gave the ESX VM 4 CPUs.  When I rebooted it, it got to the point that it was initializing the scheduler and the screen greyed out followed by a reboot.  I then tried to decrease the number of CPUs to 2 but exactly the same thing happened.  The only way the installation app will run is if there is only one CPU.

Another interesting thing, though, that was pointed out by someone who knows a lot more about ESX than I do is the fact that the installation app "sees" the physical CPU when it shouldn't.  When the installation has the dark grey over yellow screen, it lists the type of CPU in the machine (AMD FX-8120 8 core) but it only does this if I alllocated 1 logical CPU to the VM.  If I allocate multiple logical CPUs, it crashes before listing the CPU type.  Maybe that's why it crashes?  It tried to enumerate the CPUs and is successful on the first one but fails on the second - asuming that it is looking directly at the hardware.

Unlike ESX, Hyper-V will not allow me to specify how many cores I allocate to a VM, just how many CPUs.

Bert

0 Kudos
Contributor
Contributor

You have verified that your system supports IOMMU, etc... correct?

also check your BIOS settings as well.

Proper processor and motherboard support are needed for any nested hypervisors.

https://www.google.com/search?q=AMD+FX-812#hl=en&sclient=psy-ab&q=AMD+FX-812+esxi&oq=AMD+FX-812+esxi...

0 Kudos
Contributor
Contributor

No, I haven't.  I don't have a list of what is required yet.  All I did was try to set up a VM on an existing Hyper-V box and install ESX in that VM.

One of the google hits on that search suggested that ESXi doesn't like the AMD FX-8120 CPU so I just tried to do the same thing on a different Hyper-v box with an AMD Phenom II X6 1090T CPU but I ended up with exactly the same result.  The installation app crashes if I allocate multiple CPUs to the VM and gives me the CPU_CORES error if I only allocate one CPU.

Bert

0 Kudos
Contributor
Contributor

You've checked all your BIOS settings right? also your motherboard and chipset have to support it as well.

I have an Intel i5 3570K and an Asrock z77pro3 and it works fine.

0 Kudos
Expert
Expert

BertP -- I was able to replicate your crash-on-multiple-AMD-CPUs with an AMD Opteron 8354 Stepping 3 CPU (that box and those CPUs work fine on everything else but crashes the VM when the VM is ESXi 5.1 installed as a VM under Hyper-V 3.0 (crashes during the ESXi 5.1 install)) -- if only one VCPU is allocated to the ESXi 5.1 running as a VM under Hyper-V 3.0, the install proceeds but then the ESXi 5.1 install stops because it only sees one VCPU).

Since some of the others don't seem to have this problem, it's possible the problem is with AMD physical CPUs and not with Intel physical CPUs.

Datto

0 Kudos
Contributor
Contributor

What BIOS settings are required?  Everything necessary for virtualization is set - otherwise, Hyper-V wouldn't work.

I have tried this on two different machines so far with different CPUs and MBs.  I know what the CPUs are but not the MBs.  Since I am doing this remotely, I can't check the MB type at the moment.

Bert

0 Kudos
Contributor
Contributor

Datto - I have 7 machines running Hyper-V on my network with 5 different CPus.  Unfortunately, all of the CPUs are AMDs so I can't test this on an Intel box to determine if it is an AMD-only issue or not.  I have verified the problem on two different AMD CPUs and get exactly the same result.  Your test raises that to 3 so it really is starting to look like an AMD issue.

Bert

0 Kudos
Immortal
Immortal

It would be interesting to see what CPU features Hyper-V is reporting for the virtual AMD chips.  Can you run the attached program in a Linux VM running under Hyper-V and post the results?  It should look something like this...

       0:        5 68747541 444d4163 69746e65
       1:   100f52  1040800   802009 178bfbff
       2:        0        0        0        0
       3:        0        0        0        0
       4:        0        0        0        0
       5:       40       40        3        0
80000000: 8000001b 68747541 444d4163 69746e65
80000001:   100f52 10000000     37ff efd3fbff
80000002: 20444d41 69676e45 7265656e 20676e69
80000003: 706d6153     656c        0        0
80000004:        0        0        0        0
80000005: ff30ff10 ff30ff20 40020140 40020140
80000006: 20800000 42004200  2008140        0
80000007:        0        0        0      1f9
80000008:     3030        0     2003        0
80000009:        0        0        0        0
8000000a:        1       40        0        f
8000000b:        0        0        0        0
8000000c:        0        0        0        0
8000000d:        0        0        0        0
8000000e:        0        0        0        0
8000000f:        0        0        0        0
80000010:        0        0        0        0
80000011:        0        0        0        0
80000012:        0        0        0        0
80000013:        0        0        0        0
80000014:        0        0        0        0
80000015:        0        0        0        0
80000016:        0        0        0        0
80000017:        0        0        0        0
80000018:        0        0        0        0
80000019: f0300000 60100000        0        0
8000001a:        3        0        0        0
8000001b:       1f        0        0        0

0 Kudos