Yoyoz
Contributor
Contributor

Virtualized ESXi5 - Network issues with nested VMs

Jump to solution

Happy new year!

I'm facing some issues on my test environment, which is as follow:

  • - my host system is a laptop runing Linux Mint 11 (2.6.38-8-generic #42-Ubuntu SMP)
  • - I'm using VMWare Workstation 8.0.1 build-528992
  • - I've setup bridged networking on a virtual interface (made with brctl) for all VMs and the host is providing dhcp, dns, tftp, etc... facilities
  • - All VMs are on the briged network and all see each other, the host and the internet perfectly well

Now the ESXi part:

  • - the ESXi 5 server (free base license) is vitualized with a single vnic and bridged networking (same as all other VMs), and as an ESXi 5 virtual machine (was a nice surprise to see that WS 8 knows about it out-of-the-box)
  • - I've setup a few VMs nested into this virtual ESXi
  • - the ESXi VM can talk to every other system, ie the host, other VMs and its own VMs

The issue is that the nested VMs can only talk to each other or the console, but not to the host laptop or other VMs, except the ESXi itself.

I've tried the follownig with no chance:

  • - add another vnic to the ESXi and dedicate a vswitch for the VMs
  • - use NAT or Host-only network for the ESXi VM
  • - disable/unload the ESXi firewall

The only thing that works a bit is DHCP, although it seems the acknowledgement never reach the nested VMs. However, they still get a proper IP address, but after that are not able to receive any ARP traffic. If manually adding some arp entries and can see ICPM request on vnet0 (the bridge) from nested VMs to other machines and the corresponding replies. If pinging the other way I only see the requests, meaning the traffic is not forwarded to the nested VMs.

The ESXi vswitch is configured to accept promiscuous mode, MAC adress changes and forged transmits.

Thanks in advance if anybody has a clue

0 Kudos
1 Solution

Accepted Solutions
admin
Immortal
Immortal

Is promiscuous mode enabled for /dev/vmnet0 on the physical host?  See http://kb.vmware.com/kb/287 for details.

View solution in original post

0 Kudos
2 Replies
admin
Immortal
Immortal

Is promiscuous mode enabled for /dev/vmnet0 on the physical host?  See http://kb.vmware.com/kb/287 for details.

View solution in original post

0 Kudos
Yoyoz
Contributor
Contributor

I didn't think about this one because I could see vnet0 properly going into promiscuous mode and nothing in my syslog about vmnet0... I changed the rights on /dev/vmnet0 as described in your kb link and now it works fine.

You made my day, thanks a lot!

0 Kudos