irobot888
Contributor
Contributor

Virtualize Intel VT-x/EPT or AMD-V/RVI

Jump to solution

Hi,

I have two ESXi 5 hosts in a lab environment, running in VMware Player 4.0.1build 528922 on an Intel Core i7 laptop.  I'm a VCP3 and 4, and this setup is to study for the VCP5 exam.

Editing the ESXi virtual machines, I can see under Hardware > Processors that there is no tickbox to 'Virtualize Intel VT-x/EPT or AMD-V/RVI'.  As such, it looks like hardware virtualization of the Core i7 can't be passed-through to the ESXi virtual machines, and I can't therefore run nested 64-bit virtual machines on these hosts.

Can I therefore assume that this is one of the enterprise options that is only available in VMware Workstation 8? (I'd like to rule this out before purchasing - unfortuately as a VCP4 I only get a license for Workstation 7!)

Many thanks,

IR888

Tags (1)
0 Kudos
1 Solution

Accepted Solutions
a_p_
Leadership
Leadership

Welcome to the Community,

Vmware Workstation offers more features as well as some additional settings in the GUI. However, you should be able to achieve what you want by directly editing the .vmx file. Please take a look at e.g. Virtualized Intel VT-x/EPT is disabled for this ESX VM. You will only be able to run 32-bit nested V... to see whether this helps.

André

View solution in original post

0 Kudos
7 Replies
a_p_
Leadership
Leadership

Welcome to the Community,

Vmware Workstation offers more features as well as some additional settings in the GUI. However, you should be able to achieve what you want by directly editing the .vmx file. Please take a look at e.g. Virtualized Intel VT-x/EPT is disabled for this ESX VM. You will only be able to run 32-bit nested V... to see whether this helps.

André

View solution in original post

0 Kudos
admin
Immortal
Immortal

Try updating the virtual hardware.  Go to VM->Manage->Change Hardware Compatibility and select compatibility with Workstation 8.

admin
Immortal
Immortal

Sorry.  That feature is not available in Player.  You can create a new virtual machine with Player 4.0.1, in which case you will get the option to virtualize Intel VT-x/EPT or AMD-V/RVI.  Then, just replace the virtual disk (.vmdk files) for the new virtual machine with a copy of your old virtual disk.

0 Kudos
irobot888
Contributor
Contributor

Thanks André. I added the following to the ESXi5 host .vmx file:

vhv.enable = "TRUE"
monitor_control.restrict_backdoor = "true"

... and it looks like the VM is trying to pick up pass-through Intel VT-x/EPT now.

However, I now get the following error on starting up the ESXi5 VM:

Virtualized Intel VT-x/EPT is incompatible with the virtual machine configuration.

Continue without virtualized Intel VT-x/EPT?

Do you have any idea what aspect of the VM configuration would be stopping the pass-through?

Thanks in advance,

IR888

0 Kudos
irobot888
Contributor
Contributor

OK, the last error seemed to have something to do with the ESXi 5 Virtual Machine version - which was set by default at 'Workstation 6.5-7.x virtual machine'.

Manually amended in the VM .vmx 'virtualHW.version = "7"' to 'virtualHW.version = "8"', and the tickbox to 'Virtualize Intel VT-x/EPT or AMD-V/RVI' appeared in VMware Player 4.0.1 (already checked).

The VM appears to be complaining about an IDE .vmdk on startup in bottom right-hand corner, but I can't quite catch the error.  But at least the 'Virtualized Intel VT-x/EPT is incompatible with the virtual machine configuration' error on startup has now disappeared.

I'll see if I can catch the .vmdk error and report further.

In the meantime, thanks all for your help.

0 Kudos
a_p_
Leadership
Leadership

Glad to see you got it working.

Please attach the VM's latest vmware.log file to your next post. This should show the reason for the IDE error message.

André

0 Kudos
admin
Immortal
Immortal

irobot888 wrote:


Manually amended in the VM .vmx 'virtualHW.version = "7"' to 'virtualHW.version = "8"', and the tickbox to 'Virtualize Intel VT-x/EPT or AMD-V/RVI' appeared in VMware Player 4.0.1 (already checked).

This isn't entirely necessary, but to complete the manual conversion from hardware version 7 to hardware version 8, you may want to add the following line:


hpet0.present = TRUE

0 Kudos