mikerj
Contributor
Contributor

Update of OSP conflicts

Hi - I'm running a RHEL 5.8 x86_64 VM with kernel 2.6.18-308.1.1.el5.  The current version of the vmware-tools osp is 8.6.0-2 and I'm trying to update to 8.6.5-2.

[root@tmpl-rhel5-x86-64 ~]# yum list|grep ^vmware|grep nox
Unable to read consumer identity
vmware-tools-esx-nox.x86_64                8.6.0-2                     installed
vmware-tools-libraries-nox.x86_64          8.6.0-2                     installed
vmware-tools-esx-nox.x86_64                8.6.5-2                     rhel5s
vmware-tools-libraries-nox.x86_64          8.6.5-2                     rhel5s

When trying to update them using yum, I encounter the error below.  The VM is using the vmxnet3 adapter.  I usually use the tools installed via the vsphere client, but I'd like to manage them with yum and I'm hoping that I don't have to fall back to the e1000 adapter so that kernel upgrades don't break network connectivity and require intervention.  Anyone doing this now and have you run into this issue before?

Transaction Summary

====================================================================================================================================================

Install       2 Package(s)

Upgrade      28 Package(s)

Total size: 14 M

Downloading Packages:

Running rpm_check_debug

Running Transaction Test

Finished Transaction Test

Transaction Check Error:

  file /lib/modules/2.6.18-8.el5/extra/vmware-tools-vmxnet3/vmxnet3.ko from install of kmod-vmware-tools-vmxnet3-1.0.47.0-2.6.18.8.el5.3.x86_64 conflicts with file from package kmod-vmware-tools-vmxnet3-1.0.37.0-2.6.18.8.el5.3.x86_64

  file /lib/modules/2.6.18-8.el5/extra/vmware-tools-vmxnet/vmxnet.ko from install of kmod-vmware-tools-vmxnet-2.0.9.1-2.6.18.8.el5.3.x86_64 conflicts with file from package kmod-vmware-tools-vmxnet-2.0.9.0-2.6.18.8.el5.3.x86_64

Error Summary

-------------

Tags (3)
0 Kudos
0 Replies