VMware Cloud Community

Unable to install CentOS 5 on ESXI 6.5


I'm having a problem with installing CentOS 5 on ESXI 6.5 and I was hoping someone could point me in the right direction.

The CentOS 5 OS actually installed, however after installation the network card was not installed.  During the installation it asks me to modify the Network Configuration.  Then it asks me to add a device (Devernet Configuration) so I added an eth0 interface with a static IP.  However, when i start the vm it has no network interfaces.  When I try to bring the interface up I get a "Device eth0 does not exist" error message.

I looks like it's missing the driver for the network card.

So I tried to install VMWare tools to see if I can get the network interface from it

ESXI > CentOS5 VM > Actions > Guest OS > Install VMWare tools

First I got the following error:

  • Unable to install VMware Tools. An error occurred while trying to access image file "/usr/lib/vmware/isoimages/linuxPreGlibc25.iso" needed to install VMware Tools: 2 (No such file or directory). Please refer the product documentation or KB article 2129825 for details about how to get VMware Tools package for this guest operating system

The documentation basically said that this was an issue on VMware tools 10.1.0.

I tried making a copy of linux.iso and renamed it to /usr/lib/vmware/isoimages/linuxPreGlibc25.iso.  This allowed me to install VMWare tools, however when I looked at the guest OS the drive was not mounted or even present under /dev/cdrom

I tried  mounting the linux.iso  file in ESXI straight to the VM under CentOS VM > Hardware Configuration > CD/DVD drive 1

However this did not show up in the guest VM

I read online about OSPs, however how can I get installed if I can't get the package into the VM (mounting does not work and there is no network connectivity)

Any help or suggestions on this issue would be greatly appreciated

Thank you

0 Kudos
1 Reply

I tried many things and finally got networking to work on CentOS 5 on ESXI 6.5.

Below is how I did it if anyone else has this problem

- When setting up the install there is an option to configure the virtual hardware

- One of the virtual hardware is call 'Network Adapter 1'

- By default it is set to VMXNET 3 which does not work

- I changed this to E1000 and the network card showed up during the installation

Without this I have no idea how to get VMware tools installed on the CentOS5 VM

0 Kudos