yukizo
Enthusiast
Enthusiast

VMware workstation 16 Player にWindowsXPがインストールできない

Workstation 16 PlayerにWindowsXP(32bit)professional Version2002をインストールできないようです。

インストール終盤あたりで画面が真っ暗なまま反応がなくなりDVDへのアクセスも止まったままになります。

何が問題だと考えられるでしょうか?

※普遍的な現象なのか知りたいので解決に至っていなかったとしても、同じような症状になった方の報告などあれば助かります。

よろしくお願いします。

23 Replies
Jangari
Enthusiast
Enthusiast

こちらに関しては、『残り5秒で再起動します』というようなアナウンスが現れ、自動で再起動がかかりタイトルが出てきた後真っ暗になるという状態です。

こちらですが、状況から OS インストール処理が完了し、その後に再起動が行われた後、

Windows XP の起動時に XP のロゴが表示された後、画面が黒いまま描画されないという

]状況の認識で正しいでしょうか。

OS 起動時にロゴが表示された後に黒い画面が表示される、という観点で少し調べてみたところ

海外の一般のフォーラム(StackExchange)ですが似たような事例の質問が出ており、仮想マシンで

3D グラフィックスのアクセラレーション機能をオフにしてみるといった提案が出ていました。

https://superuser.com/questions/842598/black-screen-on-xp-guest

In the Virtual Machine Settings of the guest that is blank, under Hardware, Display, try turning off Accelerate 3D graphics.

3D グラフィックスのアクセラレーション機能を使用するとゲストのグラフィック処理に

ホスト側の GPU を使用(オフロード)するようになるのですが、もしかしたらこの辺りで

ハードウェアやゲストのドライバ等の相性問題が発生している可能性があるかもしれません。

3D グラフィックス アクセラレーションを使用するための仮想マシンの準備

ちなみに、VirtualBox で Windows XP を指定して仮想マシンを作ってみると、

3D アクセラレーションは無効の状態で仮想マシンが作成されるようでした。

仮想マシンの設定で [ハードウェア] > [ディスプレイ] > [3D グラフィックス] から

[3D グラフィックスのアクセラレーション] のチェックを外すことでオフに出来ます。

3D グラフィックス周りの問題かの切り分けも含め、こちらを実施することで

インストール後の OS 起動時に画面が描画されるかお試し頂ければ幸いです。

yukizo
Enthusiast
Enthusiast

3Dアクセラレーションに関しても試してみましたが変化はないですね。

一応状況をまとめておくと

ソフト:VMware workstation 16 Player ver16.0.0

ホストOS:Windows10 ver2004(64bit)

ゲストOS:Windows10(32bit)、Windows7(64bit)、Ubuntu(64bit)→正常動作

ゲストOS:WindowsXP→インストール処理の最後の自動再起動にてタイトルが出た後真っ暗なまま。

0 Kudos
yukizo
Enthusiast
Enthusiast

その後ですが、まだ解決していません。

windows10をクリーンインストールしてまっさらな状態でVmware workstation 16 playerのインストールも試してみたのですが、結果は同じでした。

■環境

・Vmware workstation 16 player ver16.0.0

・ホストOS:WIndows10 pro 64bit ver2004

・ゲストOS:WIndowXP professional ver2002 ※設定値はデフォルトのまま

・ホストPC:CPU AMD Ryzen7 1700 Eight-Core Processor 3.00GHz メモリ48GB

■現象

・インストール処理→『15秒後に再起動します』と出る→再起動→WindowsXPタイトル画面が出る→真っ暗→真っ暗なまま

・同じゲストOSイメージをVirturlBoxでは正常にインストールが完了する

・ゲストOSWindows10(32bit)、Windows7(64bit)、Ubuntu(64bit)では正常動作

■報告

・gowatana氏)Windows XP SP2 32bit、Windows 10 Home 1909、Lenovo ThinkPad X1、Core i5-8300Hで正常動作

※普遍的な現象なのか知りたいので解決に至っていなかったとしても、同じような症状になった方の報告などあれば助かります。

もし何か情報があれば引き続きよろしくお願いします。

0 Kudos
kurokobo
Contributor
Contributor

ホストの CPU が AMD だったんですね、実は結構だいじな情報でした……。

さっと調べた範囲では、Ryzen と古い OS(XP やそれ以前)の組み合わせでは仮想化が(VMware Workstation に限らず Hyper-V でも)うまく動かない例も見られるようです。

ハードウェアとソフトウェアの組み合わせの問題の場合、設定変更云々での回避は難しくなってきますが、仮想化支援機構の使い方の可能性もあるので、以下あたりのチェックボックスを変更して試してみるのもよいかもです(ただし仮想マシンのパフォーマンスに影響する可能性があります)。

pastedImage_17.png

掘ろうとすると回復コンソールやセーフモードやグラフィックドライバの埋め込みやログ調査やダンプ確認などアイディアは出せるものの、難易度と手間も上がってきてしまうので、VirtualBox で動いているようであれば、XP は VirtualBox を使うように割り切るとか、そういう選択のほうがラクかもしれないです。