Shiraishi0318
Contributor
Contributor

ゲストosで音割れ

Jump to solution

お世話になります。

先日、VM Ware Workstation Pro 12にWindows XP Pro SP3 をインストールしたのですが、

音割れして、まともに音が再生できません。

VM Tools を再インストールしても、症状は変わりません。

ホストOSはWindows 10 Proです。

初歩的なことかもしれませんが、何か確認事項はないでしょうか?

1 Solution

Accepted Solutions
VirtAppLife
Enthusiast
Enthusiast

こんにちは。

このXPの仮想マシンは、かれこれ、5年くらい前に作成したもので、
当時のVMware Workstationは、6とか7だったような記憶がありますが、
残念ながら、用途上、サウンドは不要だったので、そもそも、
サウンドカードを追加しておらず、問題有無を確認しておりません。

ワークアラウンドとしては、
MediaPlayerをスタートアップで起動して、邪魔にならないよう、
ツールバーに最小化しておく、というところでしょうか...

min_wmplayer.png

regards,

Kazuma

View solution in original post

19 Replies
VirtAppLife
Enthusiast
Enthusiast

こんにちは。

かなり以前に作成した、仮想のWindowsXP Pro SP3を、
VMware Workstation Pro 12上で動かして、
XP標準のサンプルミュージックを再生してみましたが、
自分の耳のせいかもしれませんが、特に気になるような音割れはありませんでした。

以下、環境の情報です。
・ホストコンピュータ:Let's Note CF-SZ5
・ホストOS:Windows 10 Pro(x64) ver.1607 Japanese
・仮想化ソフト:VMware Workstation 12 Pro 12.1.1 build-3770994

・ゲストOS:Windows XP Professional SP3
・VM Tools:8.4.8 build-491717 ←すごく古いです・・・

以下、参考までに、画像を貼っておきます。
Sound_within_VirtWinXP_on_WS12Pro_on_Win10x64_ver1607_japanese.png

宜しくお願い致します。

Regards,
Kazuma Yamabe
vExpert, VirtApp_Lover

0 Kudos
Shiraishi0318
Contributor
Contributor

返信ありがとうございます。

その後、いろいろ試したのですが、

システム音のみが音割れするといった状況です。

また、windows media player を起動させた状態だと、問題ありません。

0 Kudos
bluefirestorm
Virtuoso
Virtuoso

For me there is just no consistency in the XP audio output.

I don't have a fix/solution but I started noticing this as early as Workstation 10.

But it is never consistent. Sometimes, the "Windows Logon" sound is already crackling. Sometimes it is fine. Sometimes it is only the "Windows Logoff" sound that crackles. Sometimes both crackles sometimes neither crackles.

For whatever it is worth, this is another post with an example output.

Faulty audio output - VMware: Please fix audio driver

To be fair to VMware, the audio driver in XP VM is not from VMware Tools as it is an ES1371/ES1373 driver.

0 Kudos
Shiraishi0318
Contributor
Contributor

ES1371/ES1373のドライバーを再インストールしても、症状は変わりませんでした。

0 Kudos
bluefirestorm
Virtuoso
Virtuoso

I replied to your message for two main reasons

(1) to let you know you are not alone in experiencing the audio problems in XP VM and that it is inconsistent

(2) a solution may not be forthcoming from VMware as it also may not be in their control because the audio driver is not from them; apart from the fact it is terribly difficult to reproduce the problem because of the inconsistency

I don't expect re-installing the drivers would help.

But if it is very, very important for you to have good audio in your XP VM (maybe you are a music artist/audiophile with legacy Digital Audio Workstation software on XP or you want to play an old XP PC game), you may want to consider using a USB audio device and passthrough to the XP VM.

An example is this Syba USB 2.0 External Stereo Audio device, SD-AUD20101. There could be others but you have to check for compatibility with Windows XP. Searching on Amazon JP this is available at JPY11,199 but on Amazon US only around US$12 (price difference of 10 times!!!!)

http://www.sybausa.com/index.php?route=product/product&product_id=694

0 Kudos
Shiraishi0318
Contributor
Contributor

お世話になります。

VM Tools 8.4.8 とありますが、

過去のVM Tools のダウンロード方法などが、ありましたら、教えていただけないでしょうか?

0 Kudos
VirtAppLife
Enthusiast
Enthusiast

こんにちは!

Tools 8.4.8をMy VMwareで探してみましたが、残念ながら、落ちてないですね...

なので、私の仮想WinXPSP3環境内のToolsをバージョンアップしてみました。
アップ後のバージョンは以下です。

10.0.6 build-3595377

一応、アップデート後に、確認しましたが、サンプルミュージックも、
”ポーン”とかのシステム音でも、私には、音割れは確認できませんでした。

Sound_within_VirtWinXP_on_WS12Pro_on_Win10x64_ver1607_japanese_2.png

Regards,
Kazuma

0 Kudos
Shiraishi0318
Contributor
Contributor

回答ありがとうございます。

ゲストosのサウンドドライバは何になりますでしょうか?

自分の症状はシステム音のみ音割れし、

通常の音楽ファイルの再生自体は問題ありません。

また、windows media player を起動させている状態だと、システム音の音割れはありません。

サウンドドライバの問題なのでしょうか?

ちなみに、ホストosのサウンドドライバは

realtek high definition audio

です。

回答のほど、よろしくお願いします。

0 Kudos
VirtAppLife
Enthusiast
Enthusiast

こんにちわ!

デバドラ系に詳しくないのですが、
ゲストOSのWindowsXPのデバイスマネージャーで確認した情報は以下です。

 Creative AudioPCI (ES1371,ES1373)

  ver.5.1.2535.0

ちなみに、ホストOSのWindows10側の情報は以下でした。

 Realtek High Definition Audio

  ver.6.0.1.7649

参考までに、画面キャプチャを貼っておきますので、

他に欲しい情報があれば、コメントくださいませ。

Sound_within_VirtWinXP_on_WS12Pro_on_Win10x64_ver1607_japanese_3.png

Regards,

Kazuma

0 Kudos
Shiraishi0318
Contributor
Contributor

返信ありがとうございます。

ゲストosのサウンドドライバについてですが、

ドライバーはどのようにインストールされましたか?

vm ware tools をインストールした時に、自動的にインストールされましたか?

0 Kudos
VirtAppLife
Enthusiast
Enthusiast

こんにちわ

Workstationの[仮想マシン設定]-[ハードウェア]の追加で、

[サウンドカード]を追加&再起動しました。

元々、入れてなかったんですが、この投稿を見たので、

追加してみた次第です。宜しくお願い致します。

regards,

Kazuma

0 Kudos
bluefirestorm
Virtuoso
Virtuoso

I don't think the driver come from VMware Tools.

It just entered my mind to go to the Creative website to check for any newer driver.

You can try to download to see whether it fixes the distortion.

http://support.creative.com/downloads/download.aspx?nDownloadId=1843

Or go to http://support.creative.com/Products/product_list.aspx?catID=1&CatName=Sound+Blaster and select others "16 PCI" under "Archived Products"

After downloading and installing the driver, the audio device become "SB PCI".

pastedImage_2.png

I don't know if it fixes the intermittent sound problem as it does not always happen in my case.

Interesting description in the Download

File Name : SBPCI_WebDrvsV5_12_01.exe

  Overview

This package is meant for Sound Blaster® Vibra128, Sound Blaster 16 PCI, Sound Blaster PCI 128, Sound Blaster 4.1 Digital, and Sound Blaster Ensoniq AudioPCI users running Windows 98SE, Windows ME, Windows 2000 and Windows XP, who experienced distortion problem when playing a wave or MP3 file in 4 speaker mode. For PRODIKEYS™ users who are running on Windows 98SE, this Web Update will enable them to record and playback under IMPRESS mode within the PRODIKEYS application. The package will contain the following:

0 Kudos
Shiraishi0318
Contributor
Contributor

お世話になります。

OSの再インストール,ドライバの再インストールを実施しましたが、システム音を鳴らすとプチプチとノイズが入ったり、音割れしたりします。

環境は以下の通りです。

ホスト

Windows 10 pro x64

vm ware workstation pro 12.5.2 build4638234

ゲスト

Windows Xp pro x86 sp3

Creative AudioPCI (ES1371,ES1373) ver.5.1.2535.0

以上、よろしくお願いします。

0 Kudos
VirtAppLife
Enthusiast
Enthusiast

こんばんわ

環境的には、私のところとほとんど差異はないですね...

”システム音を鳴らす”という部分の具体的な再現手順を教えてもらえませんか?

regards,

Kazuma

0 Kudos
Shiraishi0318
Contributor
Contributor

回答ありがとうございます。

システム音の鳴らし方ですが、

ファイル名を指定して実行より、

mmsys.cpl と入力し、

サウンドとオーディオデバイスのプロパティを開きます。

次に、サウンドタブに移動し

起動音、終了音などを再生する

といった流れです。

よろしくお願いします。

0 Kudos
VirtAppLife
Enthusiast
Enthusiast

おはようございます。

再現手順のご案内、ありがとうございます。

早速、確認しましたところ、

確かに、Windows起動音が音割れしていて、

滑らかさに欠ける状態になることを確認できました。

ありがとうございました。

Windows Media Playerを起動しているだけで、

再生していなくても、この音割れは無くなりますね。

また、C:\WINDOWS\Mediaの各種のシステム音関連の.wavを

Windows Media Playerで再生しても、問題がないので、

rundll32.exe(mmsys.cpl)の単体起動で再生する時に発生する問題の様です。
(.wmaと.wavの違いでもありませんでした)

プログラム毎に、優先するオーディオドライバーが違い、
Windows Media Playerが起動すると、Workstationと相性の良いドライバーが待機してくれて、
rundll32.exe上での再生も処理してくれた結果、音割れせず、rundll32.exeだけだと、

他のオーディオドライバーが処理しているような感じです。(根拠無しです)

サウンド関連の設定をいじってみましたが、
改善は見られず...私では力不足のようで、お時間頂いたのに申し訳ないです。


regards,

Kazuma

0 Kudos
Shiraishi0318
Contributor
Contributor

回答ありがとうございます。

以前のバージョンでは問題なかったということで

間違いないでしょうか?

問題ないとの事でしたら。xpが音割れしない

バージョンを教えていただけないでしょうか?

使用しているpcは

HP Pavilion 15-n242tx

です。

よろしくお願いします。

0 Kudos
VirtAppLife
Enthusiast
Enthusiast

こんにちは。

このXPの仮想マシンは、かれこれ、5年くらい前に作成したもので、
当時のVMware Workstationは、6とか7だったような記憶がありますが、
残念ながら、用途上、サウンドは不要だったので、そもそも、
サウンドカードを追加しておらず、問題有無を確認しておりません。

ワークアラウンドとしては、
MediaPlayerをスタートアップで起動して、邪魔にならないよう、
ツールバーに最小化しておく、というところでしょうか...

min_wmplayer.png

regards,

Kazuma

View solution in original post

Ryufu
Contributor
Contributor

横からすみません、是非とも御礼を述べたくて。

私も同様の症状に見舞われました。
ゲストOSであるWindowsXP SP3で、システムサウンドを含む全ての音声ファイルを再生すると、音が割れると同時に再生速度も半分程度に落ちてしまう現象が発生していましたが、こちらを参考にWMPをタスクバーへ最小化しておくだけで嘘のように解消しました。

ありがとうございました。

ちなみにVMWare Toolsのバージョンは10.0.12、使用しているソフトはVMware Workstation 15 Playerです。
もし今後同様の環境で同じ症状に悩む人が居られたら、是非この記事の手順を実施してみて下さい。