VMware Global Community
lordmark89
Contributor
Contributor

Problema di connettività randomico virtual Machine VMware 6.5

Buongiorno a tutti,

sto sperimentando uno strano problema relativo ad alcune virtual machine (vHardware 13, vmware tools sono aggiornati alla versione 11265, vSphere VMware ESXi, 6.5.0, 15256549).

In sostanza, randomicamente, alcune specifiche virtual machine non sono in grado di comunicare tra loro: provando ad effettuare un ping tra loro la risposta è "destination host unreachable". Le virtual machine sono attestate sulla stessa vlan, definita a livello di Distributed vSwitch. Il problema sembra limitato ad un subset di vm: da altre sorgenti (stessa vlan e sempre virtuali e sui medesimi host esxi) non ci sono problemi a pingare e raggiungere in ogni modo le vm. Mentre il problema è in essere, queste vm che lo presentano non sono in grado di comunicare tra loro ma riescono a comunicare con il resto del "mondo". Ancora più strano, è il workaround che permette di risolvere il problema: effettuando una storage vmotion della vm sorgente o della vm destinazione che presentano il problema, le vm riprendono a pingare. La cosa più strana è che è sufficiente una vmotion di source o destination indistintamente per risolvere il problema, come se fosse l'azione stessa di vmotion a ripristinare la connettività. In più, ripristinando la situazione in cui la comunicazione tra le 2 vm non funzionavano, ovvero riportando la vm spostata sull'host precedente, la connettività continua a funzionare. Dunque il problema non sembra host related, ma vm related, e qualsiasi vmotion verso qualsiasi host sembra fixare la situazione. Successivamente però, alla prima vmotion eseguita dal drs, il problema tornerà in essere.

E' già successo qualche caso simile ? Cosa potrei provare ad indagare per capire cosa sta causando e come risolvere l'anomalia? Grazie

Reply
0 Kudos
3 Replies
Alex_Romeo
Leadership
Leadership

Buongiorno,

bisognerebbe analizzare i file di log nel momento in cui si presenta il problema.

Hai provato a disabilitare il DRS (anche HA) e successivamente riabilitarli?

Puoi postare i file di logs?

ARomeo

Blog: https://www.aleadmin.it/
Reply
0 Kudos
lordmark89
Contributor
Contributor

Grazie per il riscontro, purtroppo non è cosi semplice raccogliere i log con l'issue in essere, in quanto purtroppo si presenta davvero in maniera randomica. Il disable del drs/HA potrebbe essere risolutivo come workaround nel senso che si impedirebbe di modificare la distribuzione delle macchine: evitando spostamenti si eviterebbe, forse, il ripresentarsi del problema. Tuttavia non è ovviamente applicabile in quanto andrebbe a disabilitare due funzioni cruciali per tutte le vm sugli host. Non ci sono evidenze di casi simili che possano in qualche modo indirizzare l'analisi e l'eventuale raccolta di ulteriori informazioni?

Grazie mille

Reply
0 Kudos
Alex_Romeo
Leadership
Leadership

Una prova che io farei è quella di rimuovere i vmware tools, ed installare quelli per la versione del tuo Esxi.

Qui puoi trovare le corrispoindenze:

https://vinfrastructure.it/2018/09/vmware-tools-version-in-vsphere-6-5-and-6-7/

verifica se poi hai avuto miglioramenti.

ARomeo

Blog: https://www.aleadmin.it/
Reply
0 Kudos