VMware Global Community
sasab
Contributor
Contributor
Jump to solution

Installazione di View Server

Ciao a tutti, è la prima volta che utlizzo vmware view e sto provando a fare una installazione su Windows 2003 R2 64bit ma mi ritrovo con un errore relativo ad LDAP.

Potreste darmi qualche aiuto in merito ?

Inoltre è indispensabile avere vcenter installato sulla macchina ?

Grazie.

-

Salvatore.

Tags (3)
Reply
0 Kudos
1 Solution

Accepted Solutions
Fab75
Enthusiast
Enthusiast
Jump to solution

Usa l'FQDN del server anzichè "localhost"

View solution in original post

Reply
0 Kudos
22 Replies
ldelloca
Virtuoso
Virtuoso
Jump to solution

Ciao,

l'errore è chiaro, la porta LDAP (tcp 389) è già in uso sul server e quindi ADAM non si puo' installare.

Non è che stai installando il View Connection Server su un Domain Controller??? Non si puo' fare, tra i vari motivi proprio perchè ldap è già in uso da Active Directory.

Ciao,
Luca.
--
Luca Dell'Oca
@dellock6
vExpert 2011
[Assegnare punti a una risposta utile è un modo di dire grazie]
Luca Dell'Oca | vExpert 2011-2012-2013-2014-2015-2016-2017, VCAP-DCD, CISSP #58353 | http://www.virtualtothecore.com | @dellock6 | http://www.linkedin.com/in/lucadelloca | If you find this post useful, please consider awarding points for "Correct" or "Helpful"
Reply
0 Kudos
sasab
Contributor
Contributor
Jump to solution

Ciao Luca e grazie per l'attenzione,

sulla macchina non sono attivi i servizi relativi ad AD in quanto non è un controller di dominio.

Però la porta risulta in uso, allego l'elenco dei servizi attivi.

Grazie.

-

Salvatore.

Reply
0 Kudos
ldelloca
Virtuoso
Virtuoso
Jump to solution

Cosi' pero' non vediamo quale processo usa quale porta.

Da cmd, netstat -nao, vedi la porta 389 da quale PID è occupata, e nel task manager verifichi quale processo corrisponde a quel pid.

Ciao,
Luca.
--
Luca Dell'Oca
@dellock6
vExpert 2011
[Assegnare punti a una risposta utile è un modo di dire grazie]
Luca Dell'Oca | vExpert 2011-2012-2013-2014-2015-2016-2017, VCAP-DCD, CISSP #58353 | http://www.virtualtothecore.com | @dellock6 | http://www.linkedin.com/in/lucadelloca | If you find this post useful, please consider awarding points for "Correct" or "Helpful"
sasab
Contributor
Contributor
Jump to solution

grazie per l'aiuto però non riesco comunque ad individuare il servizio che va ad usare la porta 389 e che andrebbe fermato per permettere l'installazione di view server, ti allego la situazione attuale.

grazie !

-

Salvatore.

Reply
0 Kudos
ldelloca
Virtuoso
Virtuoso
Jump to solution

Uhm, dsamain.exe stando a questo link:

http://technet.microsoft.com/en-us/library/cc753609%28WS.10%29.aspx

è un tool di microsoft stessa per fare i mount di database di AD in LADP, ovvero quello che fa ADAM !!!

Non sono ferratissimo su View, ma non è che magari è stata fatta una precedente installazione di ADAM?

Ciao,
Luca.
--
Luca Dell'Oca
@dellock6
vExpert 2011
[Assegnare punti a una risposta utile è un modo di dire grazie]
Luca Dell'Oca | vExpert 2011-2012-2013-2014-2015-2016-2017, VCAP-DCD, CISSP #58353 | http://www.virtualtothecore.com | @dellock6 | http://www.linkedin.com/in/lucadelloca | If you find this post useful, please consider awarding points for "Correct" or "Helpful"
Reply
0 Kudos
sasab
Contributor
Contributor
Jump to solution

no di sicuro non è stata fatta nessuna precedente installazione, è una macchina virtuale nuova che ho messo su proprio per provare view ! Smiley Sad

-

Salvatore.

Reply
0 Kudos
Fab75
Enthusiast
Enthusiast
Jump to solution

Forse avevi precedentemente installato vCenter su quella macchina? Il servizio VCMSDS che si vede nello screenshot è il servizio LDAP di vCenter (quel processo dsamain.exe che vedi in task manager). View installa un servizio con un nome diverso  (VmwareVDMDS) per i servizi LDAP.

Magari fai la controprova semplicemente stoppando quel servizio e vedendo se il setup va a buon fine.

Ricorda che View Manager dovrebbe stare su un server che non ospiti altri servizi (AD, Terminal, vCenter...)

sasab
Contributor
Contributor
Jump to solution

ho fermato il servizio e la porta 389 non risulta più in uso, ho rilanciato il setup ma l'errore che restituisce è lo stesso.

-

Salvatore.

Reply
0 Kudos
Fab75
Enthusiast
Enthusiast
Jump to solution

Ok, speravo funzionasse ma evidentemente il setup è più furbo 🙂

Mi confermi che avevi installato precedentemente un vCenter? Se sì devi cercare di rimuovere ciò che è stato lasciato dalla vecchia installazione riguardo ad ADAM/VCMSDS.

Reply
0 Kudos
ldelloca
Virtuoso
Virtuoso
Jump to solution

Prova a rimuovere qualsiasi programma che anche solo vagamente assomigli a questa cosa...

Oppure, dato che vedo è una VM, non è molto elegante come soluzione visto che non si capisce il perchè, ma fai un nuovo deploy di una VM liscia.

Ciao,
Luca.
--
Luca Dell'Oca
@dellock6
vExpert 2011
[Assegnare punti a una risposta utile è un modo di dire grazie]
Luca Dell'Oca | vExpert 2011-2012-2013-2014-2015-2016-2017, VCAP-DCD, CISSP #58353 | http://www.virtualtothecore.com | @dellock6 | http://www.linkedin.com/in/lucadelloca | If you find this post useful, please consider awarding points for "Correct" or "Helpful"
Reply
0 Kudos
sasab
Contributor
Contributor
Jump to solution

si avevo installato vcenter anche perchè ero convinto (a questo punto non a giusta ragione) che per usare View servisse vCenter e invece è proprio l'esatto contrario ! Smiley Sad

-

Salvatore.

Reply
0 Kudos
sasab
Contributor
Contributor
Jump to solution

seguirò la soluzione meno elegante !Smiley Wink

-

Salvatore.

Reply
0 Kudos
Fab75
Enthusiast
Enthusiast
Jump to solution

Faccio una precisazione: vCenter è necessario per poter utilizzare View, ma non devi averlo sulla stessa macchina dove installi il Connection Server.

Senza vCenter semplicemente non riesci a fare il deploy dei virtual desktop!

Reply
0 Kudos
sasab
Contributor
Contributor
Jump to solution

quindi per poter utilizzare view all'interno della struttura è indispensabile avere anche vCenter ?

grazie.

-

Salvatore.

Reply
0 Kudos
Fab75
Enthusiast
Enthusiast
Jump to solution

Si'.

Ti consiglio di dare un'occhiata alla guida "VMware View Architecture Planning", se vuoi farti un'idea di quali componenti servono e di come interagiscono fra di loro:

http://pubs.vmware.com/view-50/index.jsp?topic=/com.vmware.view.planning.doc/GUID-5CC0B95F-7B92-4C60...

ciao

Reply
0 Kudos
AndreTheGiant
Immortal
Immortal
Jump to solution

Il numero minimo di sistemi per usare View è:

- 1 host ESX/ESXi

- 1 AD DC (può essere in una VM) che può fare anche da DNS e DHCP (di fatto senza DHCP la configurazione dei pool diventa problematica)

- 1 vCenter (può essere in una VM) ma non può essere con il DC, né con il View Connection Server

- 1 View Connection Server (può essere in una VM)

- 1 virtual desktop XP, Vista o 7 (occhio alle matrici di compatibilità)

- 1 client

Andrew | http://about.me/amauro | http://vinfrastructure.it/ | @Andrea_Mauro
Reply
0 Kudos
sasab
Contributor
Contributor
Jump to solution

Ciao a tutti, un pò alla volta mi ci sto avvicinando grazie al vostro aiuto ! 🙂

Adesso ho un problema con l'accesso da view client dal mio pc, sul server dove è installato view server riesco ad accedere alla parte di amministrazione ma se provo dal mio (windows 7) inserendo le credenziali mi ritorna sempre il messaggio di errore che allego.

Perchè in locale mi fa accedere e dalla mia macchina no ??

Cosa posso verificare ? ho provato anche a disabilitare l'accesso ssl ma il risultato non cambia.

Grazie..e scusate per la domanda banale !

-

Salvatore.

Reply
0 Kudos
sasab
Contributor
Contributor
Jump to solution

per la preparazione di un desktop non mi serve null'altro ? faccio questa domanda in quanto attraverso view administrator (eseguito in locale sulla macchina dove ho installato view connection server) non trovo nessun posto dove poter 'creare' un dekstop per poi distribuirlo, ho necessità anche di altri componenti ?

grazie.

aggiornamento:

il dekstop che si vuole distribuire è in realtà una macchina virtuale creata all'interno di un host esx collegato a vnceter.

ero stato tratto in inganno pensando come pensa terminal server e che quindi la macchina fosse 'interna' a view server.

-

Salvatore.

Reply
0 Kudos
ldelloca
Virtuoso
Virtuoso
Jump to solution

Riguardo all'errore dello screenshot, hai effettuato l'entitlement (assegnazione) della VM a un gruppo/utente?

Consiglio, seguito questa dettagliatissima guida che Tommy Trogden ha realizzato, è fatta divinamente:

http://vtexan.com/2011/11/03/how-to-install-configure-and-deploy-vmware-view-5-on-vsphere-5/

Dentro questo post trovi i link hai successivi, se segui tutta la serie dovresti trovarti già a buon punto.

Ciao,

Luca.

--

Luca Dell'Oca

http://www.vuemuer.it

@dellock6

vExpert 2011

[Assegnare punti a una risposta utile è un modo di dire grazie]

Luca Dell'Oca | vExpert 2011-2012-2013-2014-2015-2016-2017, VCAP-DCD, CISSP #58353 | http://www.virtualtothecore.com | @dellock6 | http://www.linkedin.com/in/lucadelloca | If you find this post useful, please consider awarding points for "Correct" or "Helpful"
Reply
0 Kudos