giangifort
Contributor
Contributor

Errore nella creazione di un nuovo datastore

Jump to solution

Buonasera a tutti ho un problema nellla creazione di un nuovo datastore, mi spiego meglio:

Ho un server Dell ho un datastore dunzionante con delle macchine virtuali su VMWARE ESXI 7.0 avevo poi un altro datastore a cui dovevo aggiungere dei dischi per ampliarlo e che ne aveva uno rotto per cui ho distrutto l'array e ne ho ricreato uno nuovo il vecchio datastore era vuoto per cui non ho problema a sostituire il tutto ma ora quando provo a tirare su il nuovo data store mi restituisce questo errore Failed to create VMFS datastore

questo è quello che mi esce digitando il comando

ls -lha /vmfs/devices/disks/

total 3026576369
drwxr-xr-x 2 root root 512 Mar 16 06:57 .
drwxr-xr-x 16 root root 512 Mar 16 06:57 ..
-rw------- 1 root root 558.4G Mar 16 06:57 naa.64cd98f08089130026c42eb44853edbe
-rw------- 1 root root 100.0M Mar 16 06:57 naa.64cd98f08089130026c42eb44853edbe:1
-rw------- 1 root root 4.0G Mar 16 06:57 naa.64cd98f08089130026c42eb44853edbe:5
-rw------- 1 root root 4.0G Mar 16 06:57 naa.64cd98f08089130026c42eb44853edbe:6
-rw------- 1 root root 119.9G Mar 16 06:57 naa.64cd98f08089130026c42eb44853edbe:7
-rw------- 1 root root 430.4G Mar 16 06:57 naa.64cd98f08089130026c42eb44853edbe:8
-rw------- 1 root root 816.8G Mar 16 06:57 naa.64cd98f08089130027e2f6ecfbe45916
-rw------- 1 root root 952.9G Mar 16 06:57 naa.64cd98f08089130027e2f6ecfbe45916:2
lrwxrwxrwx 1 root root 36 Mar 16 06:57 vml.020000000064cd98f08089130026c42eb44853edbe504552432048 -> naa.64cd98f08089130026c42eb44853edbe
lrwxrwxrwx 1 root root 38 Mar 16 06:57 vml.020000000064cd98f08089130026c42eb44853edbe504552432048:1 -> naa.64cd98f08089130026c42eb44853edbe:1
lrwxrwxrwx 1 root root 38 Mar 16 06:57 vml.020000000064cd98f08089130026c42eb44853edbe504552432048:5 -> naa.64cd98f08089130026c42eb44853edbe:5
lrwxrwxrwx 1 root root 38 Mar 16 06:57 vml.020000000064cd98f08089130026c42eb44853edbe504552432048:6 -> naa.64cd98f08089130026c42eb44853edbe:6
lrwxrwxrwx 1 root root 38 Mar 16 06:57 vml.020000000064cd98f08089130026c42eb44853edbe504552432048:7 -> naa.64cd98f08089130026c42eb44853edbe:7
lrwxrwxrwx 1 root root 38 Mar 16 06:57 vml.020000000064cd98f08089130026c42eb44853edbe504552432048:8 -> naa.64cd98f08089130026c42eb44853edbe:8
lrwxrwxrwx 1 root root 36 Mar 16 06:57 vml.020000000064cd98f08089130027e2f6ecfbe45916504552432048 -> naa.64cd98f08089130027e2f6ecfbe45916
lrwxrwxrwx 1 root root 38 Mar 16 06:57 vml.020000000064cd98f08089130027e2f6ecfbe45916504552432048:2 -> naa.64cd98f08089130027e2f6ecfbe45916:2

al momento il datastore in uso è da 430 GB

qualche suggerimento

Grazie buonaserata

Labels (1)
0 Kudos
1 Solution

Accepted Solutions
giangifort
Contributor
Contributor

Fantastico è andata , ti ringrazio dei preziosi consigli

Buona serata

View solution in original post

0 Kudos
7 Replies
fabio1975
Expert
Expert

Ciao 

Dalle informazioni che hai dato è quindi un volume locale al server DELL (no storage esterno).

Se a livello Controller Raid è tutto a posto (RAID configurato e stato del volume ok), proverei a eseguire i comandi della seguente KB per verificare se il volume viene visto:

https://kb.vmware.com/s/article/1014953

 

E potrebbe essere utile avere l'output dei seguenti comandi 

esxcfg-mpath -b

esxcfg-scsidevs -c

Ciao 

 

 

 

 

Fabio
BLOG: https://vmvirtual.blog

if satisfied give me a kudos
0 Kudos
giangifort
Contributor
Contributor

questoè il primo comando

mpx.vmhba1:C0:T7:L0 : Local HL-DT-ST CD-ROM (mpx.vmhba1:C0:T7:L0)
vmhba1:C0:T7:L0 LUN:0 state:active Local HBA vmhba1 channel 0 target 7

naa.64cd98f08089130027e2f6ecfbe45916 : Local DELL Disk (naa.64cd98f08089130027e2f6ecfbe45916)
vmhba2:C2:T1:L0 LUN:0 state:active sas Adapter: 54cd98f080891300 Target: 60e2f6ecfbe45916

naa.64cd98f08089130026c42eb44853edbe : Local DELL Disk (naa.64cd98f08089130026c42eb44853edbe)
vmhba2:C2:T0:L0 LUN:0 state:active sas Adapter: 54cd98f080891300 Target: 60c42eb44853edbe

questo è il secondo

Device UID Device Type Console Device Size Multipath PluginDisplay Name
mpx.vmhba1:C0:T7:L0 CD-ROM /vmfs/devices/cdrom/mpx.vmhba1:C0:T7:L0 0MB NMP Local HL-DT-ST CD-ROM (mpx.vmhba1:C0:T7:L0)
naa.64cd98f08089130026c42eb44853edbe Direct-Access /vmfs/devices/disks/naa.64cd98f08089130026c42eb44853edbe 571776MB NMP Local DELL Disk (naa.64cd98f08089130026c42eb44853edbe)
naa.64cd98f08089130027e2f6ecfbe45916 Direct-Access /vmfs/devices/disks/naa.64cd98f08089130027e2f6ecfbe45916 836352MB NMP Local DELL Disk (naa.64cd98f08089130027e2f6ecfbe45916)

Ci tengo a precisare come si è verificato il problemema praticamente io ho rimosso un array senza prima rimuovere il datastore quindi il datastore che compare con dimensioni di 836 Gb è rimasto appeso ma ora non c'è quindi mi serve un comando che mi consenta di rimuoverlo dalla lista

Grazie

0 Kudos
fabio1975
Expert
Expert

Ciao 

Potrebbe esserte utile questo comando

esxcli storage core device detached remove -d <identificativo del volume da rimuovere> 

identificativo del volume e' naa.xxxxxxxxxxxx

Qui alcuni link dove se ne parla 

How to remove unmounted/inaccessible datastore from ESXi Host (tomaskalabis.com)

Detach a Device and Remove a LUN (vmware.com)

Ovviamente ti consiglio di avere un backup delle VM per scrupolo 🙂

 

 

Fabio
BLOG: https://vmvirtual.blog

if satisfied give me a kudos
0 Kudos
giangifort
Contributor
Contributor

Ti ringrazio per i tuoi consigli ma la cacellazzione non avviene non mi viene restituito nessun errore ma se rilancio lo scan dei dischi appare sempre in lista quello che non c'e' più e non mi permette di crearne uno nuovo.. :((

0 Kudos
fabio1975
Expert
Expert

A questo punto  io proverei a:

1 - Distruggere, a livello di controller raid, il Volume che avevi creato  e che l'Host ESXi  non vede (o vede ancora ridotto) 

2 - Una volta eliminato dal controller RAID  fare  un riavvio dell'host  (senza aver creato un nuovo volume)

3 - Una volta fatto il riavvio se vede ancora il vecchio volume (non dovrebbe vederlo +)  proverei a rilanciare il comando di eliminazione che ti ho girato in precedenza. 

4- Se abbiamo definitivamente eliminato il volume creare quello nuovo dal controller raid

 

Ciao 

Fabio 

Fabio
BLOG: https://vmvirtual.blog

if satisfied give me a kudos
0 Kudos
giangifort
Contributor
Contributor

Fantastico è andata , ti ringrazio dei preziosi consigli

Buona serata

View solution in original post

0 Kudos
fabio1975
Expert
Expert

Ottimo! 

Ricordati di mettere che la soluzione e' corretta e se vuoi anch mettermi un Kudos.

Ciao e Buon lavoro

Fabio
BLOG: https://vmvirtual.blog

if satisfied give me a kudos